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Chapter 1

Introduction

1.1 Opening Remarks

Meteo-40 plus data loggers by Ammonit Measurement GmbH are professional measuring devices which record me-
teorological details in order to calculate the wind energy potential of a site. The data loggers can be used flexibly and
are well-suited for a wide range of applications. The implemented standards of measurement evaluation and data
security meet the requirements of professional specialists. However, you conveniently configure sensors, statistics
and the communication via the user-friendly web interface.

Before installation read this manual carefully. Remember that time spent now setting up the data logger properly might
save you from losing valuable data!

We recommend to configure and to test sensors and communication before the measuring equipment is installed on
the mast.

We hope you find this manual clear and easy to understand. If you have any comments or suggestions, please let us
know.

1.2 Overview of Meteo-40 plus

Depending on the model, Meteo-40 plus offers up to 34 measurement channels: There are up to 12 analog differential
voltage inputs, up to 2 analog current inputs. Furthermore, Meteo-40 plus has up to 12 counter inputs and up to 8
digital channels.

In addition, Meteo-40 plus is able to support up to 8 smart sensors via the RS485 interface.

In general, Meteo-40 plus is divided into two main units: A communication unit and a measuring unit. The communi-
cation unit offers 3 USB slots to connect a PC, modem, web camera, or flash drive, and 1 Ethernet slot to connect a
camera or router. Additionally, the Meteo-40 plus can be connected to the network via Ethernet.

Note
Meteo-40 plus Revision C offers a standard RS232 slot. Meteo-40 Revision D is equipped with an Ethernet
slot. The production of Meteo-40 plus Revision C stopped in October 2012. Revision C is not supported
anymore and cannot be upgraded to version 2 or higher.

The basic concept is shown in detail in Figure 1.1.

Picture of Meteo-40L with Caption

Figure 1.1: Overview of Meteo-40L
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1.3 Meteo-40 plus Series

The Meteo-40 plus series differs mainly in the number of input and output channels and in the measurement data
storage capacity. Some basic information about the different models (Meteo-40S, Meteo-40M, Meteo-40L, and Meteo-
40A) are shown in Table 1.1.

Feature Meteo-40S Meteo-40M Meteo-40L Meteo-40A

Input
channels

Counters 4 8 12 2
Periods 0 2 4 0
Digital 2 4 8 4
Analog (U) 4 8 12 12
Analog (I) 1 1 2 2
RS485 Up to 8 sensors

Output
channels

Switches 2 4 8 4
Constant
Current 1 1 2 2

RS485 1 for SCADA

Memory Size
Source Data 1 GiB 2 GiB 2 GiB 1 GiB
CSV Data > 50 MiB

Connectivity
USB 2 USB host, 1 USB device
Ethernet 1 for router, LAN

Display and keys LC display with backlight (4 lines each with 20 characters), five
keys

Power supply 9 - 36 V (DC)

Table 1.1: Meteo-40 plus feature overview

Note
The predecessor of the current Meteo-40 plus Revision D, Revision C, is equipped with a standard RS232
slot instead of the Ethernet slot.

Find below an overview of the terminals. The white areas indicate available connectors.

Figure 1.2: Meteo-40L Terminal

2 © 2011 — 2023 Ammonit Measurement GmbH



Data Logger Meteo-40 Plus User’s Manual 3 / 258

Figure 1.3: Meteo-40M Terminal

Figure 1.4: Meteo-40S Terminal
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Figure 1.5: Meteo-40A Terminal

1.4 The Two Systems of Meteo-40 plus

Meteo-40 plus consists of two basic systems: theMeasurement And Recording System (MARS) and theConfiguration,
Evaluation and Communication System (CECS).

For measuring and recording data, only MARS is needed. MARS is a 8-bit microcontoller designed to work with
minimal power consumption. It controls the analog data logger hardware, measurement channels and data storage.
It has no access to the display or to the devices that could be connected via USB or Ethernet (RS232 for Meteo-40
plus Revision C).

In order to use connected devices and to operate the display or the web interface, CECS has to be started. CECS is
a fully operational embedded Linux™ computer with a 32-bit microcontroller. Starting it activates all Meteo-40 plus’s
features, but increases power consumption.

To save power during a measurement campaign, CECS is usually powered down and only MARS is running. MARS
starts, when the power connector is plugged in.

The booting process of the MARS software is indicated by the illumination of the two lower LEDs (red and yellow).
Both LEDs will turn off, when the MARS is started successfully.

CECS can be started either manually or automatically. Tomanually start CECS, press themiddle button of the keyboard
and hold it until the display turns on. A manual start of CECS is necessary for the initial configuration of Meteo-40
plus.

Later on, during a measurement campaign, CECS will be started by MARS according to the configured time schedule,
e.g. to upload measurement data. After the scheduled actions have been executed, CECS turns off automatically to
reduce power consumption.
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Meteo-40

CECS - Configuration, Evaluation, and Communication System

MARS - Measurement And Recording System

LC Display Keys

System Storage
for software

and statistics
(CSV files)

USB-A

Ethernet*

USB-B

RS485 server

e.g. USB modem

e.g. PC, LAN, router,
SCADA client, or modem

PC

SCADA client

read data

write data

Source Data Storage Power System Power Supplyconfiguration

Real-Time Clock (RTC),
battery buffered

RS485 client RS485 sensors

Switches e.g. Relais

Measurement Inputs Analog and digital sensors

Current Sources e.g. PT1000

*RS232 on older Meteo-40

Figure 1.6: Block diagram of Meteo-40 plus

1.4.1 CECS: Switch on / off behavior

CECS is configured to run for 20 minutes, before it automatically turns off. When the time is expired and an action is
still running, e.g. sending an email, the system will wait until the action is finished and will switch off afterwards. The
remaining time is displayed in the status box (see Section 3.2) of the Meteo-40 plus web interface.
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Note
With every user action, e.g. navigating the web interface or pressing a button on the keyboard, the remaining
time will be reset to 20 minutes.

For SCADA operation, CECS has to run permanently. This is possible by means of the CECS always active mode. If
CECS always active mode is selected, it will be displayed in the status box (see Section 3.2) in the web interface with
the infinity symbol (∞) as well as on the Meteo-40 plus display with the word Always.

Note
The CECS always active mode is not selected by default. If the SCADA server is activated, the CECS
always active mode is automatically set.

If power supply is disconnected and the data logger shuts down while CECS was running in the CECS always active
mode, it will start automatically as soon as power is available again.

Important
When CECS is configured to be permanently on, you cannot manually shut down the system by pressing
the middle button on the data logger.

1.5 Data Storage

CECS and MARS both have access to the measurement data storage, referred to as the shared source data memory.
It is possible to view or download the source data via the web interface, see Section 6.7.

Note
For optimal data recording, it is recommended to format the data storage before starting a new measure-
ment campaign. Formatting is a very fast process, which only takes a few seconds and can be performed
via the web interface under the System→ Administration menu. For further details see Section 4.2.

1.6 User Interfaces

There are two ways to control and configure the data logger: via web interface or by using the buttons of Meteo-40
plus. The second method is only intended for checking and testing, since this control menu provides only a limited
number of configuration options. However, the web interface offers all available setup options and is recommended
for the configuration of the device. To use the web interface a TCP/IP or USB connection is required.

Thanks to its web interface, Meteo-40 plus can also be operated via Internet with mobile devices, e.g. smartphone or
tablet PC.

Important
The Meteo-40 plus web interface is accessed via HTTPS connection, which uses high-grade encryption
(AES-256, 256 bit). This connection cannot be decrypted using today’s technologies.
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1.7 Communication Methods and Required Devices

Depending on the project, Meteo-40 plus offers various methods for communication and data retrieval. All available
methods are commonly used as well as easy to handle and to configure. In order to set up the connection to Meteo-40
plus, devices like Ethernet cable or modem are necessary as shown in the following table.

Method /
Action Configuration Software

Update
Data
Download

Required
Devices Comment

Meteo-40
plus
(stand-alone)

no (only a
few settings
can be
changed)

no no -
Using the display (see
Section 4.4.1 and
Chapter 9).

USB flash
drive
(connected
to data
logger)

no no yes USB flash
drive

Manual data download on
pre-configured USB flash
drive (see Section 4.2).

LAN (data
logger
connected to
LAN)

yes
yes (Internet
access
required)

yes (Data
transfer via
email,
SCP/FTP/S-
FTP/FTPS,
AmmonitOR
or manual
data
download via
web
interface)

Ethernet
cable

Recommended for initial
configuration and software
updates (see Section 2.3).

WLAN (PC,
laptop etc.
connected to
data logger’s
WLAN)

yes no

yes
(Download
via web
interface)

USB WLAN
dongle

Recommended on site for
maintenance (see
Section 7.8).

Point-to-
Point
Ethernet
(data logger
connected to
PC)

yes no

yes
(Download
via web
interface)

Ethernet
cable

PC has to be configured
(see Section 2.4).

USB (data
logger
connected to
PC)

yes no

yes
(Download
via web
interface)

USB (A/B)
cable

Backup access. Driver file
might be required (see
Section 2.5).

USB (data
logger
connected to
smartphone)

yes

yes, tethering
function of
the
smartphone
needs to be
activated

yes
(Download
via web
interface)

USB cable of
the
smartphone
(accessory)

Convenient for remote
servicing or software
upgrades, when no
modem is installed.

Modem
access (data
logger
connected to
modem, e.g.
GPRS/GSM,
directional
radio,
satellite)

yes
yes (Internet
access
required)

yes (Data
transfer via
email,
SCP/FTP/S-
FTP/FTPS,
AmmonitOR
or manual
data
download via
web
interface)

Modem and
accessory
cable

Thanks to
AmmonitConnect a
standard SIM card can be
used in a GSM modem. A
SIM card with a static IP
address is not necessary.
(see Section 7.9).
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Method /
Action Configuration Software

Update
Data
Download

Required
Devices Comment

SCADA over
RS485
(Modbus
RTU)

no no yes (Modbus
protocol) -

Modbus register map has
to be configured for data
retrieval (see Section 8.1).

SCADA over
Ethernet
(Modbus
TCP/IP)

no no yes (Modbus
protocol) -

Modbus register map has
to be configured for data
retrieval (see Section 8.1).

Note
If you are working with a Meteo-40 plus Revision C with RS232 slot, you need an USB Ethernet adapter
to connect the data logger to your LAN. The production of Meteo-40 plus Revision C stopped in October
2012.
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Chapter 2

Getting Started with Meteo-40 plus

2.1 Introduction

Before you start working with Meteo-40 plus, connect the data logger to the power supply. The moment Meteo-40
plus is connected to the power supply, the lower LED lights turn on and indicate that the Measurement And Recording
System (MARS) is booting. Both LEDs turn off, when MARS has successfully started and is running. To access the
web interface, the second system Configuration, Evaluation and Communication System (CECS) has to be started.
Press the middle button of Meteo-40 plus and hold it until the display turns on (see Section 1.4).

In order to access the web interface, it is necessary to establish a TCP/IP connection between the host PC and
Meteo-40 plus. There are multiple ways to create this connection:

1. Ethernet with DHCP: If you connect the data logger to your LAN using an Ethernet cable (see Section 2.3) and
DHCP (Dynamic Host Configuration Protocol), any other device in the LAN (e.g. your PC) will have access to
the web interface of the data logger, as long as the CECS is running.
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LAN connection between Data Logger and PC

Ethernet cable

Ethernet
port

Ethernet
port

Local Area Network (LAN)
with DHCP Server

Ethernet or
WLAN connection

Figure 2.1: Accessing Meteo-40 plus via LAN (see Section 2.3)

2. Ethernet with link-local or static IP: Here, only a point-to-point connection between the data logger and
the PC is established (see Section 2.4). The link-local method is recommended.

Point-to-point Ethernet connection between Data Logger and PC

Ethernet cable

Ethernet
port

Ethernet
port

Figure 2.2: Accessing Meteo-40 plus via Point-to-Point Ethernet Connection (see Section 2.4)

3. USB: There are two options, either with a USB 2.0 A to B cable (The same type of cable is typically used to
connect a USB printer to a PC) or with a micro-USB cable and activated USB tethering (see Section 2.5).
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USB Connection between Data Logger and PC or Mobile Phone

USB A/B cable

Micro USB cable

USB B
port

USB A
port

USB A
port

Micro
USB B
port

Figure 2.3: Accessing Meteo-40 plus via USB-B (see Section 2.5)

Important
If you establish a connection via USB, a driver file might be needed for Windows PCs. The driver
file can be downloaded from download.windowsupdate.com (http://download.windowsupda
te.com/msdownload/update/driver/drvs/2012/12/20342322_4b9970e3174b23b5cb
2371af0837f939a71271ea.cab). For further details refer to Section 2.5.

Note
If you are working with Meteo-40 plus Revision C with RS232 slot, you need an USB Ethernet adapter to
connect the data logger to your LAN or via Ethernet to your PC (Point-to-Point). The production of Meteo-40
plus Revision C stopped in October 2012.

Note
After having configured Meteo-40 plus for WLAN, the data logger web interface can also be accessed by
using a WLAN USB dongle (see Section 7.8).

Picture of Ethernet / USB ports of Meteo-40L

Figure 2.4: Ethernet / USB ports of Meteo-40L

Tip
We recommend connecting Meteo-40 plus via Ethernet to your LAN. It is the easiest method, no additional
driver file is needed and updates can be performed immediately.

2.2 Using Bonjour™ on Windows™

For Windows Vista™ and later versions, this procedure can be simplified by installing the software Bonjour Print
Services for Windows from Apple (http://support.apple.com/kb/DL999). It provides automatic resolution
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of computer host names and the data logger can be accessed via its serial number. Unfortunately, our tests have
revealed that this software can cause problems when installed on Windows XP.

After the installation of Bonjour Print Services just type the serial number as follows in your web browser https://Dnnnnnn.local
with Dnnnnnn as your data loggers serial number. The untrusted connection alert page will appear and should be
accepted as described in Section 2.5.1.

URL:	https://d001234.local/

Meteo-40	plus	D001234

Username:

Password:

Show	password

Low	traffic	mode

Login

中文(简) 	 English 	 Español 	 Português 	 Français 	 Deutsch 	 日本 ©	2011-2023	Ammonit	Measurement	GmbH
www.ammonit.com

Figure 2.5: Meteo-40 plus web interface initial screen

2.3 Connecting Meteo-40 plus via Ethernet to your LAN

In order to connect Meteo-40 plus with your PC via Ethernet, both devices have to be connected to your local network.
Your PC should be connected via LAN or WLAN to your network. To connect Meteo-40 plus to the network, a standard
Ethernet cable is needed. If you have only one Ethernet port in your office, use a switch or a hub to multiply the
available Ethernet ports. See Figure 2.1.

Note
If you are working with Meteo-40 plus Revision C with RS232 slot, you need an USB Ethernet adapter to
connect the data logger to the LAN. Connect the USB side of the adapter to the data logger and plug in the
Ethernet cable on the other side. The production of Meteo-40 plus Revision C stopped in October 2012.

To see that Meteo-40 plus has been connected successfully, use the buttons on the data logger to navigate through the
menu. In the Communication→ Devices→ LAN menu you can find a list of connections, which displays all available
connections. If eth Activated is displayed, the connection has been successfully established.

By opening this menu item (click on the right button of the data logger keyboard), you can browse for the connection
properties such as IP address, which was automatically assigned to the data logger by DHCP server. To access the
web interface, start your web browser. Enter https:// and the IP address shown in the data logger display, e.g.
https://192.168.12.30.

Tip
We recommend using Mozilla Firefox (http://www.mozilla.com/) as your web browser to access
Meteo-40 plus. Other modern web browsers, including mobile web browsers, should work as well, but are
not systematically tested by Ammonit.
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After entering the address in your web browser, a confirmation prompt may appear. Click I understand the risks and
press Add Exception.

Figure 2.6: Firefox Connection Untrusted alert page

In the next step download the certificate by clicking on Get Certificate and Confirm Security Exception to access the
Meteo-40 plus web interface. In order to save the exception Permanently store this exception should be checked.

Figure 2.7: Add Security Exception

Important
In order to prevent misuse of the certificate, Ammonit deliberately did not store the security certificate on
each data logger. After downloading the certificate, its validity can be verified.
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URL:	https://192.168.43.21/

Meteo-40	plus	D001234

Username:

Password:

Show	password

Low	traffic	mode

Login

中文(简) 	 English 	 Español 	 Português 	 Français 	 Deutsch 	 日本 ©	2011-2023	Ammonit	Measurement	GmbH
www.ammonit.com

Figure 2.8: Meteo-40 plus web interface initial screen

Important
In order to use all functions of the web interface, activate JavaScript and Cookies in your web browser!

Go to Chapter 3 to proceed with the configuration.

2.4 Connecting Meteo-40 plus to your Windows 10™ PC via point-
to-point Ethernet connection

In order to connect Meteo-40 plus with your Windows 7™ PC, an Ethernet cable is required. No additional driver file
is needed for a direct point-to-point connection via Ethernet. See Figure 2.2.

Note
If you are working with Meteo-40 plus Revision C with RS232 slot, you need an USB Ethernet adapter to
connect the data logger via point-to-point Ethernet connection to your PC. Connect the USB side of the
adapter to the data logger and plug in the Ethernet cable on the other side. The production of Meteo-40
plus Revision C stopped in 2012.

Before you connect the devices, Meteo-40 plus has to be configured to use either a link-local connection or a static IP
address. The former is much easier to use, because it does not involve any manual configuration of the PC, if it has
the standard configuration of obtaining an IP address automatically.

2.4.1 Using link-local connection

To use a link-local address, you have to make sure your PC is configured to obtain an IP address automatically. In
most cases, this is already be the case.

In the next step Meteo-40 plus has to be configured for the link-local Ethernet connection. Open the Communication
→ Devices→ LAN menu and select eth0. Move toMethod and press the right button on the Meteo-40 plus keyboard.
The > symbol should now change to >>. Now, you can select Link-local by pressing the up or down button. When
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you are done, press the left button. Figure 2.9. Note that DHCP is configured by default to support standard LAN (see
Section 2.3) connection via Ethernet.

IP / Netmask
DNS Servers
Routes

> Method: Link-local

Figure 2.9: Meteo-40 plus display with activated link-local connection

Open your browser, e.g. Mozilla Firefox. When you are using a Mac or a Linux computer, or when you have installed
Bonjour on a Windows PC, you can just enter https://Dnnnnnn.local in the URL field of your web browser.

Otherwise, look up the IP number in the menu and enter the number as follows https://169.254.nnn.nnn as
URL. For link-local connection, IP addresses start always with 169.254., while the remaining numbers are random
and change every time.

2.4.2 Using static IP address

To use a static IP address, you need to configure both, your PC and the Meteo-40 plus. To configure the PC, open the
Network and Sharing Center in the Control Panel of your computer and click on LAN Connection (see Figure 2.10).
In most cases, the link-local connection Section 2.4.1 is preferable.

Figure 2.10: Network and Sharing Center of Windows 7™

To configure the LAN connection, click on Properties (Figure 2.11) in the LAN Connection Status window.
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Figure 2.11: LAN Connection Status

Select Internet Protocol Version 4 (TCP/IPv4) and open the Properties of the Internet protocol as shown in Figure 2.12

Figure 2.12: Properties of LAN Connection

Choose Use the following IP address and enter the following IP address 192.168.40.1 as shown in Figure 2.13. By
pressing the TAB button the Subnet mask will be filled automatically. Save the configuration with OK.

Important
If you do not have the rights to configure the settings, contact your system administrator.
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Figure 2.13: Properties of Internet Protocol

After having configured the LAN connection, connect your PC with your Meteo-40 plus using a standard Ethernet cable
and switch on your Meteo-40 plus by pressing the middle button of the keyboard.

In the next step the Meteo-40 plus has to be configured for the static IP point-to-point Ethernet connection. Open the
Communication→ Devices→ LAN→ Ethernet menu and select Ethernet (Offline). Move to Method and press the
right button and afterwards the up and down buttons on the Meteo-40 plus keyboard until Static IP is displayed.

IP / Netmask
DNS Servers
Routes

> Method: Link-local

Figure 2.14: Meteo-40 plus display with activated link-local connection

Open your browser, e.g. Mozilla Firefox. When you are using a Mac or a Linux computer, or when you have installed
Bonjour on a Windows PC, you can just enter https://Dnnnnnn.local in the URL field of your web browser.

Otherwise, just enter https://192.168.40.40, where 192.168.40.40 is the preconfigured IP address of each
Meteo-40 plus data logger.

Afterwards a confirmation prompt appears. Click I understand the risks and press Add Exception as shown in Fig-
ure 2.15.
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Figure 2.15: Mozilla Firefox Connection Untrusted Alert Page

In the next step download the certificate by clicking on Get Certificate and Confirm Security Exception to access the
Meteo-40 plus web interface. In order to save the exception, Permanently store this exception should be checked.

Figure 2.16: Add Security Exception

After confirming the certificate, theMeteo-40 plus login page is shown. Use your login details (Meteo-40 plus certificate)
to enter the web interface. To proceed with the configuration, go to Chapter 3.
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URL:	https://192.168.40.40/

Meteo-40	plus	D001234

Username:

Password:

Show	password

Low	traffic	mode

Login

中文(简) 	 English 	 Español 	 Português 	 Français 	 Deutsch 	 日本 ©	2011-2023	Ammonit	Measurement	GmbH
www.ammonit.com

Figure 2.17: Meteo-40 plus web interface initial screen

Tip
By using this point-to-point connection (without Internet access), the modem connection can be tested, e.g.
sending emails via modem.

Note
Do not forget resetting the LAN configuration on your PC (Internet protocol properties) and enabling DHCP
on Meteo-40 plus (if needed).

2.5 Connecting Meteo-40 plus with your Windows 10™ PC via USB

Meteo-40 plus requires a standard RNDIS USB driver. You can download it from download.windowsupdate.com
(http://download.windowsupdate.com/msdownload/update/driver/drvs/2012/12/20342322_4b99
70e3174b23b5cb2371af0837f939a71271ea.cab).

Tip
You can also connect Meteo-40 plus to your tablet PC or smartphone by using a micro USB cable as shown
in Figure 2.3. In doing so, you can easily connect to the data logger for maintenance reasons in the field or
for performing updates using the tethering function of your mobile device (see also Section 4.3.1).

2.5.1 Standard RNDIS USB Driver

Unpack the file 20342322_4b9970e3174b23b5cb2371af0837f939a71271ea.cab, downloaded from down-
load.windowsupdate.com (http://download.windowsupdate.com/msdownload/update/driver/drvs/2
012/12/20342322_4b9970e3174b23b5cb2371af0837f939a71271ea.cab) by double-clicking on the file icon,
then mark both contents, right-click and select then Extract....
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Figure 2.18: Unpack Windows Driver Software

Now you have two files, rndis.cat (Security Catalogue) and RNDIS.inf (Setup Information). The former is the
digital signature by Microsoft, the latter is the actual device driver file.

Figure 2.19: Select Installation of RNDIS Driver

You probably get the following security warning, which you need to confirm by clicking on Open:
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Figure 2.20: Confirm Security Warning

Finally, confirm the success dialog, by clicking on OK:

Figure 2.21: Confirm Operation Successful

The local connection can be established now by pluging in the USB cable. An IP address is automatically assigned
to the data logger, which can be found on its display in the menu Communication→ Devices→ LAN→ USB under
IP/Netmask. To start using Meteo-40 plus, type the address in your web browser, e.g. https://169.254.12.25/.
The address always starts with 169.254, the remaining part is random.
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Tip
We recommend using Mozilla Firefox (http://www.mozilla.com/) as your web browser to access
Meteo-40 plus. Other modern web browsers, including mobile web browsers, should work as well, but are
not systematically tested by Ammonit.

Important
In order to use all functions of the web interface, activate JavaScript and Cookies in your web browser!

After entering the address in your web browser, a confirmation prompt may appear. Click I understand the risks and
press Add Exception.

Figure 2.22: Firefox Connection Untrusted alert page

In the next step download the certificate by clicking on Get Certificate and Confirm Security Exception to access the
Meteo-40 plus web interface. In order to save the exception, Permanently store this exception should be checked.
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Figure 2.23: Add Security Exception

Important
In order to prevent misuse of the certificate, Ammonit deliberately did not store the security certificate on
each data logger. After downloading the certificate, its validity can be verified.

URL:	https://169.254.43.21/

Meteo-40	plus	D001234

Username:

Password:

Show	password

Low	traffic	mode

Login

中文(简) 	 English 	 Español 	 Português 	 Français 	 Deutsch 	 日本 ©	2011-2023	Ammonit	Measurement	GmbH
www.ammonit.com

Figure 2.24: Meteo-40 plus web interface initial screen

2.6 Using Meteo-40 plus with Linux

Recommended is any up-to-date Linux distribution with installed Network Manager (http://projects.gnome.o
rg/NetworkManager/). Configure the RNDIS/Ethernet Gadget to use link-local and connect the Meteo-40 plus with
the PC. You should be able to access the Meteo-40 plus with your web browser now.
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Chapter 3

Login at Meteo-40 plus

3.1 Login Options

Once you access the login page of the data logger over the web interface, you may log into one of four accounts,
which have different access rights: Guest, Viewer, User or Admin.

URL:	https://d001234.local/

Meteo-40	plus	D001234

Username:

Password:

Show	password

Low	traffic	mode

Login

中文(简) 	 English 	 Español 	 Português 	 Français 	 Deutsch 	 日本 ©	2011-2023	Ammonit	Measurement	GmbH
www.ammonit.com

Figure 3.1: Login Screen

The original access password for each account is enclosed in the data logger’s delivery. The passwords are unique
for each Meteo-40 plus. All passwords can be changed by an Admin user. Admin users can also create, edit and
delete other accounts. (see User Management: in Section 4.2).

Warning
Be careful if you change the password for the Admin account. A forgotten Admin password cannot be
recovered. The data logger must be returned to Ammonit to restore the original password.
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Account Permissions

Guest
• Look at all configuration pages
• Look at live data

Viewer
• All of the above
• Download measurement data

User

• All of the above
• Configure the data logger
• See and change communication and
encryption passwords

Admin

• All of the above
• Change the name of the data logger
• Upgrade the data logger software
• Change all users access passwords

Table 3.1: Accounts and permissions

The Meteo-40 plus web interface is available in seven languages: Chinese, English, French, German, Portuguese,
Spanish and Japanese.

There is a ”Low traffic mode” checkbox which will prevent parts of the page from being updated asynchronously. It is
particularly recommended when using BGAN satellite modems.

Important
In order to use all functions of the web interface, activate JavaScript and Cookies in our web browser!

After login, two links are shown in the upper right corner:

Help Access online help.

Logout Close the session, when access to the data logger is no longer needed.

Under these links the account you are logged into (Guest, Viewer, User or Admin) is shown, followed by the serial
number of the data logger.

Warning
Be aware that due to security reasons it is not possible to reset the access passwords. Furthermore, if you
change the Admin password and forget it, there is no way to recover it, not even for Ammonit. In this case,
you have to send the data logger to Ammonit, so that we can restore the original passwords.

3.2 Global Control Elements

A Status Box is shown in the upper left corner of the Meteo-40 plus web interface. It always shows the most important
information and control options.
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Recording: On Switch	off

Configuration: Saved Save

Connection:
MODEM,	Ethernet,
AmmonitConnect⁺

Remaining: ∞	(3)

Date/time: 2023-08-11	16:07:07	UTC

Figure 3.2: Meteo-40 plus Status Box with Recording Enabled

Recording: Off Switch	on

Configuration: Unsaved Save

Connection: USB

Remaining: 12:34

Date/time: 2023-08-11	16:07:11	UTC

Figure 3.3: Meteo-40 plus Status Box with Recording Disabled

The Status Box displays whether Meteo-40 plus is recording data and whether the current configuration is saved. You
can switch on or off recording here and save the configuration after having made any changes.

Note
If you switch Recording on, the Configuration will be saved automatically.

Important
If you switch Recording off, no measurement data will be saved to memory and no live data will be shown.
If Configuration is not saved, you have changed the configuration and the old configuration is active.
You must save the configuration to use the new configuration permanently. If you do not save the configu-
ration, your settings will be lost after disconnecting the power supply!

The Meteo-40 plus Status Box displays the current established connections (Connection), e.g. AmmonitConnect via
modem or using Ethernet directly in a LAN. The available connection modes are USB, Ethernet and Modem. If the data
logger is available through the tunnel, it will be shown as AmmonitConnect in the connections list. If maintenance
access is enabled, there will be a superscript plus (�) after AmmonitConnect. The current preferred connection for
the Internet access is written in capital letters.

Additionally, the web interface informs about the remaining time until shut down or whether CECS is configured to run
permanently (Remaining). In brackets the number of running actions are displayed, e.g. online access or upload of
CSV file.

Figure 3.2 shows a Meteo-40 plus with recording on and configuration saved which has a primary modem connection
and a secondary ethernet connection (e.g. for SCADA via Modbus TCP). CECS is always on and three actions are
running.

Figure 3.3 shows a Meteo-40 plus with recording off and configuration unsaved which is connected by USB-B. CECS
will remain on for 12 minutes and 34 seconds without further interaction and no actions are running.

3.3 Menu of the Web Interface

The menu of the Meteo-40 plus web interface consists of four main menu items: System, Measurement, Evaluation
and Communication. Each menu item is explained in the following chapters (See Chapter 4 to Chapter 7).
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Menu Submenu Item

System

Information
Administration
Upgrade
Device
Camera
Switches
Logbook

Measurement
Sensors
Channels
Evaluation

Data

Live
Statistics
Gusts
Source

Communication

Schedule
Online
AmmonitOR
Email
Remote Copy
SCADA
LAN
WLAN
Modem

Table 3.2: Menu of the Web Interface

28 © 2011 — 2023 Ammonit Measurement GmbH



Data Logger Meteo-40 Plus User’s Manual 29 / 258

Chapter 4

System Configuration

4.1 System Information

This page gives an overview of important system properties, such as data logger type, serial number, availablememory,
software versions and number of channels.
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URL:	https://d001234.local/system/information/

Help Logout
Admin	on	D001234

Recording: Off Switch	on

Configuration: Saved Save

Connection: Ethernet

Remaining: ∞

Date/time: 2023-08-11	16:02:19	UTC

System	Information

Data	logger	type Meteo-40L	plus

Serial	number D001234

Number	of
channels

12	analog	voltage,	12	counters,	2	analog	current,	2	current	sources,

8	digital,	8	switches,	8	RS485,	4	period	measurement

Active	input
channels

none

Installed	sensors none

Data	logger
location

13.43479,	52.50176	@	36.5	m

RAM Total:	7522	MiB,	Used:	3537	MiB,	Available:	3345	MiB

Source	data
storage

0.49	MiB	(0.00%	used,	current	page-id:	0)	---

System	storage
Total:	237791.37	MiB,	Used:	218241.58	MiB,	Free:	19549.79	MiB,	Type:

[68,0]

Number	of
statistics	files

3

Uptime CECS:	6:59:18,	MARS:	0:00:09

Software	version 2.1.14	(2023-08-01)

Bootloader
version

DEMO

Production	date 2023-08-02	15:17:50

AmmonitOR ABCD

Signing/encryption signing

SCADA Modbus	TCP

Current
connections

none

Metering unknown

No	file	selectedChoose	File

Upload	configuration	file
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Meteo-40

System

Information

Administration

Upgrade

Device

Camera

Switches

Logbook

Measurement

Sensors

Channels

Evaluation

Data

Live

Statistics

Gusts

Source

Communication

Schedule

Online

AmmonitOR

Email

Remote	Copy

SCADA

LAN

WLAN

Modem

Download	current	configuration

Figure 4.1: System Information Page

RAM shows the total Random-access memory available to the CECS, how much of it is used and how much is free
for system processes. If the free RAM is low (indicated in red), the CECS should be restarted.

Source data storage shows the amount of memory which is already in use for storing source data. Please note that
more than 100% is possible. A value beyond 100% means that the data logger is overwriting the oldest source data
by storing new data. e.g. 110% means that the oldest 10% has been overwritten.

Metering shows the amount of traffic used by each network interface since the last reset (see Section 4.2).

Under Current connections all current logins are displayed with IP address, e.g. via LAN, link-local USB or W-LAN
(WiFi). Connections estabilished via AmmonitConnect are indicated as such (see Section 7.3).

Use Download Current Configuration to download the configuration file. The configuration file is an INI file (http:
//en.wikipedia.org/wiki/INI_file), which is a widely-used file format. This file contains configuration
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settings related to modem, Ethernet, server upload, email, data evaluation, SCADA as well as activated channels and
sensors. By saving a configuration file, the configuration can quickly be uploaded and effectively applied to other data
loggers. The file name is config-Dnnnnnn.txt with Dnnnnnn as the serial number of the data logger.

Warning
Configuration files are forwards compatible but not backwards compatible with version 2.1.8 and older
(including Meteo-40 version 1). For example, a configuration file from 2.1.0 can be uploaded to 2.2.0, but
not the other way around. Since version 2.1.9, configuration files are forwards and backwards compatible.
If the configuration file is from a larger model, e.g. downloading from Meteo-40L and uploading to Meteo-
40M, the sensors and evaluations which use channels which the smaller model does not have will be
ignored.
Be careful with uploading a changed INI file to the data logger. Inconsistencies can lead to malfunctions of
the data logger.
We strongly advice not to change any entry in the configuration file manually.

4.2 System Administration

This page contains different administration aspects of the data logger. Only users logged in as Admin can access
the complete functionality of this section. If you are logged in as User, Viewer or Guest, changes in the System
→ Administration menu are not possible.

Data Logger Name: By giving each Meteo-40 plus a name, the data loggers can be identified easier. The name
appears in the statistics file footer, on AmmonitOR (http://or.ammonit.com/) and in the config.txt file.

Documentation

Data	logger	name

Power	Supply

	Battery

	Solar

	Wind	turbine

	Electrical	grid

	Generator

	Fuel	cell

	Other

Minimum	supply	voltage

11.5

Save	documentation

Figure 4.2: Assigning a Data Logger Name

Note
The data logger serial number is the most important ID to identify the data logger. Use the Data
Logger Name to give the data logger a custom name, e.g. Meteo-40 plus Site 1.
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CECS Power Mode The standard operation mode keeps CECS running for 20 minutes. Each user interaction resets
the remaining time to 20 min.
In order to keep CECS permanently running, e.g. for SCADA wind farm monitoring, Meteo-40 plus offers the
CECS always activemode. This mode prevents the automatic shutdown of CECS. It can be configured via web
interface (System→ Administration) or by using the display (Status→ CECS) of the data logger. To do any
changes of the CECSmode via display, permissions have to be defined in the web interface (System→ Display,
see Section 4.4.1). If the CECS always active mode is selected, it will be displayed in the status box of the web
interface with the infinity symbol (∞) as well as on Meteo-40 plus display with the word Always. The CECS
always active mode is not selected by default.

CECS	Power	Mode

Restart	CECS

Shutdown	CECS

	CECS	is	always	active	(only	recommended	for	SCADA	and	Switch	Manager)

Automatic	CECS	reboot	('Never'	only	recommended	for	SCADA)

Weekly

Power	CECS	on	digital	status	signal

None

Save	CECS	power	mode

Figure 4.3: Configuring the CECS always active Power Mode

Note
When the CECS always active mode is set, you cannot manually shut down the system by pressing
the middle button on the data logger.
If the power supply for Meteo-40 plus is disconnected while CECS is running in the CECS always
active mode, CECS will restart automatically as soon as Meteo-40 plus is powered again.

To ensure reliable Meteo-40 plus functionality it is highly recommended to reboot CECS regularly. In cases
where CECS is always on, e.g. for SCADA, Meteo-40 plus has an automatic reboot function. The default
behavior of Meteo-40 plus is to reboot once a week, every Sunday five minutes before midnight. Alternatively,
you can choose to reboot every day five minutes before midnight, or never.
To restart the CECS, click on Restart CECS.
To shutdown the CECS, e.g. during remote access, click on Shutdown CECS.

Important
When CECS is configured to be permanently active, you cannot shut down the system, neither by
pressing the middle button on the data logger nor using the Shutdown CECS button at the web
interface. You can still restart the CECS with the Restart CECS button.

Important
MARS (for measuring and recording) continues without stopping during the restart. You will not
loose any measurement data unless the recording is switched off or the power supply has been
disconnected. For further details about the systems refer to Section 1.4.

With the Power CECS on digital status signal option you can start the CECS by applying a voltage peak to the
selected digital channel. The voltage peak can be triggered over a cable / switch reachable from the ground to
start the CECS on site, in orther to prevent further climbing up the met mast during maintenance work.
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The voltage peak must last at least one second (see also Section 12.2.4). The digital channel has to be selected
from the list of available digital channels in the Power CECS on digital status signal dropdown list. This change
on data logger’s configuration will stop the measurement for some seconds, until it is automatically or manually
restarted (see Section 3.2).

Once the CECS is on, the communication can be established remotely via Modem, a previously connected
Ethernet cable or WLAN. The CECS will automatically turn off after 20 min if no action on the data logger is
performed.

Date and Time, Location: Time synchronization of the data logger is a primary concern. Four synchronisation meth-
ods are available: GPS, NTP, SCADA and Manually.

In order to synchronize date and time automatically to NTP servers, select NTP (Internet), set date and time.

NTP is a networking protocol that allows clock synchronization between the computer systems. The NTP servers
need to be trusted, as they will impose the time on your data logger.

We provide a default set of the NTP servers from the NTP Pool. The NTP Pool is generally very high quality,
but it is a service run by volunteers in their spare time. If you wish to change an NTP server, feel free to do so.

We recommend putting at least three trusted NTP servers on the NTP server list. Having less than three can
potentially cause problems. If they start to show different times, which one is to be trusted? With at least three
servers, it is easy for the device to decide which one shows the current time incorrectly.

The first NTP synchronisation happens two minutes after every CECS boot. If it fails, it tries again again 10
minutes later, otherwise it synchronises every six hours to ensure the clock remains accurate.

You can instead choose GPS, set date, time, and location. The GPS device must provide a sentence following
the GPRMC NMEA standard (e.g. PHS8-P modem).

The CECS will attempt to get the date, time and location from the satellite according to the same logic as NTP.

The Time zone field may be used to define a fixed UTC offset for the system. The measurement data is stored
as a local time without this information. Therefore, changing the Time zone during a measurement campaign
may result in data loss and is strongly discouraged.

The Minimal offset for automatic time adjustments (seconds) field can be used to only adjust the time when the
difference is sufficiently large, so that there are less discontinuities in the measurement data.

If date and time should be set manually, enter date (date format YYYY-MM-DD) and time (time format hh:mm:ss)
in the appropriate fields. Date and time format are validated after typing the values.

Every date, time and/or location adjustment is logged in the Logbook. Moreover, the current latitude and longi-
tude as well as the time of the GPS adjustment are included in each CSV file’s footer.
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Date	and	Time,	Location

Time	zone

UTC	(United	Kingdom,	Morocco)

Method	to	set	Date,	Time	and	Location

Manually,	set	date,	time	and	location

NTP	servers

0.pool.ntp.org	1.pool.ntp.org	2.pool.ntp.org	3.pool.ntp.org

Minimal	offset	for	automatic	time	adjustments	(seconds)

0.4

Date	(YYYY-MM-DD)

Time	(hh:mm:ss)

Latitude	(decimal)

13.43479

Longitude	(decimal)

52.50176

Altitude	(meters)

36.5

Save

Download	KML	file

Figure 4.4: Configuring Date, Time and Location of the Data Logger

In order to view the data logger location in GIS programs or Google Earth™, you can set the data logger location
(not altitude) either automatically via a GPS device, or manually by entering latitude, longitude, and altitude in
the appropriate fields. Enter latitude and longitude in the decimal format (dd.dddddd°), not in degrees and
minutes (dd°mm.mmmm′, like GPS) nor in degrees, minutes, and seconds (dd°mm′ss.ss″).

After downloading the KML file, you can open the file in Google Earth™.
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Figure 4.5: Data Logger Location displayed in Google Earth™

User Management: By default there are four user accounts: Admin, User, Viewer and Guest. Each account has
its own level of permissions and access rights, described in Table 3.1. Here you can change their passwords,
delete any that you do not need, and create new ones.

Name Permissions

Admin Admin

User User

Viewer Viewer

Guest Guest

Edit Delete

Edit Delete

Edit Delete

Edit Delete

Add	a	New	User

Figure 4.6: User List

To change a password, click ”Edit”. To remove an account, click ”Delete”.

To create new accounts click ”Add a New User”. You need to set the Username and Password that they will
use to log in, and what level of permissions they will have when they do. The rights offered by each level of
permissions are described in Table 3.1.
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Username

joebloggs

Permissions

Admin

Password

•••••••• Show	password

Save

Figure 4.7: Add a New User

Users created this way will be visible in the list alongside the default users. They can also be changed just like
the built-in ones.

Name Permissions

Admin Admin

User User

Viewer Viewer

Guest Guest

joebloggs Admin

Edit Delete

Edit Delete

Edit Delete

Edit Delete

Edit Delete

Add	a	New	User

Figure 4.8: User List with Custom User

Once created, a user’s name cannot be changed. You can achieve the same thing by deleting the user whose
name you’d like to change and re-creating it with the correct name.

An Admin cannot delete their own account. To remove the built-in Admin account, you must first create another
account with Admin permissions. You can then use that account to remove the built-in Admin.

A deleted account is not logged out immediately. However, all accounts (including deleted ones) are logged out
when CECS restarts.

Warning
Be aware that due to security reasons it is not possible to reset passwords. If you lose a modified
Admin password, there is no way to recover it, not even for Ammonit. In this case, return the data
logger to Ammonit. Only Ammonit is able to restore the original passwords.

Signing and Encryption Files sent by Meteo-40 plus, such as CSV data or logbook files, can optionally be digitally
signed or encrypted using the OpenPGP standard. The signature guarantees that the files have been really
produced by a specific data logger and have not been altered. The encryption ensures that nobody can see the
contents of the files without the correct password.
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Signing	and	Encryption

	Unsigned	and	unencrypted

	Sign	data	(GnuPG)

	Sign	and	encrypt	data	(GnuPG)

Encryption	password:

Show	password

Fingerprint

596F1223EBAD2FE56B5C947EF0554D0862153BE7

	Force	encryption

Save

Download	public	key	(GnuPG)

Figure 4.9: Signing and Encryption

For additional security, an Admin user can set the option Force Encryption. If this option is set, users without
Admin permissions have only restricted access to measurement data:

• CSV files can only be downloaded in encrypted form.
• CSV files can only be copied to USB flash drive in encrypted form.
• Live data can be seen only for 2 minutes on the web interface, but still unlimited on the LC display.
• Source data cannot be downloaded nor copied to USB flash drive.
• Data transfer settings (AmmonitOR, Email, Remote Copy, SCADA) cannot be changed.

Note
The signature for a CSV file refers to the canonical, uncompressed CSV file. Before version 1.4.2,
the signature referred to the compressed CSV file as sent by the data logger, however.

Note
If the Meteo-40 plus data logger has been produced before 2014-08, the digital signature is not
available, only encryption (since firmware version 1.0.1). Please contact Ammonit, if digital signature
is required on a previously purchased data logger.

Allow Manufacturer Administration In some cases it is necessary that Ammonit developers have access to your
data logger to check configurations or to modify any settings. This mode is only used for maintenance purposes.
Activate the manufacturer administration mode to allow Ammonit developers accessing your data logger.

By default the manufacturer administration mode is inactive.

Remote	Maintenance

	Allow	manufacturer	administration

Save

Figure 4.10: Allow Manufacturer Administration
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Important
Without your permission, Ammonit cannot and will never access any of your data loggers!

Reset Data: TheDisable recording button will cause the MARS to stop recording and prevents it starting automatically
as long as the browser keeps the page open. This is useful when the CECS needs to process a lot of source
data at once, e.g. generating many statistics files or USB source data copy.
The Reset metering button will reset the network traffic metering counters which are shown on the information
page and in the statistics file footer.
In order to delete all measurement data in one step, click on Delete all measurement data. The user will be
asked to approve a confirmation prompt. Deleting the measurement data usually takes less than half a minute.

URL:	https://d001234.local/confirm/format

Help Logout

Admin	on	D001234

Recording: Off Switch	on

Configuration: Saved Save

Connection: Ethernet

Remaining: ∞

Date/time: 2023-08-11	16:02:42	UTC

Confirm	Memory	Format

If	you	click	"Yes",	all	source	data	will	be	deleted!

Are	you	sure,	you	want	to	delete	all	measurement	data?

No,	cancel

Yes,	delete

Open	the	manual	for	more	information	about	this	page

Figure 4.11: Deleting All Measurement Data

Important
Recording stops after deleting measurement data. Start recording by clicking Switch on in the status
box of the web interface.

In order to delete all configurations, passwords and measurement data, click on Factory reset, delete all data.
The data logger will be set back to the condition at delivery. The user will be asked to approve a confirmation
prompt before the reset is performed.

URL:	https://d001234.local/confirm/factory_reset

Help Logout
Admin	on	D001234

Recording: Off Switch	on

Configuration: Saved Save

Connection: Ethernet

Remaining: ∞

Date/time: 2023-08-11	16:02:44	UTC

Confirm	Factory	Reset

If	you	click	"Yes",	all	settings	and	data	will	be	deleted!

Are	you	sure,	you	want	to	delete	all	settings	and	measurement	data?

No,	cancel

Yes,	delete

Open	the	manual	for	more	information	about	this	page

Figure 4.12: Factory Reset
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Note
After performing a factory reset, recording stops. Recording can be started after at least one sensor
has been configured.
The data reset is logged in the Meteo-40 plus logbook.

4.3 Upgrade Data Logger Software

The development of Meteo-40 plus is an ongoing process. Ammonit is constantly adding new features to the data
logger to better meet the needs of the user.

Important
In order to perform a software upgrade, the data logger has to be connected to the Internet, e.g. via modem
or LAN or using the tethering function of a mobile phone (Section 4.3.1). It is not sufficient to connect Meteo-
40 plus to a PC over USB, because a PC is not necessarily configured to work as a router.
You have to be logged in as Admin to perform an upgrade.
Make sure, that the date and time of the data logger is set correctly. If the data logger date and time is too
far in the past or in the future, the upgrade will not work.
If you do not have an Internet connection, you may upgrade the data logger offline, using a USB flash drive.
See Section 4.3.3 for details.

Update software list: In this step the data logger browses for updates and displays the number of available software
packages. Below the progress bar the currently installed version is displayed; the latest version describes the
available upgrade.

Note
The new software itself will not be downloaded and installed after clicking on Update software list.
The software version is not changed in this step!

Update	software	list

Update	software	list

Installed:	2.0.0.	Latest:	2.0.1.

Required	download

5	Packages,	1.060	MiB

Upgrade	data	logger	software

Download	software

Install	software

	

	

	

100%

0%

0%

Figure 4.13: System Upgrade

Upgrade data logger software: The software upgrade can easily be performed by pressing the Upgrade data logger
software button. The software packages will be downloaded and installed.
After the installation is completed, CECS is restarted.
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Note
In older firmware versions the data logger has to be restarted after the upgrade. Press the Restart
data logger button.

Important
Before upgrading the data logger via modem, make sure that the corresponding switch is configured
correctly in the Communication→ Modem menu of the data logger web interface.
Depending on the installed firmware version, the software packages needed for the upgrade can be
large. So the download and installation process can take some time depending on the speed of your
Internet connection.
In rare cases the progress bar in the Meteo-40 plus web interface may stop Reload the page and
wait. If the progress bar does not move several minutes, we recommend restarting the upgrade
process.
Do not disconnect the power supply or reboot the system during the whole upgrade process.

Update	software	list

Update	software	list

Installed:	2.0.0.	Latest:	2.0.1.

Required	download

5	Packages,	1.060	MiB

Upgrade	data	logger	software

Download	software

Install	software

	

	

	

100%

100%

50%

Figure 4.14: System Upgrade

4.3.1 Upgrade using a Smartphone

The Meteo-40 plus data logger can only be upgraded when it is connected to the Internet.

By connecting your smartphone to the data logger, you can set up an Internet connection via the tethering function of
the smartphone.

Connect your smartphone to the USB-A slot of the Meteo-40 plus. Make sure that the data logger has no Ethernet LAN
connection during the procedure. If in doubt just unplug the Ethernet cable from the data logger. Open the settings for
Tethering and portable hotspot of the smartphone operating system (see Figure 4.15) and activate USB tethering.

Important
Before starting the upgrade via tethering, make sure that Use DHCP for wired network is selected in the
Communication→ LAN menu of the Meteo-40 plus web interface. Additionally, make sure Connect to
Internet via modem only is not selected in the Communication→ LAN menu of the Meteo-40 plus web
interface. See Figure 7.26 for an example.

Browse at Meteo-40 plus display for the IP address using the keys (Communication→ Devices→ LAN→ USB
(Activated)→ IP settings). Enter the data logger’s IP address in your smartphone browser, login and perform the
upgrade.
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Figure 4.15: Tethering Settings of an Android™ smartphone

Tip
The tethering function can also be very useful for remote servicing. You might need to start an online
action over the display in order to stablish the connection via AmmonitConnect for remote access (see
Section 4.4.1).

4.3.2 Software Upgrade Behind a Firewall

For most firewalls that allow outgoing HTTPS and HTTP traffic, no special configuration is needed. Only in some very
restrictive environments, you may need to configure your firewall for the Meteo-40 plus software upgrade or ask your
network administrator to do so. If Meteo-40 plus is in a separated subnet, you may also need to specify a Gateway in
the LAN settings of the data logger.

Meteo-40 plus needs to connect the server archive.ammonit.com via HTTPS (port 443) as outbound connection
to perform a software upgrade. Make sure, that these connections are allowed. There is no need for Meteo-40 plus
to connect any other servers, use any other protocols or use any kind of inbound connections.

4.3.3 Offline Upgrade using USB Flash Drive

Warning
Note, that this method is not the preferred software upgrade method. If possible, please use the online
upgrade method.
Make sure, you have saved all your data and your configuration before performing an offline upgrade.

4.3.3.1 Prepare the Offline Upgrade

1. Make sure that all relevant data from data logger is saved: Configuration file, CSV files, and, if necessary, source
data.

2. Make sure the software version you will upgrade to is actually newer than the software version already installed
on the data logger. Downgrades are not supported. Always use the latest offline update image from Ammonit,
because errors of older versions might be fixed!

3. Download the latest version from here (https://archive.ammonit.com/archive/usb-images/appr
oved/Meteo-40-plus.zip) and unpack the zip archive. You will need the meteo-40.bin image file.

4. You need a prepared USB flash drive of at least 2 GiB capacity. The flash drive must formatted as FAT32.
The image file must be placed in the top-level of the flash drive, not in a directory. Further information is in the
README.txt file.
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4.3.3.2 Performing the Offline Upgrade

1. Switch off the CECS of the data logger. In doubt, remove the power supply.

2. Plug the prepared USB flash drive into one of the two USB-A slots of the Meteo-40 plus.

3. If necessary, reconnect the power supply of the data logger. Switch on the CECS.

4. You will see the following text on the LC display:

Found image
for USB upgrade.
Press the > button

to proceed.

Figure 4.16: Press the right arrow button

You have to press the right arrow button within ten seconds, otherwise the boot process continues normally and
no upgrade will be performed.

5. For around half a minute, the following message appears:

Reading
image for
USB upgrade.
Please wait...

Figure 4.17: Reading the image

Warning
After that step interrupting the process, unplugging the USB flash drive, or a power failure can lead
to an non-functional data logger!

6. The complete process takes about ten to fifteen minutes, until the following message appears:

SUCCESS:
Remove power plug,

wait 3s, and
remove USB drive.

Figure 4.18: Successful upgrade

which should be performed accordingly: Remove the power supply of the data logger, remove the USB flash
drive, wait at least three seconds, and plug-in again the power supply of the data logger.

4.4 The Device Page

4.4.1 Display Access

The display page shows, what can be seen on the LCD.
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>	System												

		Status												

		Channels										

		Communication					

Remote	Display

Figure 4.19: Remote Display

In order to give users without access to the web interface the chance of configuring the data logger, some permissions
for display users can be selected, e.g. switch on recording or (de-)activate WLAN.

If the corresponding permission Run an action is set, you can also start the execution of an action over the display
menu Communication→ Schedule. Select one of the actions and press the right button to start it.

Display	Settings

Permissions	of	Display	User

	Change	CECS	mode

	Switch	between	DHCP,	static	IP,	and	link-local

	Switch	off	recording

	Switch	on	recording

	Change	the	state	of	switches

	(De-)	Activate	WLAN

	Run	an	action,	e.g.	go	online

Other	Settings

	Activate	display	backlight

Save

Figure 4.20: Display Settings

Note
To view the display in the web interface, it is advised to enable JavaScript in your web browser.

4.4.2 Connected USB Devices

Also on the device page, you can find a list of the USB devices, that are currently connected to the data logger and
recognized by it, e.g. a modem, a flash drive, or a camera.
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Note
The list of devices is not updated automatically. You have to reload the page to see any changes.

4.4.3 USB Flash Drive Copy

Meteo-40 plus offers the possibility to download created CSV statistics files with measurement data (statistics see Sec-
tion 6.3), the source data in CSV format, and/or the logbook in CSV format on an USB flash drive, which is connected
to the data logger. Before you use this function, data logger and USB flash drive have to be configured.

USB	Flash	Drive	Copy

USB	passphrase	(at	least	eight	characters)

••••••••••••••••• Show	password

Save	USB	passphrase

Show	USB	files

Figure 4.21: Configuring the USB Flash Drive Copy

Important
A file system like FAT32, NTFS, ext4, ext3, or ext2 is required on USB flash drive.

In order to format the USB flash drive with FAT32 on your Windows™ PC, connect the USB flash drive to the PC.
Open the Windows™ Explorer. Right-click on the USB flash drive shown under Computer. Click on Format... and
select FAT32 as File system. Start the formating process.

Figure 4.22: Formatting the USB flash drive (Windows™ PC)

Create a INI file named keyfile.txt, which has to be saved on the USB flash drive used to download CSV files
(statistics and/or source data). This INI file must include the data logger serial number and a password in a the INI file
format. The INI file is necessary to prevent unauthorized access to data. Example:

[D123456]
password = yoursecretpassword
statistics = all
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Note
The passphrase for the USB flash drive must have at least 8 characters!

The passphrase has to be entered in the field shown in Figure 4.21.

It is possible to use one USB flash drive for several data loggers. To do so, in the keyfile.txt the details of the
data loggers have to be entered section by section, e.g.

[D123456]
password = passwordone
statistics = since 2016-01-01
gustdata = since 2016-01-01
config = save
logbook = all

[D234567]
password = passwordtwo
statistics = newest 10
config = save
sourcedata = all

[D345678]
password = passwordthree
statistics = month 2016-01
config = save
sourcedata = day 2016-01-07

The following entries are possible:

password Mandatory, must have at least eight characters

statistics One of the time period values, see below. Copies the primary statistics files.

secondary One of the time period values, see below. Copies the secondary statistics files.

tertiary One of the time period values, see below. Copies the tertiary statistics files.

config Value save to copy the configuration file. Other values are not yet implemented.

logbook One of the time period values, see below.

gustdata One of the time period values, see below.

sourcedata One of the time period values, see below.

Warning
Copying source data may take a very long time, even some hours.

stop_recording Value yes to stop recording while copying source data. By default, Meteo-40 plus keeps recording
while copying source data. With this entry, it is much faster since the hardware does not need to read and write
at the same time. It is intended for back-ups after the measurement campaign is finished.

The time period values are:

all Copy all files of this type.
since DATE Copy files of this type since and including DATE in format YYYY-MM-DD.

until DATE Copy files of this type until and including DATE in format YYYY-MM-DD.

month DATE Copy files of this type in the month of DATE in format YYYY-MM.

day DATE Copy files of this type at the day of DATE in format YYYY-MM-DD.
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newest NUMBER Copy newest files of this type, max. NUMBER.

oldest NUMBER Copy oldest files of this type, max. NUMBER.

Meteo-40 plus has to be switched on for download. If the USB flash drive is configured correctly, it will be recognized
by the data logger. If the passphrase entered in the web interface and in the keyfile.txt does not match data
download is not possible.

Meteo-40 plus shows in its display the number of downloaded files. When the download is finished, the data logger
menu is shown and the USB flash drive can be disconnected.

All data files are compressed to keep them as small as possible.

Note
If encryption and/or digital signature is switched on for the data logger, copying to the USB flash drive
behaves accordingly, i.e. data will be encrypted and/or signed.
If the Force Encryption option is enabled, copying source data to USB flash drive is prohibited.

4.4.4 Show USB Files

This page shows the files corresponding to the data logger on the attached USB stick and allows them to be down-
loaded and deleted.

4.5 Using a Camera

You can take pictures with Meteo-40 plus and send the image to AmmonitOR, as an email attachment, copy it to an
SCP/FTP/SFTP file server or copy it to a permanently connected USB flash drive. Each of these options must be
individually configured. See the corresponding checkboxes in the Communication→ AmmonitOR, Communication
→ Email, and Communication→ Remote Copy submenus.

You can either use a USB webcam plugged into one of the two USB-A slots or an Ethernet connected camera by
HTTP/HTTPS.
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URL:	https://d001234.local/system/camera/

Help Logout
Admin	on	D001234

Recording: Off Switch	on

Configuration: Saved Save

Connection: Ethernet

Remaining: ∞

Date/time: 2023-08-11	16:03:06	UTC

Camera

Current	Camera	Image

Refresh	image

Camera	Image	Settings

Camera	Image	URL:

	Copy	Camera	Image	to	USB	Drive

Save	camera	settings

中文(简) 	 English 	 Español 	 Português 	 Français 	 Deutsch 	 日本 ©	2011-2023	Ammonit	Measurement	GmbH
www.ammonit.com

Meteo-40

System

Information

Administration

Upgrade

Device

Camera

Switches

Logbook

Measurement

Sensors

Channels

Evaluation

Data

Live

Statistics

Gusts

Source

Communication

Schedule

Online

AmmonitOR

Email

Remote	Copy

SCADA

LAN

WLAN

Modem

Figure 4.23: Camera Image

Note
If the camera should be used for monitoring purposes, a steady power supply has to be connected.

4.5.1 Camera Configuration

To take one or more photos with an outdoor camera, just enter the URL of the photo in the web interface. The URL
depends on the installed camera, e.g. http:// nn.nn.nn.nn/ or https:// nn.nn.nn.nn/. Mobotix M25M
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camera image URL typically is http://10.13.0.197/record/current.jpg.

Camera	Image	Settings

Camera	Image	URL:

	Copy	Camera	Image	to	USB	Drive

Save	camera	settings

Figure 4.24: Attaching Camera Images

If the option Copy Camera Image to USB Drive is selected and a USB drive is connected to the data logger, the
image will be copied to the USB device whenever any of the scheduled actions run (see also Section 7.2). The files
can be downloaded or deleted (see also Section 4.4.4).

If you connect the cammera via Ethernet, it is recommended to use static IP addresses. You must configure both the
camera and Meteo-40 plus, each with a different address in the same network. E.g. 10.13.0.197 for the camera
and 10.13.0.200 for the data logger. In this case, the netmask would be 255.0.0.0. DNS server and gateway are
not relevant here.

The static IP address of Meteo-40 plus can be configured in the Communication→ LAN menu (see Section 7.7). In
order to configure the IP address of the camera use the software delivered with it.

If LAN online, whenever CECS is on has been disabled, the Ethernet port may be inactive. This means you might
not see an image on accessing the System→ Camera menu (see Section 4.5) menu. You will know if the Ethernet
interface is active because it will appear at the connections list in the status box of the web interface.

If you want the Ethernet port to be always active despite the higher power consumption, you can configure it in Com-
munication→ LAN menu (see Section 7.7).

Important
If a USB modem is connected to Meteo-40 plus and Ethernet is used for the camera, it is necessary to
select Connect to Internet via modem only in the Communication→ LAN menu.

4.6 Configuring Switches

Switches can be used to control and optimize the power consumption of the measurement system. External devices
connected to Meteo-40 plus, such as modem, camera or heating can be controlled via the data logger. Meteo-40 plus
will close (turn on) the configured switch when the correspondig device is needed, e.g. to send data via the modem
connection, and open it again (turn off) when not needed.

In a solar power plant, a switch can be used to orient the solar trackers for protection of the payloads in case of high
wind.

Meteo-40L data logger provides eight switches intended for the following tasks:

• Control the modem power supply (recommended). See Section 7.9 for GSM and Section 7.7 for satelite.
• Control camera power supply. See Section 7.7.
• Control of the selected switch according to the configured measurements and thresholds Section 4.6.1.

A switch can only fulfill one of the duties. It can either be used to control the modem’s power supply or at the Switch
Manager.

To manually toggle one or more of the switches individually, go to the System→ Switches menu.
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Switches

Id Label State Action

S1 Modem On Turn	off

S2 Heating Off Turn	on

S3 Off Turn	on

S4 Off Turn	on

S5 Off Turn	on

S6 Off Turn	on

S7 Off Turn	on

S8 Off Turn	on

Figure 4.25: Switch Configuration

Warning
We highly recommend configuring a switch for the modem in the Communication→ Modem menu. If the
modem is switched manually via the System→ Switches menu, you risk the shutdown of the modem after
rebooting the data logger or after problems with the power supply.
Switch S1 is assigned to the modem by default. In case the switch is not used for the modem, it can be
deselected.

Note
Refer to Chapter 13 for more information about physically connecting the supply using a switch.

4.6.1 Switch manager

The Switch manager is designed to automatically toggle one of the switches deppending on the configured condi-
tions. It is commonly used for sensor’s heating control. Only one switch can be selected.

In order to use this function, select a switch as well as one or more switching conditions. The available switching
conditions are temperature range, minimum humidity, minimum voltage, minimum windspeed and two time frames. If
more than one condition is configured, the switch will only be closed (i.e. on) when all conditions are fulfilled. If only
one time frame is needed, the duration of the second time frame duration must be set to 00:00. If the inverted logic
is selected, the switch will remain closed as long as the conditions are not fulfilled. Only configured sensors and free
switches are listed.

The state of the selected switch is reviewed according to the values calculated at the end of the configured statistics
interval for SCADA, Switch manager and snapshots in the Data→ Statistics menu. The default statistics interval is
10 min. The average value is used for temperature, humidity and voltage whereas the maximum is used for wind
speed.

Important
It is necessary to keep the CECS always on if the switch manager is deployed. The state of the switch can
only be closed (i.e. on) when CECS is running, i.e. to perform an action (see Section 7.2) or if CECS is
configured to be always on (see Section 4.2). On CECS shut down, the selected switch is opened (turned
off).
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Switch	Manager

Managed	switch

S2

	Invert	switch	behaviour

Label

Heating

Switching	Conditions

Temperature

Int.	Temperature	(Temperature)

Minimum	temperature	(°C)

-30

Maximum	temperature	(°C)

30

Humidity

None

Minimum	humidity	(%)

70

Voltage

Supply	voltage	measurement	(Analog	Voltage)

Minimum	voltage	(V)

0

Wind	speed

Anemometer	(Wind	Speed)

Minimum	wind	speed	(m/s)

20

Time	Frames

	Use	timer

First	time	frame	start	(hh:mm)

09:00

Duration	(hh:mm)

0:45

Second	time	frame	start	(hh:mm)

09:50

Duration	(hh:mm)

00:00

Save

Figure 4.26: Switch Manager

If the sensor heating should be supplied by an external power supply via relay, check the connection plan Figure 13.17.
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4.7 Using the Logbook

Events which are not related to measurement data are listed in the logbook. The logbook displays for example all user
logins and the user’s IP address. A calendar is shown with a monthly overview. Blue highlighted boxes indicate days
with logbook entries. By clicking on the day, the entries are displayed. Click on the arrows shown above the calender
to go to the previous or next month.

It is also possible to add entries to the logbook, e.g. to record replacements of sensors or any maintenance work that is
important for data interpretation. Add messages by clicking on Log a message. A short text message can be entered.

Logbook entries of a day can be downloaded by clicking on the Download buttons.

2016 05 06 07 08 09 10 11 12
2017 01 02 03 04 05

◁ 2015-06
Mon Tue Wed Thu Fri Sat Sun

1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 	 	 	 	 	

Date/Time
Date/Time

Message
Message

Measurement	and	Recording	Errors

RS485_TIMEOUT

Reset	measurement	errors

▶

Log	a	message Download Download	month Download	year Download	all

Figure 4.27: Logbook

MARS errors are indicated by the red LED (second from bottom). A detailed list containing error codes is reported
belowMeasurement and Recording Errors. By clicking on Reset Measurement Errors the list of errors can be deleted.

Note
The MARS error codes can be important for Ammonit engineers to identify errors in the data logger.

4.7.1 Logbook Events

The following actions or events are logged to the logbook:

• User note to logbook
• Log in of a user and failed login attempt
• Factory reset
• Memory format
• Configuration file upload
• Setting date and time via GPS, NTP, EKO sun tracker, SCADA or Admin (manually)
• Setting location via GPS or EKO sun tracker
• Copying CSV files in any of the following ways: to USB flash drive, via Email, Remote Copy or AmmonitOR upload
• Software upgrade
• Password reset by manufacturer
• CECS start/stop
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• Actions execution
• Actions initiated by a short message (SMS)
• RS485 Serial Interface
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Chapter 5

Measurement

5.1 Sensor Configuration

In the Measurement→ Sensors menu, sensors can be added and basic parameters can be configured by using the
Sensor Helper (see Section 5.1.2). After having configured the sensors, two buttons are available for each sensor:
Delete and Change. These allow a user to delete or change an existing sensor with help of the Sensor Helper.

Label Type Model Order	No. Height Serial	No. Period Channels Change Delete

Top

Anemometer
Anemometer

Thies

Anemometer

First	Class

Advanced

120 1	s C1 Delete

Backup

Anemometer
Anemometer

Thies

Anemometer

First	Class

Advanced

118 1	s C2 Delete

Middle

Anemometer
Anemometer

Thies

Anemometer

First	Class

Advanced

60 1	s C3 Delete

Low

Anemometer
Anemometer

Thies

Anemometer

First	Class

Advanced

10 1	s C4 Delete

Top	Wind

Vane
Wind	Vane

Thies	Wind

Vane	10	Bits

Serial

Synchron

120 1	s D1 Delete

Backup	Wind

Vane
Wind	Vane

Thies	Wind

Vane	10	Bits

Serial

Synchron

118 1	s D2 Delete

Low	Wind

Vane
Wind	Vane

Thies	Wind

Vane	10	Bits

Serial

Synchron

60 1	s D3 Delete

Hygro/Thermo

@10.0m
Hygro/Thermo

Galltec

Hygro-

Thermo

Active	KP

10 1	s A1,	A2 Delete

Barometer

@10.0m
Barometer

Barometric

Pressure

Sensor	AB60

10 1	s A3 Delete

Change

Change

Change

Change

Change

Change

Change

Change

Change

Add	sensor

Delete	all	sensors

RS485	client	configuration

Figure 5.1: Sensor Definitions
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Below the sensor definitions overview you can find four buttons: Add sensor, Delete all sensors, RS485 serial interface
and Download sensor database.

Add sensor: Opens the Sensor Helper to configure a new sensor.

Delete all sensors If all sensors should be deleted, e.g. after a completed measurement campaign, you can click on
Delete all sensors to remove all sensors from the configuration in one step.

RS485 serial interface Occasionally it can be necessary to send a command to a sensor connected to an RS485
client port, e.g. in order to detect communication problems or to change a sensor configuration (see Sec-
tion 5.1.4).

Download sensor database Download a CSV file which describes all the sensors available in Sensor Helper.

Note
By clicking on a column headline in the sensor definitions overview, you can sort the selected column in
ascending or descending order.

Note
When adding a new sensor or changing the electrical channel of a sensor, recording is stopped automat-
ically. That way, it is clear which measurements use the old configuration and which measurements use
the new one. Also, if no sensors at all are configured, recording is switched off. Afterwards, one can switch
on recording. Also, recording will be switched on automatically after 20 minutes of no further configuration
changes.

Important
For some estimations related to solar sensors, the location of the measurement station has to be added in
the System→ Administration menu (see also Section 4.2).

Warning
Adding or deleting a sensor switches the recording off. The new configuration is unsaved! By clicking on
Switch on, the configuration will be automatically saved and recording will resume.

5.1.1 Difference between Sensors, Channels, and Evaluations

To have a better understanding of the sensor management, it is important to know the difference between sensors,
channels, and evaluations.

In general, a sensor is an electro-mechanical device, which records physical values. The physical values are trans-
formed into an electrical value by the sensor. For example, wind speed can be transformed into a frequency. To map
these electrical values on the corresponding physical values, an evaluation process has to be performed.

A sensor may be connected to more than one electrical channel of Meteo-40 plus. The number of used electrical
channels depends on the kind of sensor and also on the kind of electrical wiring of the sensor. For example, wind
vane POT (potentiometer) may use the two analog channels A1 and A2. Another example is the pyranometer Delta-T
SN1 that emits two analog voltage signals and one digital status signal. The two analog output signals have to be
connected to two analog voltage channels and the digital status signal has to be connected to one digital input.

The evaluation process of the measured values is done by the software of the Meteo-40 plus data logger. Both pieces
of data are saved: the measured physical value at every channel and the evaluated value. Some typical formulas are
displayed below.

Most anemometers deliver a rectangle pulse output signal with a frequency proportional to the instant speed. Con-
necting it to a counter input (i.e. C1 to C12), its frequency will be measured. For the evaluation of wind speed a linear
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formula will be applied using slope and offset values given in the configuration of the Measurement→ Sensors menu.

vwind =

{
slope · Cx+ offset : Cx > 0
minimal_value : Cx = 0

Equation 5.1: Linear Equation for Wind Speed

A counter value of 0 results in an output equal to the minimal_value instead of the offset. The offset is ignored
in that case. Leaving the minimal_value field blank is equivalent to setting it equal to the offset.

The output signal of many pyranometers is an analog voltage. To measure and record this signal, the output of the
pyranometer should be connected to an analog voltage input (i.e. A1 to A12). To interpret the value of the apparent
solar radiation, the measured value is internally divided by the specific sensitivity of this sensor. In this case sensitivity
has to be configured.

5.1.2 Sensor Helper

In order to simplify the configuration of sensors, Meteo-40 plus provides a Sensor Helper in the Measurement→
Sensors menu. The Sensor Helper guides you through the sensor configuration. It will appear when you attempt to
Add sensor or Change a sensor, a channel or an evaluation.

You must select one of the available sensor types (e.g. anemometer, wind vane, barometric pressure sensor, solar
sensor, etc.) and the supported models. If the sensor appears in the list, the appropriate channel settings will be
automatically selected as shown in Figure 5.2. Depending on the sensor, further settings can be configured by the
user, e.g. Slope, Offset, Sensitivity, measurement rate, channel, etc..

Important
If the sensor doesn’t appear in the list of preconfigured sensor, you can always use a generic sensor from
the Other Sensor list.

Note
Only channels and switches which are not already used by other sensors are available.
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Sensor	type

Anemometer

Sensor

Thies	Anemometer	First	Class	Advanced

Installation	height	(m)

120

Label

Top	Anemometer

Serial	number

Wind	Speed	Slope	(m/s/I)

0.0462

Wind	Speed	Offset	(m/s)

0.21

Measurement	rate

1	s

Counter	Channel

C1

Add	more

Finish

Figure 5.2: Sensor Helper with Sensor Settings
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Important
For many sensors, slope and offset values are pre-configured according to the manufacturer’s information.
Carefully check the values. If calibrated sensors are installed, use the slope and offset or sensitivity values
indicated in the calibration protocol of the sensor.

5.1.3 Order of Sensors and Evaluations

The order of sensors and evaluations in the web interface and the LC display is always consistent.

Sensors are ordered by

1. sensor type (anemometers, wind vanes, thermo/hygro sensors, barometers, precipitation sensors, solar sen-
sors, ultrasonics, power meters, other sensors),

2. height (from highest to lowest),

3. and finally the textual label (alphabetically).

Evaluations are ordered by

1. evaluation type (wind speed, wind direction, humidity, temperature, differential temperature, air pressure, air
density, etc.),

2. height of the corresponding sensor (from highest to lowest),

3. and finally the textual label (alphabetically).

5.1.4 RS485 Serial Interface

During the installation process or when changing any sensor settings during deployment, it can be useful to send a
special command to a connected RS485 sensor.
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Send	request	over	M	(R1)

Protocol:

ASCII

Modbus	address

1

Modbus	start	register	(0..65535)

0

Modbus	register	quantity	(1..20)

1

Modbus	function	code

3

Command:

Latest	response:

Not	available

Send	request

M	serial	settings

RS485	speed

38400

RS485	data	format

8N1

Save

Figure 5.3: RS485 Serial Interface

First of all, the general serial settings of the RS485 client have to be configured according to the configuration of the
sensor. All sensors in an RS485 bus will share the configured settings.

If Modbus protocol is selected, the telegram will be internally composed according to the selected parameters and
shown in the command box. The available parameters for the request are: Sensor ID for the unique sensor identi-
ficator in the bus (0..247), Modbus Function code (01 to 06 supported), Start address (PDU addressing, first
reference is 0) and Quantity or value (quantity of registers/inputs for read only function codes (01 to 04) and
value for writing function codes (05 and 06)).

If ASCII protocol is selected, the custom command must be typed by the user in the command box. The following
escape sequences representations are recognized for the ASCII commands:

Escape Sequence Symbol
<CR> U+000D Carriage Return
<LF> U+000A End of Line
<STX> U+0002 Start of Text
<ETX> U+0003 End of Text

Table 5.1: ASCII escape sequences for RS485 Serial Interface
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The communication will be reflected in the logbook including a timestamp. Example of ASCII communication: ”RS485
Request: ’01TR00003<CR>’, Response: ’<STX>000.1 096 +24.6 M 0E*1D<CR><ETX>’”. Example of Modbus com-
munication: ”RS485 Request: ’0104277400063aa6’, Response: ’01040c41375c2942c0000041e800006d3d’”.

Note
The RS485 serial interface is only available for Admin.

5.2 Measurement Channels

In the Measurement→ Channels menu a table is shown, which displays all connected channels with details such as
label, value, rate, range, protocol and selected switch. To modify sensor settings, click on Change to open the Sensor
Helper (see also Section 5.1.2).

Id Label Value Unit Period Range Protocol Addr. Switch Sw.	Pretime Change

A1
Hygro/Thermo

@10.0m
--- V 1	s -10	V..+10	V

A2
Hygro/Thermo

@10.0m
--- V 1	s -1	V..+1	V

A3
Barometer

@10.0m
--- V 1	s -10	V..+10	V

C1
Top

Anemometer
--- I 1	s

C2
Backup

Anemometer
--- I 1	s

C3
Middle

Anemometer
--- I 1	s

C4
Low

Anemometer
--- I 1	s

D1 Top	Wind	Vane --- 1	s
Thies	10-

Bit

D2
Backup	Wind

Vane
--- 1	s

Thies	10-

Bit

D3 Low	Wind	Vane --- 1	s
Thies	10-

Bit

Change

Change

Change

Change

Change

Change

Change

Change

Change

Change

Digital	test

Figure 5.4: Measurement Channels Overview

Note
Click on a column headline in the measurement channels overview to sort the selected column in ascending
or descending order.

5.3 Configuring the Evaluation

In the Measurement→ Evaluation menu the settings for data evaluation are shown. A table displays the configured
sensors with their measured and estimated values. The order of evaluations is explained in Section 5.1.3. If the
settings should be modified, click on Change to open the Sensor Helper (see also Section 5.1.2).
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Label Evaluation Origin Height Value Unit
Minimal

Value
Slope Offset

Installation

Offset
Clip Change

Top

Anemometer
Wind	Speed C1 --- m/s 0.21 0.0462 0.21

Backup

Anemometer
Wind	Speed C2 --- m/s 0.21 0.0462 0.21

Middle

Anemometer
Wind	Speed C3 --- m/s 0.21 0.0462 0.21

Low

Anemometer
Wind	Speed C4 --- m/s 0.21 0.0462 0.21

Top	Wind

Vane

Wind

Direction
D1 --- ° 0.3515625 0 0

Backup	Wind

Vane

Wind

Direction
D2 --- ° 0.3515625 0 0

Low	Wind

Vane

Wind

Direction
D3 --- ° 0.3515625 0 0

Hygro/Thermo

@10.0m
Humidity A1 --- % 100 0 100

Hygro/Thermo

@10.0m
Temperature A2 --- °C 100 -30

Barometer

@10.0m
Air	Pressure A3 --- hPa 60 800

Change

Change

Change

Change

Change

Change

Change

Change

Change

Change

Add	evaluation

Figure 5.5: Screenshot of the Configuration for the Evaluation

In addition to the automatically generated evaluations, it is possible to apply formulas to the measured values or even
combine evaluations. The new evaluations can be added in the Evaluation Helper by clicking on Add evaluation. See
Section 5.3.1.

Note
Click on a column headline in the evaluation configuration overview to sort the selected column in ascending
or descending order.

5.3.1 Evaluation Helper

The Evaluation Helper introduces a higher flexibility to Meteo-40 plus sensors configuration. Apart from the automati-
cally configured evaluations which appear when you add a sensor, this tool allows you to generate new evaluations,
combining the existing ones by means of a formula. The standard statistics are available for the new evaluation and
will be included in the CSV statistics file. The Evaluation Helper also provides some special statistics like the covari-
ance, kurtosis, turbulence intensity or Obukhov length. To use this feature, click Add evaluation in the Measurement
→ Evaluation menu. The Evaluation Helper will guide you through the configuration process. After choosing a formula
from the list, the corresponding parameters will be shown for selection.

Important
Only the measured values are saved by default to the CSV statistics file. Estimated values are for infor-
mation purposes. In order to include estimated values in the CSV statistics file, select the values over the
statistics selection interface in the Data→ Statistics menu under Select statistics (see also Section 6.3.1).

5.3.1.1 Addition

Addition of two or three previously configured evaluations.

A = B+ C

Equation 5.2: Addition of two elements
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A = B+ C+ D

Equation 5.3: Addition of three elements

5.3.1.2 Density of moist air

According to IEC 61400-12-1 it is required to measure air density, which is calculated from air temperature and air
pressure. Air density has a significant influence on the wind energy calculation. See calculation of wind energy in
Section 10.1.

At high temperatures measuring relative air humidity is recommended according to IEC 61400-12-1. In order to cal-
culated density of moist air, Meteo-40 plus offers two options: with or without relative humidity.

If air density should be calculated without humidity, choose only a temperature and a barometric pressure sensor from
the list in the Evaluation Helper (see Section 5.3.1). Meteo-40 plus calculates air density for evaluation with original
1-sec measurement data according to the following formula:

ρ =
p

R0 · T

Equation 5.4: Calculation of Density [ρ] of Dry Air

where p is the air pressure, T the air temperature and RO the gas constant of dry air 287.05[J/kgK].

If relative humidity should be considered for air density calculation, choose also a humidity sensor from the list in the
Evaluation Helper (see Section 5.3.1). With selected humidity sensor, Meteo-40 plus calculates density of moist air
for evaluation with original 1-sec measurement data according to the following formula:

ρ =
1
T

(
p
R0

− RH · pH2O

(
1
R0

− 1
RH20

))

Equation 5.5: Calculation of Density [ρ] of Moist Air

where T is the air temperature, p the air pressure, R0 the gas constant of dry air 287.05[J/kgK], RH2O the gas constant
of water vapour 461.5[J/kgK], pH2O the vapor pressure, RH the relative humidity.
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Formula

Density	of	moist	air	(IEC	61400	2005)

Unit:	kg/m³

Temperature

Hygro/Thermo	@20.0	m

Air	Pressure

Barometer

Label

Installation	height	(m)

20.0

Save

Delete

Figure 5.6: Evaluation for Air Density

5.3.1.3 Albedo

Surface albedo is defined as the ratio of irradiance reflected to the irradiance received by a surface. It is dimensionless
and measured on a scale from 0 (corresponding to a black body that absorbs all incident radiation) to 1 (corresponding
to a body that reflects all incident radiation). If an upper pyranometer reading, a lower pyranometer reading, or both
is/are less than 2 W/m², the albedo value is invalid.

Albedo =
IrradianceReflected
IrradianceGlobal

Equation 5.6: Albedo

5.3.1.4 Ampere meter

Based on Ohm’s law, you can use the Ampere meter formula to transform the measured voltage to the corresponding
current, after introducing the value of the shunt resistor used. This formula can be used with any existing voltage
evaluation (e.g. if you previously configured a Gantner A3.1 module).

I =
V
R

Equation 5.7: Ohm’s law

where I is the current through the conductor in units of amperes, V is the voltage measured across the conductor in
units of volts, and R is the resistance of the conductor in units of ohms.

5.3.1.5 Differential temperature

By selecting Differential temperature in the Evaluation Helper, the difference between two temperature measurements
can be recorded every second. Choose two temperature sensors from the list for theta 1 and theta 2. According to
the following equation the difference is calculated.
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Δϑ[K] = ϑ1[°C] − ϑ2[°C]

Equation 5.8: Calculation of the Temperature Difference [Δtheta]

5.3.1.6 Division

Division of two previously configured evaluations.

A =
B
C

Equation 5.9: Division

5.3.1.7 Effective irradiance

Effective irradiance (Eeff) is total plane of array (POA) irradiance adjusted for angle of incidence losses, soiling, and
spectral mismatch. In a general sense it can be thought of as the irradiance that is “available” to the PV array for power
conversion.

Eeff = G0 ·
ISC

ISC0 · (1+ TKISC · (T− T0))

Equation 5.10: Calculation of effective irradiance

where G0 : reference condition irradiance (W/m²), ISC : measured short circuit current (A), ISC0 : short circuit current at
reference condition (A), T : measured surface temperature (°C), T0 : surface temperature at reference condition (°C),
TK ISC : temperature coefficient of short circuit current (%).

5.3.1.8 Soiling ratio ISC index

The soiling ratio ISC index (SR ISC) is a standard metric for the effects of soiling on energy production. This dimension-
less factor is in range 1.0 to 0 and equals 1 when both modules are clean.

For identic soiled an clean devices, SR ISC can be calculated as follows (legacy systems).

SRISC =
ISCSoiled · (1− TKISC · (TSoiled − T0))
ISCClean · (1− TKISC · (TClean − T0))

Equation 5.11: Calculation of SR ISC for identic soiled and clean devices

where ISC is the measured short-circuit current of the soiled and clean modules and T is the measured temperature of
the soiled and clean modules respectively.

5.3.1.9 Soiling loss index

The soiling loss index (SLI) is a standard metric for the effects of soiling on energy production. It is calculated from
the effective irradiances of a clean reference panel and a dirty test panel.

SLI = (1− EeffClean

EeffSoiled
) · 100

Equation 5.12: Calculation of SLI
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where EeffClean : efective irradiance of the clean PV module and EeffSoiled : effective irradiance of the reference PV
module.

5.3.1.10 Pyrgeometer incoming long wave irradiance Ein

Incoming long wave irradiance received from the atmosphere. Pyrgeometer equation by Albrecht and Cox.

Ein = Enet + σ · T

Equation 5.13: Pyrgeometer incoming long wave irradiance

where Ein is the long-wave irradiance received from the atmosphere [W/m²], Enet is the net irradiance at sensor surface
[W/m²], σ is the Stefan–Boltzmann constant 5.670374419 x 10-8 [W/(m2·K4)] and T is the Absolute temperature of
pyrgeometer detector [K].

5.3.1.11 Net radiation total NR

Calculation of the total net radiation for net radiometers.

NR = Eupshort−wave
+ Euplong−wave

− Elowshort−wave − Elowlong−wave

Equation 5.14: Net radiation total

where long-wave radiation must be calculated with the Section 5.3.1.10 formula.

5.3.1.12 Inflow angle

Angle off the horizontal plane at which the wind flow comes into the sensor.

φ = arctan(
Vz

Vh
)

Equation 5.15: Calculation of the inflow angle

where Vz is the vertical wind speed and Vh is the horizontal wind speed.

5.3.1.13 Linear equation

The linear equation can be used with any existing evaluation in order to apply an slope and offset. It can also be used
to provide a dimensionless measurement (e.g. from a previously configured Other sensor) with a unit, an evaluation
type, a height and a label for better interpretation.

A = Slope · B+Offset

Equation 5.16: Linear equation
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Formula

Linear	equation

Slope	*	Evaluation	+	Offset

Any	Evaluation

Other	Sensor	Other	Evaluation	R1C1_1

Offset

0.3

Slope

1

Evaluation	type

Temperature

Unit

°C

Label

Installation	height	(m)

0.0

Save

Delete

Figure 5.7: Evaluation for linear equation

5.3.1.14 Multiplication

Multiplication of two previously configured evaluations.

A = B · C

Equation 5.17: Multiplication

5.3.1.15 Turbulence intensity

Turbulence intensity (TI) is defined as the ratio of standard deviation of fluctuating wind velocity to the mean wind
speed, and it represents the intensity of wind velocity fluctuation. It is calculated at the end of the averaging period
(normally 10 minutes) and included in the measurement data CSV files.

TI = σ(U) / avg(U)

Equation 5.18: Turbulence intensity

where σ(U) is the standard deviation of the wind speed and avg(U) is the mean wind speed.

A commonly used procedure when analyzing turbulence data is to transform the horizontal wind vector in the geo-
graphical coordinate system into a rotated coordinate system that aligns with the mean wind direction during every
averaging period. The longitudinal TI is defined as the standard deviation of longitudinal wind speed, normalized with
the mean wind speed.

© 2011 — 2023 Ammonit Measurement GmbH 65



TI Long = σ(U) / avg(U)

Equation 5.19: Longitudinal turbulence intensity

where σ(U) is the standard deviation of the longitudinal wind speed and avg(U) is the mean wind speed.

5.3.1.16 Obukhov length

The Obukhov Length can be useful for turbulences analysis and is typically associated with a 3D ultrasonic sensor.
To add this evaluation, the measurement of wind speed, wind direction, vertical wind speed and virtual temperature at
one height are needed.

L = u*3 / ( K × g / avg(T) × σ(VZ, T))

Equation 5.20: Calculation of the Obukhov Length

u* = (σ(VX, VZ)2 + σ(VY, VZ)2) 1/4

Equation 5.21: Calculation of the friction velocity

where u* is the friction velocity [m/s], g the graviatitonal acceleration 9.81[m/s²], σ(VZ, T) the covariance of vertical
wind speed and virtual temperature and K the von Kármán constant 0.41.

5.3.1.17 Obukhov stability parameter

Dimensionless stability parameter given by the normalized measuring height above ground z with the Obukhov length
L. Can be useful for turbulences analysis and is typically associated with a 3D ultrasonic sensor. To add this evaluation,
the measurement of wind speed, wind direction, vertical wind speed and virtual temperature at one height are needed.

ζ = z / L

Equation 5.22: Calculation of the Obukhov stability parameter

where z is the height above ground and L is te Obukhov length as in Section 5.3.1.16.

5.3.1.18 Sensible heat flux

Sensible heat flux is measured with the eddy covariance method. In meteorology, it represents the heat exchanged
between the Earth’s surface and the atmosphere which resulted in a temperature change.

QH = ρ × Cp × σ(VZ, T)

Equation 5.23: Calculation of the sensible heat flux

where ρ is the air density 1.2[kg/m 3], C p the specific heat with constant pressure 1004.67[J/K/kg] and σ(V Z, T) the
covariance between the vertical wind speed and the temperature.

5.3.1.19 Solar zenith angle

The solar zenith angle is the angle between the zenith and the centre of the Sun’s disc. It is calculated from the
configured latitude and longitude and the time in the moment of the calculation.

66 © 2011 — 2023 Ammonit Measurement GmbH



Data Logger Meteo-40 Plus User’s Manual 67 / 258

Important
In order to use any formula based on the solar zenith angle, latitude and longitude of the measurement
station have to be entered or acquired with a GPS device in the System→ Administration menu (see also
Section 4.2).

5.3.1.20 Diffuse solar irradiance (DHI)

DHI[W/m²] = GHI[W/m²] − DNI[W/m²] · cos(θ)

Equation 5.24: Calculation of Diffuse Solar Irradiance

where θ is the solar zenith angle.

Note
If the DNI pyranometer was tilted or not alligned to north, tilt angle and cardinal direction must be introduced.

Tilt angle (°): (X axis) inclination angle with the Y axis aligned to north [-90°, 90°]

Cardinal direction (°): Clockwise rotation from north around the Z axis [0°, 360°]

5.3.1.21 Total apparent power

Apparent power is the product of the rms (root mean square) values of voltage and current. It is taken into account
when designing and operating power systems.

S[VA] = U1[V] · I1[A] + U2[V] · I2[A] + U3[V] · I3[K]

Equation 5.25: Calculation of total apparent power [S].
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Chapter 6

Data Evaluation

6.1 Introduction

As soon as Recording in the status box (see Section 3.2) is switched on, Meteo-40 plus records and stores mea-
surement data. In order to check current data, the web interface offers the possibility to have see the live data (see
Section 6.2). In the Datamenu, measurement data can be downloaded (see Section 6.7 and Section 4.2) and statistics
can be configured, which will be saved into CSV files.

6.2 Live Data Page

This page displays the currently measured data. The data are presented in a table and in a line chart.

Click on Start to display currently measured values. Stop pauses displaying data. The table shows all available data.
In comparison, the line chart can be customized by choosing sensors and connected channels.

Note
Enable JavaScript in your web browser to display live data in a chart.

6.2.1 Publishing live data

The Meteo-40 plus can be configured to publish live data every second to an XMPP server using the publish-subscribe
extension. The data are published using SSL/TLS encryption in JSON format.

The Meteo-40 plus authenticates itself with the server using the serial number as the local part of the JID, e.g.
”d123456@xmpp.test”.

Multiple clients can efficiently subscribe to and process the data. The Ammonit Live Data Aggregator is a tool to
generate and send statistics files using the published data which is configured on AmmonitOR (https://or.ammon
it.com/). Ammonit Live Dashboard (https://live.ammonit.com/) is an interactive program which visualises
live data in the browser.

Livedata server Select to which server you want to publish your data to. You can choose between Ammonit livedata
server and Custom server.

Publish live data to server Enable this checkbox to start publishing the live data.

Publish average data to server Enable this checkbox to start publishing average data.
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Server name The name of the XMPP server to which the data should be published, e.g. ”xmpp.test”. If you selected
Ammonit Livedata server as your Livedata server above, you will not be able to change this parameter.

Server port The TCP port for incoming XMPP connections, e.g. 443 or 5223. If you selected Ammonit Livedata
server as your Livedata server above, you will not be able to change this parameter.

Password Password to your custom live data server. If you selected Ammonit Livedata server as your Livedata
server above, you will not be able to change this parameter.

Allowed subscribers The Ammonit Live Data Aggregator can be enabled using the checkbox. Allow more JIDs
by entering them into the text box. Use a semicolon (;) between each JID. This is useful for Ammonit Live
Dashboard.

Allow unrestricted data access If you allow the unrestricted data acces using this checkbox, live and average data
along with the configuration will be published to the public nodes, where the data will be publicly avaliable to
anyone who subscribes to this node. It overrides the JIDs specified above in the Allowed Subscribers field.

6.3 Statistics Data Files

In the Data→ Statistics menu CSV files with statistics are listed and can be downloaded. Meteo-40 plus shows a
calendar with available statistics. Click on a month to highlight days with available CSV files. To navigate through the
calendar, click on a month or use the arrows to move one month ahead or back. Click on a highlighted day to list all
CSV files which have been generated for this day.

To view the available CSV files for a whole month, click on Show month; for a complete year, click on Show year. You
can jump between the years and months by clicking on a month or year in the calendar.

All CSV files for the selected period are listed in a table and the file name refers to the time interval covered. For each
file, a link to download the corresponding signature, its size in bytes, the methods through which the file has been
shared and a link to visualize the matching source data are available. To display the source data corresponding to a
file, click on the arrow in the Source column.

Below the list of CSV files it is indicated how many statistics CSV files are currently visible, from the available files in
the data logger, e.g. 1 of 53 files.

If CSV files have been uploaded to an AmmonitOR project, sent per Email, copied to a configured SCP/FTP/SFT-
P/FTPS server, or copied onto a USB stick, they will be tagged by a checkmark in the corresponding box.

To manually download or delete one or more files, select them and click Download selected or Delete selected re-
spectively. For the download, the CSV files will be compressed into one ZIP archive. If you want a certain file to be
sent or copied again, you can also mark the selected files as not sent with the option Mark as not sent.

Important
Deleting CSV statistics files does not delete the corresponding source data, statistics files can be generated
again as long as the matching source data are still in the Source data storage.

To immediately generate statistics files form the available source data, click on Generate now. Meteo-40 plus will
generate new files for the configured file interval, containing a line with the calculated statistics for each statistics
interval. For the standard configuration of daily file interval and ten minutes statistics interval, there will be 144 lines.

If Generate partial files is selected, not only the files for a complete file interval will be generated but also a file with
the residual data until the moment of the generation. This setting is only recommended for testing purposes.

Whenever statistics files are generated they are checked for a variety of known issues. If any checks fail, the files
will be marked as possibly inconsistent with a description in the Check column. Sometimes new software releases
perform new checks.

If many files are generated at once, the new ones will have a question mark in the Check column until they have all
been generated and checked.

Once the files pass the checks, the days will be shown in blue on the calendar with a tick in the Check column. Until
then, they are brown.
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If some files have been marked as possibly inconsistent, and the issue cannot be fixed, you can manually mark them
as ok with the Ignore errors button.

Under Maintenance we provide some options for trouble-shooting in case of CSV files generation problems. Clear
all sent files will replace all existing CSV files which have already been shared by any means (AmmonitOR, Email or
Remote Copy) with the text “CSV file removed via web interface” to free up memory. Fix checked files will inspect
all existing files, search for known issues and regenerate the files if needed. This option is only available if the data
logger detects any suspicious files. Files which have been replaced with an empty file as described in Clear all sent
files will be marked as suspicious. The Behaviour if file limit is reached option controls what happens when the system
is low on storage. When there are more than 10,000 statistics files or less than 30MiB free storage remaining, the
data logger stops creating new files. Changing the behaviour to automatically delete the oldest sent files will ensure
that these limits are not exceeded, and files continue to be generated.

Generate	now Download	selected Delete	selected Mark	as	not	sent

Statistics	calendar

2023 08

2023-08

Mon Tue Wed Thu Fri Sat Sun

	 1 2 3 4 5 6

7 8 9 10 11 12 13

14 15 16 17 18 19 20

21 22 23 24 25 26 27

28 29 30 31 	 	 	

Select
File Sig Size AmmonitOR Email Copy USB Check Source

2023-08-10	00:00:00

—

2023-08-10	23:55:00

↴ 1631 ✓ ↴

1	of	3	files

Ignore	errors

Maintenance

Behaviour	if	file	limit	is	reached

Stop	creating	new	files

Save

Show	month Show	year

◀ ▶

Clear	all	sent	files

Fix	checked	files

Figure 6.1: Downloading Statistics

6.3.1 Configuring Statistics and CSV files

In order to configure statistics and CSV files, go to the Data→ Statistics menu. You can define the interval over which
statistics will be calculated, and which statistics are needed.

Meteo-40 plus automatically suggests the standard statistics for each evaluation and channel. These can be removed
and additional statistics can be selected manually.
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Click on Select statistics in the Configure statistics section to create the statistics, e.g. average, maximum, minimum,
standard deviation, count, sum and median. Activate checkboxes to include evaluators and channels in the statistics.
Remove checkboxes to exclude evaluators and channels. Additionally, Meteo-40 plus displays internal current and
internal voltage in the CSV files.

Configure	statistics

Statistics	interval	for	files

10	min

File	interval

Daily

	Generate	partial	files	(not	recommended)

Statistics	interval	for	SCADA,	Switch	manager	and	snapshots

10	min

SCADA	Summary	interval

Daily

Save

Additional	Statistics	Files

Select	statistics

Secondary	files

Tertiary	files

Figure 6.2: Configuring the Statistics

The options are:

Select statistics Select individual statistics for every evaluator and channel. See Figure 6.4.

Statistics interval for files Defines over which time interval statistics are calculated, generating a new line in the
CSV file. Several intervals are available from 1/4 s to 1 h. The same statistics interval may appear in multiple
files if the recording is switched off and on again.

File interval Determines, how often a new aggregate data file in CSV format has to be created. Selecting Hourly,
produces one file per hour that includes data from the last hour. Daily generates only one file per day, etc.
Several intervals are available from every 5 minutes to weekly. The file interval is also applied to Gust data files.

Generate partial files Generate CSV files up to the current moment, even if the file interval has not yet finished.
This means that the latest file will be incomplete and regenerated later, so it is only recommended for testing
purposes.

Statistics interval for SCADA, Switch manager and snapshots Defines over which time interval statistics are cal-
culated from the live data. The calculation occurs at the end of the interval and the data are available over
SCADA, applied to switch manager, sent/copied as a snapshot and uploaded to an XMPP server if configured.
All current data from that period is considered to generate new aggregate data. Several intervals are available
from 2 s to 1 h.

SCADA Summary interval Applied only to the Summary statistic of the SCADA Modbus server. Typically used to
obtain a daily summary of sun status or precipitation measurements.

Secondary Files Suplementary statistics files can be generated with a different interval for the statistics calculation.
Secondary statistics can be configured here. See Section 6.4.
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Tertiary Files A further suplementary statistics interval can be configured here. See Section 6.4.

Warning
Be careful with setting the statistics interval and the file interval! Low values for the statistics interval lead
to huge statistics files, which you might need to remove manually once in a while. Low values for the file
interval lead to many small CSV files, which might be hard to handle.

Note
Low data file time intervals like 1, 2, 5 and 10 minutes are always delayed in generation by one or two
intervals. It means that 5 minute file will always be generated with the delay of 5 or 10 minutes. I.e. 5
minute interval file that should be generated at 12:00 (containing data from 11:55 to 12:00) will be first
generated at 12:05 or 12:10.

For solar-related evaluations Meteo-40 plus estimates certain values in addition to the measured values, i.e. esti-
mated sun status and estimated direct normal irradiation. In order to create the estimated values, the location of the
measurement station has to be entered in the System→ Administration menu. By default the estimated values are
not included in the CSV file. If required, select the values for the statistics.

Meteo-40 plus uses vectorial calculations for wind direction, i.e. vectorial average, direction maximum, direction mini-
mum, and vectorial standard deviation (Yamartinomethod). Hence, the calculatedminimum value for the wind direction
can be higher than the maximum in case of wind from northern directions.

d = atan2

(
n∑
i=1

sin(ϑi),
n∑
i=1

cos(ϑi)

)

Equation 6.1: Calculation of wind direction average

The equation for the average wind direction d is given by Equation 6.1 and converted to a value between 0 and 360°.

max. value 5°

90°

min. value 345°

180°

270°

Figure 6.3: Vectorial Calculation for the Wind Direction
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Evaluator/Channel Avg Max Min SDv Cnt Sum Med Val

Wind	Speed	(Top	Anemometer)

Wind	Speed	(Backup	Anemometer)

Wind	Speed	(Middle	Anemometer)

Wind	Speed	(Low	Anemometer)

Wind	Direction	(Top	Wind	Vane)

Wind	Direction	(Backup	Wind	Vane)

Wind	Direction	(Low	Wind	Vane)

Humidity	(Hygro/Thermo	@10.0m)

Temperature	(Hygro/Thermo	@10.0m)

Air	Pressure	(Barometer	@10.0m)

A1	(Hygro/Thermo	@10.0m)

A2	(Hygro/Thermo	@10.0m)

A3	(Barometer	@10.0m)

C1	(Top	Anemometer)

C2	(Backup	Anemometer)

C3	(Middle	Anemometer)

C4	(Low	Anemometer)

D1	(Top	Wind	Vane)

D2	(Backup	Wind	Vane)

D3	(Low	Wind	Vane)

Analog	Voltage	(Int.	Voltage)

Analog	Current	(Int.	Current)

Temperature	(Int.	Temperature)

Save

Back

Figure 6.4: Statistics Configuration Page

Press Save to finish the configuration of statistical values.

6.4 Secondary and Tertiary Statistics Files

Sometimes it is necessary, to have additional statistics on top of the standard, e.g. with a different statistics interval
or a different selection of values. You can activate the supplementary generation of statistics files with two different
configurations. The files will be listed in a similar table as the main statistics files (see Figure 6.5 and Figure 6.6). If
the files are generated, they will be automatically sent per Email or AmmonitOR alongside the main statistics files.

Warning
Beware that having more CSV files

1. is more work for the data logger, so more time and energy is consumed

2. fills the memory of the data logger faster

3. needs more bandwidth for data transmission
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6.4.1 Secondary Statistics Files

Select Generate additional files with secondary interval to activate the generation of the secondary files. You can
configure a statistics interval different from the main statistics interval. To select the statistics which will be calculated
and included in the secondary files, click on Select statistics.

Generate	now Download	selected Delete	selected

Mark	as	not	sent

Secondary	statistics	files	calendar

2023-08

Mon Tue Wed Thu Fri Sat Sun

	 1 2 3 4 5 6

7 8 9 10 11 12 13

14 15 16 17 18 19 20

21 22 23 24 25 26 27

28 29 30 31 	 	 	

Select File Sig Size AmmonitOR Email Copy USB Source

0	of	0	files

Ignore	errors

	Generate	additional	files	with	secondary	interval

Secondary	statistics	interval

10	min

Save

Show	month Show	year

◀ ▶

Select	statistics

Back

Figure 6.5: Secondary Statistics Page

6.4.2 Tertiary Statistics Files

Select Generate additional files with tertiary interval to activate the generation of the tertiary files. You can configure
an statistics interval different from the main and the secondary statistics interval. To select the statistics which will be
calculated and included in the secondary files, click on Select statistics.
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Generate	now Download	selected Delete	selected

Mark	as	not	sent

Tertiary	statistics	files	calendar

2023-08

Mon Tue Wed Thu Fri Sat Sun

	 1 2 3 4 5 6

7 8 9 10 11 12 13

14 15 16 17 18 19 20

21 22 23 24 25 26 27

28 29 30 31 	 	 	

Select File Sig Size AmmonitOR Email Copy USB Source

0	of	0	files

Ignore	errors

	Generate	additional	files	with	tertiary	interval

Tertiary	statistics	interval

10	min

Save

Show	month Show	year

◀ ▶

Select	statistics

Back

Figure 6.6: Tertiary Statistics Page

6.5 Gust Data Files

Detecting extreme wind events or gusts can be interesting to compare different geographical terrains or to estimate
wind turbines load. Meteo-40 plus offers the possiblity to generate extra CSV files including the measurements at the
maximum rate. To generate gusts data files you must activate this option in menu Data→ Gusts.

One gusts CSV file will be generated per day (or the configured file interval in Data→ Statistics menu) including all
wind gusts of that period. If no gust was registered during the period, an empty file is generated. Empty files will not
be visible in the Gust data files calendar but will be listed beneath.

To be considered a gust, the selected trigger evaluationmust exceed the configured threshold value aminimum number
of consecutive repetitons (minimum repetitions parameter) and not more than the selected maximum repetitions. The
gust as well as the previous and posterior number of seconds specified by time overhang parameter are included in
the gusts CSV file.
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Generate	now Download	selected Delete	selected

Mark	as	not	sent

Gust	data	files	calendar

2023-08

Mon Tue Wed Thu Fri Sat Sun

	 1 2 3 4 5 6

7 8 9 10 11 12 13

14 15 16 17 18 19 20

21 22 23 24 25 26 27

28 29 30 31 	 	 	

Select File Sig Size AmmonitOR Email Copy USB Source

0	of	0	files

Ignore	errors

Show	month Show	year

◀ ▶

Figure 6.7: Gust Data Calendar

Not every existing measurement is related to gusts analysis. The relevant evaluations must be selected. Press the
Select evaluations button to access the evaluations selection site and select which evaluations will be included in gusts
CSV files.

Evaluator Include

Anemometer	(Wind	Speed)

Wind	Vane	(Wind	Direction)

Hygro/Thermo	(Humidity)

Hygro/Thermo	(Temperature)

Save

Back	to	gust	data

Figure 6.8: Gust Evaluations Selection

Important
If the gusts data generation is activated in a running project, all existing source data will be analyzed and
gusts CSV files will be generated. This process could take several hours.

6.6 The CSV File Format

Meteo-40 plus stores measurement data in standard Comma-Separated Value (CSV) format with configuration infor-
mation in ini file format. The CSV format is documented in RFC 4180 (http://tools.ietf.org/html/rfc4180)
and well explained, e.g. in Wikipedia (http://en.wikipedia.org/wiki/Comma-separated_values). Ini files
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are described, e.g. in Wikipedia (http://en.wikipedia.org/wiki/INI_file) as well. CSV files can easily be
read by many programs and software tools, as can the ini file format. The CSV section and configuration footer are
separated by a blank line.

Note
In almost all cases, the CSV files created by Meteo-40 plus are compressed using GNU gzip (http:
//www.gzip.org/) with the typical file extension .gz. gzip compressed files can be decompressed
on all operating systems, see, e.g. Wikipedia (http://en.wikipedia.org/wiki/Gzip) for further
details.

6.6.1 Ammonit Meteo-40 plus specific details

Themeasurement data files of the Meteo-40 plus use the , (comma) as field separator, " (double quote) for embedding
commas in textual strings and UTF-8 as character set.

The CSV and ini parts are separated by one empty line.

6.6.1.1 Data part (CSV format)

The CSV part starts with a header line. This line is a comma-separated list of the statistics for each active channel
and evaluator. The first item of the list is the date/time entry.

Important
The date and time value shows the start time of the statistics interval.

Date and time format are similar to ISO-8601, e.g. 2014-07-17 15:50:00. The date and time values are always
the local time of the data logger. The timezone is stated in the second part of the file.

The evaluator statistics have the form Sensor;Evaluation;Statistic (e.g. Anemometer;wind_speed;Avg or
WindVane10bit;wind_direction;Count). Thereafter, the channel statistics are displayed in the form Channel;Statistic
(e.g. A2;Avg or C1;StdDev).

The statistics can individually be selected per sensor in the Data→ Statistics menu (see Figure 6.4).

According to the configured statistics interval, Meteo-40 plus calculates the statistics. Each time period is represented
in a line of the CSV file. The values are generally decimal numbers, using a point (.) as decimal mark. The number of
digits displayed after the decimal point is automatically calculated based on the measurement precision. For example,
an anemometer with a slope of 0.0462 m/sI uses two digits after the decimal point. The average and standard deviation
statistics include two additional digits to reflect the additional information from repeated sampling.

Language settings of the data logger do not have an influence on the CSV file.

The following evaluation types are available:
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wind_speed: Wind Speed,
wind_direction: Wind Direction,
humidity: Humidity,
temperature: Temperature,
temperature_differential: Differential Temperature,
air_pressure: Air Pressure,
air_density: Air Density,
solar_irradiance: Global Horizontal Irradiance,
solar_irradiance_diffuse: Diffuse Horizontal Irradiance,
solar_irradiance_direct: DNI·cosθ,
solar_DNI: Direct Normal Irradiance (DNI),
solar_irradiance_direct_sw: Estimated DNI,
solar_DNIcos_sw: Estimated DNI·cosθ,
sun_status: Sun Status,
sun_status_sw: Estimated Sun Status,
precipitation: Precipitation,
precipitation_intensity: Precipitation Intensity,
precipitation_status: Precipitation Status,
precipitation_sum: Precipitation Sum,
wind_speed_vert: Vertical Wind Speed,
counter: Counter,
voltage: Analog Voltage,
current: Analog Current,
status: Status,
active_power: Active Power,
power_factor: Power Factor,
reactive_power: Reactive Power,
apparent_power: Apparent Power,
obukhov_length: Obukhov Length,
dir_max_speed: Direction at max. Speed,
brightness_max: Brightness max. Value,
brightness_direction: Direction of Brightness,
frequency: Frequency,
inclination_angle: Angle of Inclination,
vibration_frequency: Vibration Frequency,
vibration_amplitude: Vibration Amplitude,
other: Other Evaluation,
any: Any Evaluation

The following statistics are available:

Avg: Average,
Max: Maximum,
Min: Minimum,
StdDev: Standard deviation,
Count: Count of valid values,
Sum: Sum,
Med: Median,
Val: First valid value

The last column of the CSV file is addr. This is the memory address in the source data storage for the start of the
interval.

6.6.1.2 Information part (Ini file format)

The information part contains data logger information as well as sensor details like installation height, slope and offset
values, as well as unit and sensor name.

The information part is included in every file. It can be found below the statistical data. The overall format of the
configuration is the following:

[Section 1]
key1=value
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key2=value
[Section 2]
key1=value

All section names, keys and values are case-sensitive and may contain unicode characters in UTF-8 encoding. While
sections and values may contain spaces; keys will not. Each section is unique; each key is unique within its section.
Neither the order of sections nor the order of entries within the sections are significant or guaranteed.

• [System]: Serial number in the format serial=D123456 and type of the data logger in the format type=Meteo-40L
the assigned name; timezone in the format timezone=UTC+01:00 (the offset can be positive or negative or be
missing, which indicates UTC); the location in decimal degrees and altitude inmeters: latitude=0.0 longitude=0.0
altitude=0.0 aswell as the software version and important system settings, e.g. cecs_power_permanent=true.
The gps_fix field indicates the timestamp of the most recent synchronisation with the satellite if GPS is used.

• [Summary] contains the date and time when the CSV file was created, the used source data storage, the summary
over the file time interval for configured precipitation, precipitation intensity, status and sun status evaluations and
total traffic for each network interface.

• [Evaluation] indicates file_interval and stat_interval (see also Section 6.3).
The file_interval, usually daily, can have the following values:
fiveminutes
tenminutes
fifteenminutes
twentyminutes
thirtyminutes
hourly
twohours
threehours
fourhours
sixhours
twelvehours
daily
weekly

The stat_interval, usually 10 min, can have the following values:
1 s
2 s
3 s
5 s
10 s
20 s
30 s
1 min
2 min
5 min
10 min
15 min
20 min
30 min
1 h

• [Adjustment]: CS1 and CS2 are the calibration values for the current source of Meteo-40 plus. The values are
for informational purpose only.

• [RX]: The rate of RS485 client number X is given in s, min or h; serial_setting for RS485 includes speed
without unit, as well as data format in conventional notation (e.g. 9600 8N1).

• [Sensor;Evaluator]

– statistic: List of statistics, which are calculated for the sensor, e.g. average, min, max.
– unit: Unit for the data, e.g. m/s.
– sensor_label: Name, which has been entered by the user in the sensor configuration.
– sensor_height: Installation height in meters, which has been entered by the user in the sensor configuration.
– sensor_type: Indicates the type of the sensor, e.g. anemometer. The following values are possible:
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anemometer: Anemometer,
wind_vane: Wind Vane,
hygro_thermo: Humidity / Temperature Sensor,
barometer: Barometric Pressure Sensor,
precipitation: Precipitation Sensor,
pyranometer: Solar Sensor,
ultrasonic: Ultrasonic Anemometer,
power_meter: Power Meter,
other: Other Sensor

– sensor_model: The model of the sensor, e.g. Thies First Class Advanced.
– formula: The type of formula used to convert the electrical values, e.g. linear.
– formula_params: Parameters, which are referenced to in the formula, including related channels and evaluator
parameters, e.g. A5 A6 var_offset var_slope. Values of the parameters are displayed in the lines below
the formula parameters, e.g. var_offset, var_slope, var_period, var_sensitivity.

• [Channel]

– statistic: List of statistics, which are calculated for the channel/sensor. For each statistic a column is displayed
in the upper part of the CSV file.

– unit: Unit of the calculated data. This is the SI unit for the type of quantity, however the unit for barometric
pressure might be either hPa or mbar, and the temperature unit is °C or K for differential temperature.

– rate: Configured rate for the channel with unit (not applicable for client channels).
– range: Configured range for analog voltage channels (Ax) with unit.
– protocol: Protocol, which is used for digital channels (Dx).

6.6.2 CSV import in LibreOffice or OpenOffice

Tip
Use LibreOffice (http://www.libreoffice.org/) Calc or OpenOffice.org (http://www.openoffi
ce.org) Calc. These are free, professional spreadsheet programs to process your CSV files.

The recommended settings to import the CSV file are shown in Figure 6.9.
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Figure 6.9: LibreOffice CSV-file import settings

6.6.3 CSV Import in Microsoft Excel 2010™

Depending on the version of Microsoft Excel™ the procedure can be slightly different. In general, we recommend
using the import assistant of Microsoft Excel™.

Note
Save CSV files always in a directory. The described process in Microsoft Excel™ does not work, when files
are opened via your email program.

1. Launch Microsoft Excel™ and open the Options window, which can be found in the File menu. Open the
Advanced menu. In the Editing options section deselect Use system separators and use . (dot) as decimal
separator and , (comma) as Thousands separator. See figure Figure 6.10.
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Figure 6.10: Microsoft Excel 2010™ CSV Import (1)

2. After setting the options, click on the Data tab as shown in Figure 6.11. In order to import the CSV file, click
on From Text in the group Get External Data, locate and double-click the file you want to import. Follow the
instructions in the Text Import Wizard.
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Figure 6.11: Microsoft Excel 2010™ CSV Import (2)

3. In the first step of the wizard choose Delimited as Original data type and select Unicode (UTF-8) for the file
origin. See Figure 6.12.

Figure 6.12: Microsoft Excel 2010™ CSV Import (3)

4. In next step define Comma as delimiter and ” as text qualifier as shown in Figure 6.13.
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Figure 6.13: Microsoft Excel 2010™ CSV Import (4)

5. In the last step of the wizard, select Text for the data format columns. See Figure 6.14.
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Figure 6.14: Microsoft Excel 2010™ CSV Import (5)

6. By clicking on Finish the file opens in your selected sheet. See Figure 6.15.

Figure 6.15: Microsoft Excel 2010™ CSV Import (6)

7. In order to change the cell format of the date and time columns from text to date time format, highlight the
column(s) and open Format Cells in the Numbers group on the Home tab. Select Custom and enter YYYY-MM-
DD hh:mm:ss.000 as shown in Figure 6.16.
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Figure 6.16: Microsoft Excel 2010™ Format Cells

6.7 Access to Source Data

Source data contains all electrically measured values neither interpreted nor aggregated statistically. If source data
are available and the used sensors are known, it is possible to re-evaluate a complete measurement campaign.

Important
Source data is only recorded, when recording is switched on!
See the note about recording in Section 5.1 for details.

The source data storage is organized as a ring buffer, which means that the oldest data will be overwritten when
the storage is filled entirely. For compactness reasons data is saved in a binary format and cannot be read directly.
However, you can view or download data.

To view or download source data, go to the Data→ Source menu. Meteo-40 plus displays all months and related
days, on which source data is available. As shown in Figure 6.17, select month, day and time period to display related
source data in the table below.
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2023 08

2023-08

Mon Tue Wed Thu Fri Sat Sun

	 1 2 3 4 5 6

7 8 9 10 11 12 13

14 15 16 17 18 19 20

21 22 23 24 25 26 27

28 29 30 31 	 	 	

HH:MM HH:MM HH:MM HH:MM HH:MM HH:MM

00:00 00:10 00:20 00:30 00:40 00:50

01:00 01:10 01:20 01:30 01:40 01:50

02:00 02:10 02:20 02:30 02:40 02:50

03:00 03:10 03:20 03:30 03:40 03:50

04:00 04:10 04:20 04:30 04:40 04:50

05:00 05:10 05:20 05:30 05:40 05:50

06:00 06:10 06:20 06:30 06:40 06:50

07:00 07:10 07:20 07:30 07:40 07:50

08:00 08:10 08:20 08:30 08:40 08:50

09:00 09:10 09:20 09:30 09:40 09:50

10:00 10:10 10:20 10:30 10:40 10:50

11:00 11:10 11:20 11:30 11:40 11:50

12:00 12:10 12:20 12:30 12:40 12:50

13:00 13:10 13:20 13:30 13:40 13:50

14:00 14:10 14:20 14:30 14:40 14:50

15:00 15:10 15:20 15:30 15:40 15:50

16:00

Date	and	Time A1 A2 A3 A4 C1 sw V I T addr
2023-08-11	15:45:00.000 0000001053x0

2023-08-11	15:50:00.000 5 0 0 3 3 1 3 1 2 0000001054x0

2023-08-11	15:55:00.000 0000001055x0

2023-08-11	16:00:00.000 2 3 2 2 4 1 5 4 2 0000001056x0

2023-08-11	16:05:00.000 0000001057x0

5	lines

◀ ▶

Source	data	only Evaluated	data	only Source	and	evaluated	data Download	ten	minutes

Download	hour Download	day Download	week

Show	all	weeks

Figure 6.17: Screenshot of the Source Data Page

The displayed source data can be downloaded as CSV file by clicking on the buttons below the table.

Download ten minutes Click to download a CSV file with source data of the selected 10min-period.
Download hour Click to download source data of the selected hour, i.e. source data of one table row. The source

data in the downloaded CSV file starts with 00:00 and ends with 59:59.
Download day Click to download source data of the selected day, i.e. the source data of the whole day from 00:00:00

to 23:59:59. If source data of the current day is downloaded, the CSV file includes all data up to the download
moment.

Download week Click to download source data of the week containing selected day, i.e. Monday 00:00:00 to Sunday
23:59:59.

Show all weeks Open a table of every week of source data for a complete overview and easier downloading.

Warning
The volume of downloaded source data can be huge, e.g. a filled 2 GB memory can lead to a 10 GB CSV
file.
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Chapter 7

Communication

7.1 Introduction

Depending on the usage of Meteo-40 plus, several communication methods are available:

Measurement
Campaign

Power Plant
Monitoring Maintenance (Site) Configuration

(Office)

Mobile Communiction
(GPRS, UMTS)

Directional Radio

Satellite

USB Flash Drive

Ethernet

RS485

Ethernet

WLAN

USB cable

Ethernet

WLAN

USB cable

Table 7.1: Data Transmission with Meteo-40 plus

The Meteo-40 plus web interface can be accessed via:

• LAN
• WLAN(WiFi) using a USB WiFi stick
• Modem for GSM/ GPRS, directional radio or satellite connection
• USB
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Tip
To download measurement data without accessing the Meteo-40 plus web interface, a pre-configured USB
flash drive can be used (see Section 4.2).

If Meteo-40 plus has been connected successfully to one of the above mentioned devices or networks, it is shown
on the data logger display under the menu Communication. USB and Ethernet connections are displayed in menu
Communication→ Devices→ LAN; a connected modem in menu Communication→ Devices→ Modem. WLAN
(WiFi) parameters are displayed in menu Communication→ Devices→ WLAN.

Note
When no USB device is connected, Meteo-40 plus displays one unavailable USB connection, which
refers to the USB-B slot. As soon as you connect Meteo-40 plus via USB with your computer the displayed
connection will change to active.

Once the connection has been established, further settings can be configured via the web interface. There are different
ways to collect data from Meteo-40 plus:

• Email
• Remote Copy
• AmmonitOR upload (also AmmonitOR installation on customer’s server) (AmmonitOR account is required)
• Direct download via web interface
• Direct download from data logger on USB flash drive

Data transmission between Meteo-40 plus and PC can be automatic (one-way) or interactive (two-way). Automatic
communication means that Meteo-40 plus sends CSV files by email or uploads data via SCP/FTP/SFTP/FTPS. Once
the actions have been configured, no further interaction is needed. Active communication implies an action by the
user, e.g. accessing the web interface while Meteo-40 plus is online. If a modem is used, you can access Meteo-40
plus via AmmonitConnect.

Automatic Communication Interactive Communication

• Data Upload to AmmonitOR
• Email CSV and other files
• Data Upload via SCP, FTP, SFTP or FTPS

• Online Access via AmmonitConnect
• Meteo-40 plus Configuration
• Data Download via Web Interface

Table 7.2: Automatic vs. Interactive Communication with Meteo-40 plus

The settings for data transmission or online access can easily be configured via the Meteo-40 plus web interface in
the Communication→ Schedule menu (see also Section 7.2). CSV files, which include measurement data, are stored
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on the data logger and can be downloaded directly from the data logger, sent automatically via email to an address of
your choice or uploaded automatically to an SCP/FTP/SFTP/FTPS server of your choice.

In order to configure the settings for each communication method, use the menu items: Online, AmmonitOR, Email,
Remote Copy, LAN,WLAN and Modem.

Tip
We recommend using our online platform AmmonitOR to manage and monitor measurement data. To
register and start using AmmonitOR, go to the AmmonitOR login page (https://or.ammonit.com/a
ccess/login/).

Port Direction Configurable Usage

21/tcp (FTP) outgoing yes
file transfer from
Meteo-40 plus to file
server

25/tcp (SMTP) outgoing yes
email transfer from
Meteo-40 plus to mail
server

53/tcp+udp (DNS) outgoing no domain name system

123/tcp+udp (NTP) outgoing no network time protocol
to set time and date

443/tcp (HTTPS) incoming no secure Meteo-40 plus
web interface

443/tcp (HTTPS,
XMPP) outgoing no software update and

live data

465/tcp (SMTPS) outgoing yes
secure email transfer
from Meteo-40 plus to
mail server

502/tcp (Modbus) incoming no Meteo-40 plus SCADA
service

587/tcp (SMTP with
STARTTLS) outgoing yes

secure email transfer
from Meteo-40 plus to
mail server

4040/tcp outgoing no
secure tunnel for
Meteo-40 plus web
interface

4041/tcp outgoing no

secure file transfer
from Meteo-40 plus to
file server, e.g.
AmmonitOR

Table 7.3: Ports used by Meteo-40 plus

7.2 Configuring the Communication Schedule

Actions are processes, which the data logger performs according to the settings in the Communication→ Schedule
menu. You select which action should be performed at which time and how often or how long during a day.

Meteo-40 plus turns on one minute before an action takes place and stays switched on as long as the action is running.
The status box in the web interface informs about the number of running actions.
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Note
If CECS is always active has been selected in the CECS power mode section of the System→
Administration menu, Meteo-40 plus does not switch off automatically. Refer to Section 1.4.1 for further
details.

Configuring the schedule includes defining the communication behavior during a day and selecting on which weekdays
an action should be performed. Each action starts performing at its Start Time and will be repeated according to
the defined Interval until the number of actions (Quantity) is achieved or a new day begins (00:00).

Online Indicates the periods, at which the Meteo-40 plus web interface can be accessed over the Internet. If config-
ured, a tunnel connection is established.

Note
Be carefully selecting the online intervals of the data logger. Connection costs can be very high
depending on the communication method. In most cases up to three online intervals of 20 minutes
are sufficient.

AmmonitOR Indicates, when and how often CSV files should be uploaded to an AmmonitOR account.

Email Indicates, when and how often emails with attached CSV file(s) should be sent. If necessary, CSV files are
generated automatically before emails are sent.

Remote Copy Indicates, when and how often CSV file(s) should be uploaded to a configured server using SCP, FTP,
SFTP or FTPS. If necessary, CSV files are generated automatically before upload.

Only generate CSV Indicates, when and how often CSV files should be generated without sending or uploading
them. Select this option to generate CSV files for the manual download via web interface or on USB flash drive.
According to the configured statistics (see Section 6.3), Meteo-40 plus generates CSV files on the selected days
at the scheduled times.

Action Mon Tue Wed Thu Fri Sat Sun
Start

time
Quantity Interval Next Progress Status

Online 12:00 1 0:00
2023‑08‑12

12:00
Run	now Waiting

AmmonitOR 12:00 1 0:00
2023‑08‑12

12:00
Run	now Waiting

Email 12:00 1 0:00
2023‑08‑12

12:00
Run	now Waiting

Remote

Copy
12:00 1 0:00 — Run	now Waiting

Only

generate

CSV
12:00 1 0:00 — Run	now Waiting

Online	duration

00:20

Save

Figure 7.1: Configuring the Schedule

Weekdays Select the weekdays on which the action should be performed.

Start time Enter the time of the first occurence on the given weekdays in 24-hour hh:mm format. For example, enter
14:00 when the action should start at 2 PM.

Quantity Enter the number of occurences which should be performed during a day. After raising the Quantity above
1, an Interval can be entered. The last action will be performed at the latest at midnight, even if the user’s
defined number of actions has not been achieved.
Enter the Quantity as integer, e.g. 2, 3 or 4.
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Interval Enter the time between successive occurences of the action. The Interval can be entered once the Quantity
of an action is raised above 1. Entering 01:00 means that the action will be performed hourly; entering 24:00
means that there is only one action per day possible.
Enter the Interval in the time format hh:mm.

Next Displays the date and time of the next occurence.

Status If the action has not run since the CECS booted, the status will be ”Waiting”. If the action is running, it will
describe what it is doing. Once completed, the status will be ”Finished”.

Online duration Enter the length of time (hh:mm), which the data logger should be connected to the Internet.
Example: start time 11:00, duration 00:20, quantity 2 and interval 03:00 means that the data logger will be
online at 11:00 and 14:00 for 20 minutes. Note that the duration should be shorter than the interval if the quantity
is greater than 1, but this is not enforced.

Note
Actions running just before midnight may be interrupted by the automatic CECS reboot. See Section 4.2
for details. The action will not be resumed in this case.

For immediate action, click Run now. You can also start an action over the display menu (see Section 4.4.1).

While Meteo-40 plus is online, the time elapsed is shown in the last column as percentage value. Otherwise, the Run
now button can be clicked to connect Meteo-40 plus immediately to the Internet.

Note
Consider the time settings for sending emails and uploading CSV files via SCP/FTP/SFTP. During night
hours the battery’s energy might be too low to send or upload large files.

Do not forget saving your modifications. Without saving the previous changes will be reset.

Tip
In order to save or reduce connection costs, we recommend carefully setting the online periods of the data
logger in the schedule. In most cases it is sufficient to configure not more than three time slots of 20 minutes
for Internet activity.

7.3 Configuring Online Access

The Meteo-40 plus web interface can only be accessed remotely, when the data logger is powered-on and an Internet
connection has been established. Periods for online access can be configured in the Communication→ Schedule
menu.

Important
Meteo-40 plus can be connected to AmmonitConnect (see Figure 7.2) to obtain a unique subdomain. Thus
the GSM modem can be equipped with a standard SIM card with dynamic IP address. AmmonitConnect
manages the subdomains. Users access the Meteo-40 plus web interface (when online) by entering its
subdomain, e.g. https:// subdomain .connect.ammonit.com. Additionally, the connection between
data logger and server is encrypted and therefore cannot be accessed by unauthorized users.

AmmonitConnect can be configured in the Communication→ Onlinemenu. You can choose between AmmonitConnect,
your own AmmonitConnect or no AmmonitConnect.
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Outbound
SSH

Access via direct interface (Ethernet or USB)

AmmonitConnect Server
(provides public IP address,
at which the data logger can
be reached on the Internet)

Access via HTTPS
connection

Figure 7.2: Communication between Meteo-40 plus and PC via AmmonitConnect

Note
If you use a SIM card with static IP address, an AmmonitConnect connection is not necessarily needed.
AmmonitConnect is still useful because it caches static files such as images.

AmmonitConnect

AmmonitConnect	server

Official	AmmonitConnect

AmmonitConnect	login

_ac-login@connect.ammonit.com

AmmonitConnect	port

4040

AmmonitConnect	access	code	(highly	recommended)

	Prevent	implicit	AmmonitConnect	activation	(only	recommended	for	satellite
communication)

AmmonitConnect	notify	address	(optional,	use	semicolon	(;)	for	more	than	one
address)

Save

Download	SSH	key

Link	to	AmmonitConnect

Remove	AmmonitConnect	identification

Figure 7.3: Configuring the Online Access

Meteo-40 plus offers three AmmonitConnect options (see Figure 7.3) in the Communication→ Online menu:

96 © 2011 — 2023 Ammonit Measurement GmbH



Data Logger Meteo-40 Plus User’s Manual 97 / 258

No AmmonitConnect Select this option, when you use a SIM card with static IP address or when you are connected
directly to the data logger via LAN (Ethernet) or USB.

AmmonitConnect Select AmmonitConnect (see Figure 7.2) to access the data logger’s web interface via an Am-
monitConnect domain link https://Dnnnnnn.connect.ammonit.com ).

Custom AmmonitConnect Enter AmmonitConnect login and AmmonitConnect port of your own AmmonitConnect
server. Your server has to authenticate the Meteo-40 plus data logger. Download the SSH key of the data logger
for authentication. Contact your system administrator for further details.

Download SSH Key Download SSH Key is only necessary, if you use your own AmmonitConnect server or an
AmmonitOR installation. The SSH public key is used to authenticate the data logger at your server.

Link to AmmonitConnect In order to get the URL to access your Meteo-40 plus data logger via AmmonitConnect,
click on Link to AmmonitConnect.

AmmonitConnect access code By using a AmmonitConnect access code, you prevent unauthorized Internet traffic
from reaching the data logger. This traffic might slow down your connection and increase Internet costs. For the
AmmonitConnect access code, you can use upper and lower case letters, number, and the underscore. Other
symbols are not allowed.

Tip
By entering an AmmonitConnect access code, connection costs can be saved. The login page of
the data logger is not visible for unauthorized users. Thus the URL of the data logger cannot easily
be spammed or attacked.

Once the AmmonitConnect access code has been entered in your browser, it is saved as cookie on your PC. The
AmmonitConnect access code only needs to be entered again on your PC after the cookie has been deleted.

Tip
By using AmmonitConnect with an AmmonitConnect Access Code, you can boost your connection to
your data logger. The AmmonitConnect server recognizes the IP address of your data logger in the
field. In some cases the IP address is accessible from outside (routable IP address of the installed
SIM card). However, in this case you can directly access your data logger via its IP address. There
is no need to use the detour via the AmmonitConnect server in Germany. AmmonitConnect still man-
ages the connection. In this case you can access the web interface of the data logger via the URL:
https://dnnnnnn-direct.connect.ammonit.com .
This feature works with all Ammonit Meteo-40 plus data loggers, no matter which firmware version is in-
stalled.

In order to access the data logger via AmmonitConnect, the URL of the data logger has to be entered in your browser,
i.e. https://dnnnnnn.connect.ammonit.com/ . On your first access via AmmonitConnect you have to enter
the AmmonitConnect access code, see Figure 7.4.
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URL:	https://loggerserial.connect.ammonit.com/

AmmonitConnect

Please	enter	your	AmmonitConnect	access	code.

	 Send

The	default	AmmonitConnect	access	code	is

Ammonit.

The	AmmonitConnect	access	code	must	be
configured	on	your	device	under
Communication/Connect.

It	prevents	unauthorized	access	to	the	login
page	of	the	device.

You	can	view	your	device's	connection	at
AmmonitOR.

©	2011-2023	Ammonit	Measurement	GmbH
www.ammonit.com

Figure 7.4: Entering the AmmonitConnect Access Code

Prevent implicit AmmonitConnect activation The data traffic can be reduced by selecting this checkbox. The fea-
ture is especially designed for satellite communication. By activating the checkbox, the connection is only
established according to the configured schedule (see Section 7.2). Other AmmonitConnect activations are
prevented.

AmmonitConnect notify address Any semicolon (;) separated XMPP addresses (JIDs) entered here will be con-
tacted when the data logger connects to or disconnects from AmmonitConnect. Those accounts will receive a
message from connect@ammonit.com which includes the timestamp of the connection, the installed software
version and links to the relevant online services.

Important
Meteo-40 plus can only be accessed via AmmonitConnect server, when the data logger is online! The
online periods are configured in the Communication→ Schedule menu.

If Meteo-40 plus is configured for AmmonitConnect and your data logger is currently not online, the following page
(see fig Figure 7.5) will be displayed.
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URL:	https://loggerserial.connect.ammonit.com/

AmmonitConnect

Your	device	is	currently	not	connected	to
AmmonitConnect.

If	you	believe	it	should	be,	please	check	that:

Your	device	is	configured	to	be	online	at	this
time

Your	device	is	configured	to	use
AmmonitConnect

You	can	view	your	device's	connection	at
AmmonitOR.

©	2011-2023	Ammonit	Measurement	GmbH
www.ammonit.com

Figure 7.5: Communication via AmmonitConnect (closed tunnel)

Remove AmmonitConnect identification Public key cryptography is used at Meteo-40 plus to identify the Ammonit-
Connect server in order to prevent man-in-the-middle attacks. During the installation, Ammonit includes the ssh
host fingerprint of the official AmmonitConnect server in the known hosts list of every data logger, to make it pos-
sible to use the AmmonitConnect service. If you are using a custom AmmonitConnect server, the new fingerprint
will be added to the data logger known hosts list on the first access to your AmmonitConnect server. If the Am-
monitConnect server ssh host key changes due to a server relaunch you must delete the old AmmonitConnect
host identification in order to allow the connection.

7.4 Configuration for using AmmonitOR

In the Communication→ AmmonitOR the AmmonitOR server can be selected, and one can configure which kind of
data is send to AmmonitOR.

If an Admin user set the option Force Encryption, the parameters cannot be changed with User permissions.

Note
If you do not have an AmmonitOR account yet, go to the AmmonitOR login page (https://or.ammon
it.com/access/login/) or click on Link to AmmonitOR to register. Further details about AmmonitOR
and a user manual can be found on www.ammonit.com (http://www.ammonit.com).

AmmonitOR server Select your preferred AmmonitOR server: Ammonit-hosted installation or your own AmmonitOR
server.
If you use the Ammonit-hosted installation, server details are filled automatically. If you use your own installation,
enter the necessary server details. Your local AmmonitOR server has to authenticate each data logger. To do
so, see Section 7.4.1.
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AmmonitOR project key Enter the Project key of your related AmmonitOR project. The Project key is displayed in
the project overview of your AmmonitOR project. It consists of four to six uppercase letters. You can connect
more than one data logger to an AmmonitOR project. To do so, use the same Project key for all project-related
data loggers.

Server, Port, Username Name or IP address of your AmmonitOR server, TCP port, and username for upload. These
values are automatically set correctly for the Ammonit hosted server.

Start date Files older than this date will not be transmitted to AmmonitOR.

AmmonitOR	server

Ammonit	AmmonitOR

AmmonitOR	project	key

Server

upload.ammonit.com

Port

4041

Username

upload

Start	date	(YYYY-MM-DD)

	Send	CSV	files

Send	logbook	data

Yes

	Send	configuration	file

	Send	camera	image

	Send	data	snapshot

	Send	gust	data	files

	Send	secondary	CSV	files

	Send	tertiary	CSV	files

Save

Save	and	copy	test	data

Reset	send	status

Download	SSH	key

Link	to	AmmonitOR

Figure 7.6: AmmonitOR Settings

Decide, which data should be monitored in AmmonitOR:

AmmonitOR send options
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CSV files Select this, if you want to send all measurement data to AmmonitOR.
If you do not want your measurement data sent to AmmonitOR, deselect this switch.

Logbook data Whether to send logbook entries. Select No to never send them, Yes to send them always on the next
day, or Immediately to send them with every scheduled email.

Configuration file Select this option, to send the data logger configuration file to AmmonitOR. Passwords and the
modem PIN will be stripped of the configuration file for security reasons.

Camera image Select this option, to send camera images to AmmonitOR. The camera image is taken at the moment
of the sending to AmmonitOR. See Section 4.5.1 to save the image to a USB stick instead of sending it.

Data snapshot Select this option, to send data snapshots to AmmonitOR. The data snapshot consists of the mea-
surements just in the moment of sending to AmmonitOR.

Gust data, secondary, and tertiary CSV files Select this option, to send gust data, secondary, or tertiary CSV files
to AmmonitOR.

Note
This files are only stored on AmmonitOR, but not yet interpreted in any way.

File Edit View Go Bookmarks Tabs Help

Back https://or.ammonit.com/projects/376/logger/591/connections/

Messages

Data logger
Overview
All evaluations (7 days)
Connections
Connection alarms
Logbook
Configurations
Photos

Data
Calendar
Data tables
Table of averages
Raw data files
Export data
Upload data

Plots
Correlation plot
Daily profile
Long term comparison profile
Monthly profile
Overlay graph
Shadow zone plot
Simple height profile
Speed direction bar
Speed direction dots
Sunshine hours
Turbulence intensity
Turbulence intensity polar
Wind direction
Wind speed
XY plot

Data logger Roof Mast (D110057)

Earlier connections View text View graphic

Showing connections from 2013-10-31 until 2013-11-30 (30 days)

Time in UTC

Day of month
Access this data logger via tunnel

00:00
01:00
02:00
03:00
04:00
05:00
06:00
07:00
08:00
09:00
10:00
11:00
12:00
13:00
14:00
15:00
16:00
17:00
18:00
19:00
20:00
21:00
22:00
23:00

31 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29

Figure 7.7: Connection Log in AmmonitOR

Reset send status With this function, Meteo-40 plus forgets about ever sending files to AmmonitOR. Any files will be
sent again.

Save and copy test data This function sends a test file to AmmonitOR. This is useful to check the connection and
settings, such as the project key.

Save Save the current settings.
Link to AmmonitOR Click on Link to AmmonitOR to set up a new AmmonitOR account.
Download SSH Key Applies only, when you use a local AmmonitOR installation (not the Ammonit-hosted installation).

Your AmmonitOR server has to authenticate each Meteo-40 plus data logger. To do so, download the SSH key
and see Section 7.4.1 and AmmonitOR user manual on the Ammonit website (http://www.ammonit.com/
en/ammonit-customer-login).

7.4.1 Authenticating Meteo-40 plus at your local AmmonitOR installation

If data files should be uploaded to a local AmmonitOR installation, the local AmmonitOR server has to authenticate
each Meteo-40 plus data logger. To do so, download the SSH key from each Meteo-40 plus data logger. The SSH
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key can be downloaded in the Communication→ AmmonitOR menu. Copy the SSH key on your local AmmonitOR
server.

Open the AmmonitOR administration web interface (admin rights are necessary) and enter the SSH key in the Base
→ SSH keys menu of AmmonitOR. For further details see AmmonitOR manual, which can be downloaded from the
Ammonit website (http://www.ammonit.com/en/ammonit-customer-login). After adding the key, the file
upload can be configured.

7.5 Configuring Email Parameters

In order to receive data via email from the data logger, Meteo-40 plus has to be connected to the Internet (e.g. via
modem) and an email account has to be configured in the Communication→ Email menu.

Important
Do not use your personal email account for data logger emails. We recommend setting up a separate ac-
count. Anyone logged in as either Admin or User on the data logger can access username and password,
and consequently the related email account.
The mechanism for sending emails with username and password is called SMTP AUTH, which is being
gradually phased out by some email service providers.
AmmonitOR can be configured to automatically export emails which doesn’t require an external email ser-
vice provider and avoids uploading the same files multiple times from the data logger.

Enter server and account details:

SMTP method Select the method used to secure outgoing SMTP transfers. SMTP (Simple Mail Transfer Protocol)
is a standard protocol used to send emails. Choose either SMTP over SSL/TLS (also known as SMTPS),
STARTTLS (establish an initially-insecure connection which is upgraded to a secure one before data transfer)
or unencrypted. Check with your email service provider for the supported methods.

SMTP server Enter SMTP server address, e.g. smpt.mail.provider.com. SMTP server details can be obtained from
your email service provider.

SMTP port Enter the SMTP port, or 0 for the default. The default is 465 for ”SMTP over SSL/TLS”, otherwise 25. The
port number can be found in the SMTP server details or from your email service provider. Some newer servers
use 587 for STARTTLS.

Verify server SSL/TLS certificates When using SMTP over SSL/TLS or STARTTLS, the server identifies itself by
sending a certificate. When this option is enabled, the data logger verifies that the configured server was issued
that certificate by a trusted authority. Disabling this option risks man-in-the-middle attacks.

SMTP username Enter the username, which is used to access your email account. Often the username is the same
as the email address.

SMTP password Enter the password, which is used to access your email account.

From Enter the sender’s email address, which is often also the username of the email account.

To Enter the email address of the recipient. If more than one email address should be entered, use a semicolon (;)
to separate the email addresses.

Cc If required, enter the recipient(s), who should receive the email in copy. If more than one email address should be
entered, use a semicolon (;) to separate the email addresses.

POP server (for POP-before-SMTP authorization) Only required for SMTP servers using POP-before-SMTP or SMTP-
after-POP authentication.

Start date (YYYY-MM-DD) Indicates which data files should be sent via email. No files older than the Start date will
be sent.
Enter the start date in ISO-8601 format: YYYY-MM-DD (e.g. 2016-01-31).

Maximal number of attachments Each email will contain at most this many attachments. If there are more than this
amount of attachments to send, then multiple emails will be sent.
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All other send options are explained in the AmmonitOR section, AmmonitOR send options.

According to the settings in the Communication→ Schedule menu (see Section 7.2), an email is sent to the specified
account including one or more CSV files. An email includes all CSV files generated since the last email was sent.

SMTP	method

SMTP	over	SSL/TLS

SMTP	server

SMTP	port	(e.g.	0	(default),	25,	465,	or	587)

0

	Verify	server	SSL/TLS	certificates

SMTP	username

SMTP	password

Show	password

From

To	(use	semicolon	(;)	for	more	than	one	address)

Cc	(use	semicolon	(;)	for	more	than	one	address)

POP	server	(for	POP-before-SMTP	authorisation)

Maximal	number	of	attachments

10

Start	date	(YYYY-MM-DD)

	Send	CSV	files

Send	logbook	data

Yes

	Send	configuration	file

	Send	camera	image

	Send	data	snapshot

	Send	gust	data	files

	Send	secondary	CSV	files

	Send	tertiary	CSV	files

Save

Save	and	send	test	email

Reset	send	status

Figure 7.8: Configuring Email Parameters
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In certain cases it might be necessary to reset the status of the data files sent via email. The data files can be resent
e.g. to another email address or if old files have been lost. Press Reset send status to set the send status of CSV files
listed in the Data→ Statistics menu to zero. The entered Start date indicates the data files, which should be reset for
email transfer.

Important
Do not forget saving the settings. By clicking the button Save and send test email, the configuration
can be checked.

Note
In order to test the email function, the data logger has to be connected to the Internet via modem, LAN or
WLAN (WiFi). It is not sufficient to connect Meteo-40 plus to a PC via USB, because a PC is not neces-
sarily configured as router. If your smartphone supports tethering, you can connect your smartphone and
configure it as router to test the email function of the data logger (see Section 4.3.1).

On the Statistics Data Download page in the Data→ Statistics menu all CSV files which have been sent via email
have a checkmark. See also Section 6.3.

7.5.1 Signing and Encrypting Emails and Attachments

Digital signature and encryption are very complex topics. By digitally signing an email or a file, its authenticity can be
verified. A valid digital signature indicates that the email or file was created by a known sender, e.g. your Meteo-40 plus
data logger (authentication), and the email has not been manipulated on its way to the receiver (integrity). By using
encryption, you can encode emails and attachments in a way that third parties cannot read the file, only authorized
parties are allowed to open and read the files. A password is required to decrypt emails and files.

Read this section carefully and follow our description step by step to avoid any misunderstandings. For further details
about digital signature and encryption, refer to Chapter 14.

Meteo-40 plus supports the international standard OpenPGP (https://en.wikipedia.org/wiki/Pretty_G
ood_Privacy#OpenPGP) for signing and encryption. Specifically, the free software GnuPG is used. Refer to the
GnuPG website (http://gnupg.org/) for further details.

In the Communication→ Email menu emails and attachments can be signed or signed and encrypted using OpenPGP.

Unsigned and unencrypted If emails should be sent neither with digital signature nor password protected, select
this option.

Sign data (OpenPGP) Select this option to digitally sign CSV and logbook files sent via email. The CSV and logbook
files sent by Meteo-40 plus are signed with a unique digital key. A certificate, indicating the digital signature,
is attached to the email for each CSV and logbook file. The attachments can, however, be opened and saved
without restriction.
As soon as a signed file is modified, the certificate is invalid.
In order to verify the certificate, download the Public key, displayed in the Meteo-40 plus web interface and
import the key into your local verification software, e.g. Gpg4win (see Section 7.5.1.1).

Sign and encrypt data (OpenPGP) Select this option to sign (as above) and encrypt CSV and logbook files sent via
email. Enter an Encryption password, which is required to decrypt the file on the recipient’s side.
In addition to the digital signature Meteo-40 plus can encrypt CSV and logbook attachments with a Private
key. The encrypted files can only be opened by authorized persons with the Encryption password. To do so,
additional software is required. See e.g. Section 7.5.1.1.
To decrypt the data, download the Public key by clicking on the button in the Meteo-40 plus web interface.
Import the Public key into your encryption software (see below). The displayed Fingerprint is used to
authenticate the Public key.
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7.5.1.1 Working with Gpg4win to Decrypt and Verify Files on Windows™ PCs

In order to open and read files, which have been encrypted by Meteo-40 plus, additional software is necessary. We
recommend installing GPG4win (GNU Privacy Guard for Windows). Ggp4win enables users to encrypt, decrypt, sign
and verify emails and attachments as well as files in a directory. The software includes the following components:

• GnuPG: encryption tool
• Kleopatra: certificate manager for OpenPGP
• GpgOL: add-in for Microsoft Outlook 2003/2007/2010/2013™ for email encryption
• GpgEx: plug-in for Microsoft Explorer™ for file encryption
• Gpg4win Compendium: documentation for beginners and advanced users

Go to the GPG4WiN website (http://gpg4win.de/download) and download the current software version. Install
the software with the above mentioned components.

Note
If you work with Microsoft Outlook™, the program has to be restarted to implement the GpgOL add-in as
separate ribbon. For decryption via the GpgOL add-in, go to Section 7.5.1.5.

Before working with Gpg4win, the software has to be configured. Download the Public key from the Meteo-40 plus
web interface, as shown in Figure 4.9.

Important
Each Meteo-40 plus data logger has its own unique public key. If you work with different Meteo-40 plus
data loggers, you have to import the public key of each Meteo-40 plus. One user’s private key is sufficient
to certify the public keys (as shown in Figure 7.11).

Import the Public key in Gpg4win via right-mouse click in the Windows Explorer™. A message is displayed after
successfully importing the key.

Figure 7.9: Importing the Public key into Gpg4win

Open the Kleopatra software. The Public key is listed under Other Certificates.
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The Public key of the Meteo-40 plus data logger has to be certified by your own key. If a user’s private key has
already been generated, skip the following task and go on with Figure 7.11.

If no user’s private key exists, create a new certificate via the File→ New Certificate menu. Select Create a personal
OpenPGP key pair and enter the required details. Click Create key and enter a high quality password. Your key should
have been successfully created.

Figure 7.10: Creating the private key

The Public key of Meteo-40 plus has to be certified. Go to Other Certificates and select Meteo-40 plus’s key. Open
the context menu via right-mouse click and select Certify Certificate.

Figure 7.11: Certifying the Public key

Before trusting the certificate, check the displayed Fingerprint with the Fingerprint shown in the Meteo-40 plus
web interface (see Figure 4.9).
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verify finterprint

Figure 7.12: Verifying the Fingerprint

Verify the certificate and enter the password for the Private key. The password is used to unlock the Private
key for the OpenPGP certificate. Finally both certificates are displayed under Trusted Certificates.

Figure 7.13: Trusted Certificates

7.5.1.2 Verifying digital signatures in the Windows Explorer™

If Sign data (OpenPGP) has been selected, each CSV and logbook file sent by Meteo-40 plus comes with a detached
signature file, i.e. a separate signature file (.sig) is attached to the email. The signature file has the same name as the
CSV or logbook file - ending on .sig.

Download and certify the Public key of Meteo-40 plus as described in Section 7.5.1.1.

Download both related files to your directory. Choose the data or logbook file, which should be verified. Open the
context menu with a right-mouse click on the .csv.gz, .log or .sig file and select Verify.
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Figure 7.14: Verifying signed files

Make sure that Input file is a detached signature is selected. Both related files should be listed, with the signature
ending on .sig in the Input file field. Select Decrypt/Verify. After verification the Kleopatra software indicates the
validity of the signature.

Figure 7.15: Successfully verified signature

7.5.1.3 Verifying digital signatures in Microsoft Outlook™

If Sign data (OpenPGP) has been selected, each CSV and logbook file sent by Meteo-40 plus comes with a detached
signature file, i.e. a separate signature file (.sig) is attached to the email. The signature file has the same name as the
CSV or logbook file - ending on .sig.

Download and certify the Public key of Meteo-40 plus as described in Section 7.5.1.1.

Open the email and select the file, which should be verified (ending on .csv.gz or .log). Click on Save and decrypt
in the Attachments ribbon of Microsoft Outlook™.
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Figure 7.16: Verifying files in Microsoft Outlook™

Make sure that Input file is a detached signature is selected. Both related files should be listed, with the signature
ending on .sig in the Input file field. Select Decrypt/Verify.

Figure 7.17: Verifying signatures in Microsoft Outlook™

After verification the Kleopatra software indicates the validity of the signature.
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Figure 7.18: Successful validation of the signature

Note
If test emails sent by Meteo-40 plus have been signed, a separate signature file is attached, e.g. Meteo-40
plus.txt.sig. To verify the signature, open the email and select both related attachments, e.g. Meteo-
40 plus.txt and Meteo-40 plus.txt.sig. Choose Save and decrypt in the Attachments ribbon of Microsoft
Outlook™.
Both files are listed in the Kleopatra software: Input file and Signed data (see Figure 7.19). Select Decryp-
t/Verify to validate the signature.

Figure 7.19: Verifying signed test mails

7.5.1.4 Decrypting files in the Windows Explorer™

Download and certify the Public key of Meteo-40 plus as described in Section 7.5.1.1.
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Encrypted files can be decrypted in the Windows Explorer™. Right click on the file and select Decrypt and verify.

Figure 7.20: Decrypting files via the GpgEx plug-in for Windows Explorer™

Start the decryption process by clicking Decrypt and verify.

Figure 7.21: Decryption via Kleopatra Software

For decryption enter the password, which you entered for encryption in the Meteo-40 plus web interface in the System
→ Administration menu.
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Figure 7.22: Password Prompt for Decryption

After successful decryption the file is displayed in the initial folder or the one selected in the decryption process.

Figure 7.23: Successful File Decryption

7.5.1.5 Decrypting files in Microsoft Outlook™

After installing Gpg4win a new ribbon GpgOL should be shown in your Outlook™ application. Follow our step by step
guide to decrypt encoded data files sent by your Meteo-40 plus data logger.

Download and certify the Public key of Meteo-40 plus as described in Section 7.5.1.1.

Open the email item and go to the Attachments ribbon (Click on one of the attached files). Click on Save and decrypt
in the Attachments ribbon.
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Figure 7.24: GgpOL add-in in Microsoft Outlook™

Select the folder, in which the files should be saved and start the decryption process by clicking on Decrypt/Verify in
the Kleopatra software. For decryption, enter the passphrase that you configured for encryption in the Communication
→ Email menu of the Meteo-40 plus web interface. See also Section 7.5.1.4.

Both encoded and decrypted data files should be successfully saved in the selected folder.

Note
In order to verify signed and encrypted test emails sent by Meteo-40 plus, open the email and selectDecrypt
in the GpgOL ribbon of Microsoft Outlook™. Enter the password, which has been set for Encryption in the
Meteo-40 plus web interface at the System→ Administration menu.

7.6 Configuring SCP, FTP, SFTP and FTPS Parameters

By using Remote copy you can upload CSV files to a server of your choice. To do so, Meteo-40 plus has to be
connected to the Internet, e.g. via modem.

The CSV file upload can be configured in the Communication→ Remote copymenu. Meteo-40 plus offers six methods
to upload data:

If an Admin user set the option Force Encryption, the parameters cannot be changed with User permissions.

SCP with SSH key Select this option to upload files via SCP to your server. The connection is encrypted with RSA
2048 bit. Enter server address, port, username and directory to enable the file upload. Contact your system
administrator for the server details.
To set this up, copy the data logger’s public SSH key to the authorized_keys file on the server. If in doubt,
ask your server administrator.

Note
The Directory can be either absolute, i.e. starting with a forward slash (/), or relative to the remote
users home directory, i.e. starting with a tilde and a forward slash (~/).

SCP with password This option is the same, but authenticates using the provided password instead of the SSH key.

FTP Select this option to upload files to your FTP server. Enter server address, username, password and directory
to enable the file upload. Contact your system administrator for the server details.
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Note
FTP transfer always uses passive mode, not active mode.

Warning
The file upload via FTP is not encrypted.

SFTP with SSH key or password SFTP is similar to FTP but encrypted using SSH. In principle, the same facts apply
as with SCP.

FTPS FTPS is similar to FTP but encrypted using TLS (also known as SSL).

All files uploaded via Remote Copy have a checkmark in the Copy column in the Data→ Statistics menu. See also
Section 6.3.
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Method

SCP	with	SSH	key

	Verify	server	SSL/TLS	certificates

Server

Port

0

Username

Password

Show	password

Directory

Start	date	(YYYY-MM-DD)

	Send	CSV	files

Send	logbook	data

Yes

	Send	configuration	file

	Send	camera	image

	Send	data	snapshot

	Send	gust	data	files

	Send	secondary	CSV	files

	Send	tertiary	CSV	files

Save

Save	and	copy	test	data

Reset	send	status

Download	SSH	key

Figure 7.25: Configuring the Remote Copy Parameters

By entering a Start date, you can configure which files should be uploaded. No files older than the Start date will be
uploaded.

All other send options are explained in the AmmonitOR section, AmmonitOR send options.

Important
Save your configuration. The entered values are reset after moving to another page.

Each upload includes all collected CSV files, which have been generated since the last file upload. If it is the first
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upload, Meteo-40 plus uploads all CSV files - no matter, how many CSV files have been generated. The sequence of
actions can be configured in the Communication→ Schedule menu. For further details refer to Section 7.2

Tip
If you are using Windows™, you might try the FileZilla (http://filezilla-project.org) FTP server.
After downloading and installing the software, you have to add a new user. Enter the appropriate fields and
select the folder, which should be shared. It is also important to configure Windows™ Firewall by adding
an exception for the corresponding port (21 for FTP) and the FileZilla server interface.

Warning
Make sure to download FileZilla only from its official website or other trusted sources. Malicious versions
have been released, that might copy private information to unauthorized parties.

7.7 Configuring LAN Parameters

Important
Restart the data logger or disconnect the Ethernet cable for some seconds to apply new network settings.

Meteo-40 plus data loggers can be connected to your LAN using a standard Ethernet cable. The network connection
will be automatically recognized. In order to access the Meteo-40 plus web interface, enter the assigned IP address
https://nn.nn.nn.nn/ in your web browser. The IP address can be found on the data logger display by selecting
the corresponding device at the Communication→ Devices→ LAN→ eth0 menu. Refer to Section 2.3 and Chapter 3
for more information about the login.

Note
If you are working with Meteo-40 plus Revision C with RS232 slot, you need an USB Ethernet adapter
to connect the data logger to your LAN. The production of Meteo-40 plus Revision C stopped in October
2012.

A table in the Communication→ LAN menu displays, which devices are connected, e.g. USB and / or Ethernet with
its state, IP address and product (if available).
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Interface State IP	Addresses

eth0 activated 172.17.0.2

	LAN	online,	whenever	CECS	is	on

IP	address	allocation	method

DHCP

	Connect	to	internet	via	USB	modem	only	(recommended	e.g.	for	SCADA	and	Ethernet	camera)

LAN	switch	(typically	S1)

None

IP	address

192.168.40.40

DNS	server

192.168.40.1

Gateway

192.168.40.1

Subnet	mask

255.255.255.0

Additional	subnets

Save

Check	optimal	BGAN	settings

Figure 7.26: Configuring LAN parameters

LAN online, whenever CECS is on The checkbox is selected by default. Thus after connecting Meteo-40 plus to
LAN via Ethernet, the data logger goes online as soon as the CECS subsystem is switched on.

Use DHCP, static IP, or link-local By default, Meteo-40 plus automatically obtains an IP address from aDHCP server.
DHCP is available in most networks. If DHCP is selected, the fields below are disabled. DHCP can be used to
connect a Meteo-40 plus to the internet through a local network without any further configuration.
For most SCADA applications, the data logger has to be configured with a fixed IP address by selecting Static
IP. Thus the use of DHCP server has to be deactivated. See Section 7.7.1 for more information.

Note
For upgrading the Meteo-40 plus firmware via the tethering function of your smartphone, the method
has to be set to DHCP. See also Section 4.3.1.

The Link-local method is useful for connecting a PC with Meteo-40 plus directly using an Ethernet cable. A
link-local connection cannot be used for internet access. This connection will not have an influence over a USB
modem communication and can be used for testing the modem.
Setting themethod to Disabledwill power off the Ethernet port which considerably reduces power consumption
while the CECS is on and Ethernet is not needed (e.g. when using a USB modem).

Connect to Internet via USB modem only (recommended e.g. for SCADA) Select this checkbox to set the USB
modem connection as preferred Internet connection. This checkbox is not selected by default.
This function is only recommended, when the Ethernet port is used and the USB-modem is preferred for the
Internet connection, e.g. in SCADA applications or connecting a camera to the Ethernet port.

By choosing a LAN switch you can supply your router or modem, e.g. BGAN satellite modem. For further details about
BGAN modems refer to Section 7.9.7.
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7.7.1 Configuring a Static IP address in a LAN

In order to configure a static IP address in a LAN, go to the Communication→ LAN menu and select Static IP. Enter
the details for IP address, DNS server, Gateway and Subnet mask.

If the data logger has to be available from other subnets, e.g. if the SCADA client is located in another network segment,
it is possible to add additional subnets. The previously configured gateway will also be used for this subnets. A list
of IP numbers and subnet prefixes can be entered in Additional subnets field. Use a semicolon (;) to separate the IP
addresses, e.g. 192.168.13.0/24;192.168.14.0/24

Interface State IP	Addresses

eth0 activated 172.17.0.2

	LAN	online,	whenever	CECS	is	on

IP	address	allocation	method

Static	IP

	Connect	to	internet	via	USB	modem	only	(recommended	e.g.	for	SCADA	and	Ethernet	camera)

LAN	switch	(typically	S1)

None

IP	address

192.168.1.170

DNS	server

0.0.0.0

Gateway

0.0.0.0

Subnet	mask

255.255.255.0

Additional	subnets

Save

Check	optimal	BGAN	settings

Figure 7.27: Configuring a Static IP Address in a LAN

Note
If you are working with a SIM card with static IP address, it is not necessary to change the LAN settings.
Refer to Section 7.9.3.

7.8 Configuring WLAN

For local wireless access to the data logger, you can connect a WLAN (WiFi) USB stick to Meteo-40 plus. Meteo-40
plus will create a wireless access point (hotspot) and you can connect to this network and access the data logger web
interface.

Before using the WLAN function, Meteo-40 plus has to be configured. Go to the Communication→ WLAN menu and
select the checkbox Activate WLAN. According to the configured IP address and Netmask, the available IP addresses
range is shown.
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Important
Note down or copy the assigned IP address, as you need this IP address to access the Meteo-40 plus web
interface via WLAN!

Each Meteo-40 plus is delivered with a unique default WLAN passphrase. If you would like to change it, you may enter
a Passphrase consisting of at least eight characters. Click on Save to finish the configuration.

	Activate	W-LAN

IP	address

192.168.42.1

Netmask

255.255.255.0

Network

192.168.42.0

First	address

192.168.42.2

Last	address

192.168.42.254

Passphrase	(at	least	eight	characters)

Show	password

Save

Figure 7.28: Configuring WLAN Parameters

After successfully configuring the Meteo-40 plus, the new wireless access point must appear among the available
wireless networks at your computer. The new WLAN name is the serial number of the data logger (Dnnnnnn). Select
the WLAN and enter the Passphrase.

Open your browser and enter the configured IP address (see Figure 7.28).

Note
If you are already connected to a WLAN, a second WLAN connection could cause problems.

7.9 Configuring the Modem

Meteo-40 plus can be connected to the Internet viamodem to perform scheduled actions. UMTS/GSM/GPRSmodems,
or BGAN satellite modems can be configured. UMTS/GSM/GPRS modems are configured via the Meteo-40 plus web
interface in the Communication→ Modem menu.

Note
Depending on the SIM card used in the modem, a different APN (Access Point Name) has to be entered for
proper communication. If you use a SIM card with dynamic IP address, you can easily configure the modem
via our provider helper, see Section 7.9.1. If you use a SIM card with static IP address, an individual APN
might be necessary. Ask your provider for the correct APN. See also Section 7.9.3.
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In order to configure a BGAN satellite modem, refer to Section 7.9.7.

Important
We recommend configuring the modem in the web interface before connecting the modem to the data
logger.

Tip
If your SIM card gets locked, e.g. by entering the wrong PIN code, enter the PUK code to reset the PIN
code. See also Section 7.9.5.

On the upper part of the configuration page, the properties of the connected modem are displayed, e.g. signal strength,
operator, IP address and supported bands. If there is no modem connected, the fields are empty.

Telephone	number

*99#

APN

Username

Password

	Modem	online,	whenever	CECS	is	on	(recommended)

Modem	switch	(typically	S1)

S1

PIN

Save

New	PIN

PUK	(for	changing	the	PIN)

Save	new	PIN

Short	Message	Service

Use	provider	helper

SMS	configuration

Received	SMS	messages

Figure 7.29: Modem Configuration
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In the upper part of the screen, the current modem and connection properties are displayed:

State Connection status

Reason Reason of connection failure

Signal Signal strength

Operator Mobile network operator

IP Address IP address of modem

Product Product details

RX/TX Received/transmitted bytes

Bands Radio bands supported by the modem

Use the Provider Helper (see Section 7.9.1) to complete the required information or enter the details manually:

Number Depending on your provider, the phone number of the GPRS/ UMTS or satellite service has to be entered,
e.g. *99#.
If you are using point-to-point protocol (PPP, TCP/IP connection without GPRS or UMTS), enter the phone
number in the relevant field. In this case, the APN is not important, but username and password probably are,
depending on your provider.
In case of doubt contact your provider.

APN (Access Point Name) Enter the APN of the GPRS/ UMTS network, which can be requested from the provider
or can be found in the Internet. CDMA does not require an APN.
Use the Provider helper to set APN and provider details automatically. Check the details with your provider.
See Section 7.9.1.

Important
If you are using a SIM card with static IP address, the APN is different from the one offered in the
Provider helper. Ask your provider for the exact APN. See also Section 7.9.3.

Username Enter the username for the APN, if applicable.
The username will automatically be set by selecting the APN via the Provider helper.

Password Enter the password for the chosen APN.
Password is automatically set after selecting the APN via Provider helper.

Modem online, whenever CECS is on The checkbox is selected by default. Thus the modem establishes an online
connection as soon as CECS is switched on (automatically or manually). See also Section 7.9.4.
If the checkbox is deselected, the modem only turns on according to the defined actions in the schedule (see
Section 7.2).

Note
The default setting with activated checkboxModem online, whenever CECS is on can increase power
consumption - depending on modem type and location of the next transmitting mast.

Tip
By deactivating the checkboxModem online, whenever CECS is on, connection costs can be saved.
The modem will only be switched on according to the scheduled actions, and not if the CECS is just
switched on for maintenance purposes.

Modem switch A switch can be selected for automatic control of modem power supply at the Modem switch combo
box (see Section 4.6). An external relay will be controlled by the switch (see also Figure 13.1 for electrical
connection plans). The modem will be power cycled as needed to prevent possible modem hangups.
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Important
If the modem is connected via relay to the data logger, a switch must be configured. Without selecting
a switch for the modem, it will not be power cycled on data logger restart, e.g. after installing an
upgrade or at the end of an action requiring communication. The assigned switch has to be saved
to the data logger configuration. We highly recommend the usage of a modem switch, the modem
may otherwise misbehave.
Switch S1 is set by default for the modem. If a different switch is used to control the modem relay, it
must be accordingly selected. If the switch is not used for the modem, it can be deselected.

Note
The switch configured for the modem supply is not available for sensor configuration.

Important
If you use a BGAN satellite modem, a switch for the LAN connection has to be assigned in the
Communication→ LAN menu (see also Section 7.9.7).

PIN Enter the PIN code of the used SIM card.

Band restrictions By default, the modem decides which band to use to connect to the network. Some modems can
restrict which bands are allowed, and which one is preferred. The modem does not automatically reconnect
after changing this setting. Changing this setting is only recommended when certain bands do not work or are
unwanted.

New PIN This field is used, if you like or have to change the PIN. To use it, you need also to enter the PUK below.

PUK The PUK PIN Unlock Key (or Personal Unblocking Code, PUC) is used to activate the new PIN above.

SMS Click here to configure short message functions. See Section 7.9.2.

After connecting a modem, Meteo-40 plus shows certain modem properties in its display in the Communication→
Devices→ Modem menu. Use the right keyboard button to navigate to the modem properties. Additionally, you can
see the properties such as state, signal strength and bands in the table (see Figure 7.29) displayed in the web interface
in the Communication→ Modem menu.

Apply the configuration by clicking on Save. We recommend testing the modem connection. Therefore, activate the
checkboxModem online, whenever CECS is on. The state of the modem should change to Active, when the modem
has been configured successfully.

Close the modem connection by deactivating the Modem online, whenever CECS is on mode. If no action is running,
the modem connection is closed after 20 minutes from the last user interaction.

The connection will instantly be closed, when CECS is shut down in the System→ Administration menu or when the
modem is manually disconnected from Meteo-40 plus.

Important
If you close the modem connection while accessing the data logger over the modem, you will instantly lose
the communication with the data logger and you will not be able to access it until the next scheduled online
action (Communication→ Schedule).

7.9.1 Using the Provider Helper

In order to support users configuring modem settings, Meteo-40 plus offers a provider form, which can be started by
clicking on Use provider helper. After choosing continent and country, the form shows available providers and APNs.
Select the relevant APN and click on Finish to set APN, username and password in the modem configuration.
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Note
The Provider helper is designed for SIM cards with dynamic IP address. For SIM cards with static IP
address, refer to your provider to get the details for the modem configuration. See also Section 7.9.3.

The Provider helper does not fill in the number field. Enter number and PIN code manually to finish the modem
configuration.

Continent

Europe

Country

Germany

Provider

O2

Access	point	name/CDMA	access

internet	(o2	MMS)

Finish

Figure 7.30: Meteo-40 plus Provider Helper

7.9.2 Short Message Service

In order to configure the Short Message Service (SMS), go to the Communication→ Modem menu and select SMS.

	Enable	short	message	service

Receiver	number

SMSC

SMS	password

Show	password

Save	and	send	test	message

Save

Figure 7.31: Settings for Short Message Service

The parameters are:

Enable short message service Tick the checkbox to enable the SMS function of Meteo-40 plus.

Receiver number This number is currently only used for sending test messages, i.e. one should enter the telephone
number of a mobile phone. The number is not used for other SMS functions of Meteo-40 plus.

SMSC The SMSC (Short message service center) has to be configured for some mobile telephony providers and
SIMs, for others it is not necessary. In case of doubt, ask your mobile telephony provider.

SMS password Enter a password to use the SMS function. Without password the service is not possible. Use at
least eight characters for the password (numbers and letters are allowed).
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7.9.2.1 Sending a Short Message

If the SMS feature is activated and a password has been entered, a message can be sent to the telephone number
linked with the SIM in the modem. The content must be password command where password is the configured SMS
password and command is an SMS command. Be careful typing the password respecting upper and lower cases.

Command Description

info or just i, like information

Meteo-40 plus replies to the short message with
its serial number, software version, internal
voltage, internal current, and internal
temperature in that moment, and the current
recording pointer, as well as state of switches,
modem, and Ethernet.

online or just o, like online Meteo-40 plus tries to get online immediately
and replies the same details as information.

s N + or s N -, like switch N on/off (N
corresponds to the switch number)

Meteo-40 plus turns on or off the specified
switch and replies the same details as
information. E.g.:
s1+ to switch on S1
s2- to switch off S2.

Table 7.4: Short Message Commands

Note
If you are unsure about the telephone number of the SIM or whether SMS sending works, try the Save and
send test message function.

7.9.3 Working with Static IP SIM cards

If a SIM card with static IP address is used, refer to the configuration details given by your provider to complete the
fields in the Communication→ Modem menu. The APN for SIM cards with static IP address is different than for SIM
cards with dynamic IP address. The Provider helper is designed for SIM cards with dynamic IP address.

7.9.4 Two Ways to Establish an Online Connection via Modem

Note
For testing the USB modem communication you can use a link-local connection over USB or LAN simulta-
neously. This connection will not have an influence over the usb modem communication.

According to the actions scheduled in the Communication→ Schedule menu, Meteo-40 plus has to establish an online
connection. To do so, CECS of Meteo-40 plus has to be switched on (see also Section 1.4). Meteo-40 plus offers two
possibilities to set up or control the online connection via modem using the checkbox Modem online, whenever CECS
is on:

Modem is online to perform a scheduled action (checkbox inactive) An online connection is established, when
it is needed for an action, i.e. sending emails, uploading files or remote access according to the schedule (see
also Section 7.2).
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Modem is online, when CECS is running - independent of scheduled actions (checkbox is active; default) An
online connection via modem is established as soon as CECS (see also Section 1.4) of Meteo-40 plus is acti-
vated, either manually or according to the schedule in the Communication→ Schedule menu. The connection
is closed, when CECS is switched off.
By default the Modem online, whenever CECS is on checkbox is activated and the modem always goes online,
when CECS is running.

Important
The default setting with activated checkbox can increase power consumption - depending on modem
type and location of next transmitting mast.

We recommended deactivating this option, if the CECS always active mode (see Section 4.2) is selected. With
activated CECS always active mode, the modem will stay permanently online, despite the scheduled online
actions.
The mode is independent from the LAN online mode.

7.9.5 Reset PIN Code of Locked SIM Card

If a wrong PIN code has been entered and the SIM card has been locked, use its PUK code to create a new PIN code.
On the bottom of the modem configuration page you can find the appropriate fields (see Figure 7.29). Click on Save
to apply the new PIN code, which will automatically be copied in the PIN code field for the modem configuration.

Note
Sometimes, the modem will report that the SIM card is locked but the actual issue is connectivity. When
testing indoors, it can help to attach an antenna and place it outside or near a window.

7.9.6 Connecting a GSM/GPRS Modem to Meteo-40 plus

We recommend testing the modem connection before final installation in the field.

Important
In order to avoid PIN conflicts, we recommend configuring the modem before the modem is connected to
Meteo-40 plus.

Before connecting the modem to Meteo-40 plus insert the SIM card into the modem. Afterwards the modem can be
provided with power and connected to the data logger. If the modem has been successfully recognized, Meteo-40
plus shows the connection in its display Communication→ Devices→ Modem.

7.9.6.1 Information on Modem Sierra Wireless Airline Fastback Extend EDGE FXT009

If you are using the modem Sierra Wireless AirLine Fastback Extend EDGE FXT009, slide the SIM card into the
modem as shown in Figure 7.32.

Important
It is very important to lock the SIM card slot after inserting the SIM card into the modem. If the SIM card is
not properly placed, connection problems may occur.
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Figure 7.32: Inserting SIM Card into modem Fastback Extend EDGE FXT009

To customize the frequency bands of the modem, connect the modem directly to your computer via USB. If you are
using a Windows™ PC and the modem is not displayed in the Device Manager underModem, you require a driver file,
which can be downloaded from the Sierra Wireless (http://www.sierrawireless.com/) website. On Linux™
PCs, in general no driver file needs to be installed.

After connecting the modem to your PC, go to the Device Manager (see Figure 7.33) and open the properties of the
modem by double-clicking on the modem.

connected modem

Figure 7.33: Device Manager

Go to the Modem tab (see Figure 7.34) to get the name of the COM Port, to which the modem is connected, e.g.
COM5. Change the Maximum Port Speed to 57600 baud rate. Save the changes.
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COM port

change baudrate

Figure 7.34: Modem Properties

To switch from one supported band to another, you can configure your modem with the help of AT commands.

AT+WMBS=5 (to switch to 850/1900 MHz)
AT+WMBS=4 (to switch to 900/1800 MHz)
AT+WMBS=7 (to switch to 850/900/1800/1900 MHz)

In order to customize the frequency bands, a standard terminal program like PuTTY (http://www.putty.org/)
can be used. Open the program and enter the port number as Serial line and 57600 for the Speed as shown in
Figure 7.35. Open the command window (see Figure 7.36) of the terminal program. In order to test the connection,
enter ” at” and press Enter. If OK is shown, the connection is fine and you can change the frequency bands with the
above mentioned AT commands.

Warning
Make sure to download PuTTY only from its official website or other trusted sources. Malicious versions
have been released, that might copy private information to unauthorized parties.

enter COM port and speed

Figure 7.35: PuTTY Configuration
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Figure 7.36: PuTTY Command Window

Important
Restart the modem after modification.

7.9.7 Connecting a BGAN Satellite Modem to Meteo-40 plus

7.9.7.1 Pointing the terminal to the satelite

It is recommended to test the conectivity outdoors because pointing through a window introduces a slight drop in signal
strength. Most units have audible and visual pointing indicators. The terminal first needs to acquire GPS, which may
take a long time. Some units will then diplay pointing information to help with the orientation of the antena. Line-of-sight
to the satellite is required for connectivity.

7.9.7.2 Configuring Meteo-40 plus with BGAN Satellite Modem

Important
BGAN modems are not configured using the modem page, but in the LAN page, as shown in Figure 7.26.

BGAN satellite modems are connected via Ethernet to Meteo-40 plus. If you are working with Meteo-40 plus Revision
C with RS232 slot, you have to use an USB Ethernet adapter to connect the satellite modem to your data logger.

Configure DHCP to automatically assign an IP address to data logger Ethernet port and modem. Both Meteo-40 plus
and modem must be configured to use DHCP.

Use the software provided by its manufacturer to configure the BGAN satellite modem.

In order to supply the modem, select a LAN switch from the dropdown list in the Communication→ LAN menu. Hence
prior to the scheduled actions, the modem can be supplied via the Meteo-40 plus switch (see Section 7.7). For testing,
the checkbox LAN online, whenever CECS is on may be switched on. So the modem goes online as soon as CECS
has been switched on. After testing, this setting should be switched off to prevent excessive traffic.

For testing the satellite modem, go to the Communication→ Schedule menu and press Run now for the online ac-
tion. Go to the Communication→ Online menu and copy the AmmonitConnect address of the data logger, e.g.
https://dnnnnnn.connect.ammonit.com . Disconnect the data logger from your PC and / or LAN. After enter-
ing the copied address in your browser, you should be able to log into the Meteo-40 plus web interface.
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7.9.7.3 Recommended Settings for Satellite Connections

URL:	https://d001234.local/communication/lan/?screenshot=yes

Help Logout

Admin	on	D001234

Recording: Off Switch	on

Configuration: Unsaved Save

Connection: Ethernet

Remaining: ∞

Date/time: 2023-08-11	16:06:14	UTC

LAN

Please	turn	off	'CECS	is	always	active'

Please	activate	AmmonitOR	with	a	valid	project	key

Please	use	AmmonitOR	for	data	transfer

Please	configure	a	AmmonitConnect	access	code

Please	prevent	implicit	AmmonitConnect	activation

Please	configure	no	more	than	three	online	times	of	max.	one	hour	combined

Please	turn	off	LAN	online,	whenever	CECS	is	on

Please	do	not	use	EMail	for	data	transfer

Please	use	daily	CSV	files	with	10	minute	statistics	interval

Interface State IP	Addresses

eth0 activated 172.17.0.2

	LAN	online,	whenever	CECS	is	on

IP	address	allocation	method

DHCP

	Connect	to	internet	via	USB	modem	only	(recommended	e.g.	for	SCADA	and	Ethernet	camera)

LAN	switch	(typically	S1)

None

IP	address

192.168.40.40

DNS	server

192.168.40.1

Gateway

192.168.40.1

Subnet	mask

255.255.255.0

Additional	subnets

Save

Check	optimal	BGAN	settings

Figure 7.37: Check BGAN optimal settings

Use the Check optimal BGAN settings button to verify if all recommended settings are properly configured.

1. We strongly recommend sending data only to AmmonitOR, but not by email. The data transfer to AmmonitOR
consumes less bandwidth than email (see Section 7.2 and Section 7.4).

2. Use only few tunnel connections, e.g. twice or thrice a week for twenty minutes (see Section 7.2).

3. Use a tunnel access code to prevent unauthorized access to the data loggers login page (see Figure 7.3) which
can generate data traffic.

4. Prevent implicit tunnel activation, only recommended for satellite communication (see Figure 7.3).

5. Do not set the check on LAN online, whenever CECS is on (see Section 7.7).

6. Be sure to generate not too huge or too many CSV files by keeping the default of one file per day with 10 minutes
statistics interval (see Section 6.3). Avoid gust data files, which may get large, depending on configuration and
wind conditions.
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7.10 Troubleshooting

Some mobile service providers and also firewalls in corporate networks restrict the communication of mobile devices
to certain ports. The communication of the Meteo-40 plus data logger might also be affected. There are different
incidents, e.g. the tunnel connection does not work, but Rx/Tx traffic is possible or the tunnel is accessible, but
sending emails does not work. Reasons for this are often blocked ports by the communication service provider or the
firewall or broken DNS.

7.10.1 How to perform the test for tunnel and AmmonitOR

In the web user interface, just save the online/tunnel parameters or AmmonitOR settings. In this moment the data
logger checks the connection and presents the result.

Alternatively, you can do the check from the LC display. Go to Communication (Figure 7.38). Then select Communication
Check (Figure 7.39). This will take some time. After some seconds, you can see the results (Figure 7.40).

System
Status
Channels

> Communication

Figure 7.38: Select ”Communication”

Devices
Activation

> Check Connection
Schedule

Figure 7.39: Select ”Check Connection”

Tunnel accessible
Port 4040 open
AmmonitOR accessible
Port 4041 open

Figure 7.40: View results of check

If one of the servers is not accessible or a port is blocked, please contact your network administrator or mobile service
provider.
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Chapter 8

SCADA

8.1 Configuring Meteo-40 plus for SCADA

Meteo-40 plus SCADA Server can be used to monitor performance and production of wind farms by providing reliable
meteorological data. Meteo-40 plus data loggers support the standard protocols Modbus TCP/IP over Ethernet as
well as Modbus RTU over RS485 (server).

SCADA parameters can be configured in the Communication→ SCADAmenu. In order to activate SCADA for Meteo-
40 plus, select the checkbox Activate SCADA server.

	Activate	SCADA	server

SCADA	protocol

Modbus	RTU

TCP	port

502

	Allow	global	access

Allowed	client	IP	address(es)

Modbus	unit	id

3

RS485	server	speed

38400

RS485	server	data	format

8N1

Save

Edit	Modbus	register	map

Figure 8.1: Configuring SCADA Parameters

Depending on the SCADA system in which Meteo-40 plus is integrated, a protocol for data retrieval has to be chosen:

Modbus TCP over Ethernet If you use Modbus TCP, a TCP port has to be entered. The default value is 502. If
Allow global access is selected, the SCADA server will be accessible over every available TCP connection (e.g.
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Ethernet, Modem, USB-B), otherwise it will only be available over the Ethernet connection. By entering an IP
address in field Allowed client IP address, the access to the data can be restricted to a single IP. Only the client
with the specified IP address can request data from Meteo-40 plus. If the field is left empty or filled with value
0.0.0.0, any client is allowed to access the data. You can also introduce a list of IP addresses separated by a
semicolon (;), e.g. 192.168.13.5;192.168.14.6

Note
In most SCADA systems, the Ethernet interface should be configured properly with a static IP ad-
dress. Refer to Section 7.7 for further details.

Important
If a USB modem is connected to Meteo-40 plus and Ethernet is used for SCADA, it is necessary to
select Connect to Internet via USB modem only in the Communication→ LAN menu.

In order to connect Meteo-40 plus to a fiber optic, an industrial media converter 10/100BaseT to 100BaseFX
(-40–75 °C) can be used.
Make sure that your Modbus TCP client is addressing theMeteo-40 plus SCADA server with the properModbus
unit ID configured here. The default value is 1.
Modbus TCP uses the unit identificator for routing purposes in case of addressing a device on a MODBUS
or MODBUS+ serial line subnetwork. The Modbus TCP server is still sensitive for this parameter. For further
details see MODBUS Messaging on TCP/IP Implementation Guide V1.0b recommendations at The Modbus
Organization (http://www.modbus.org/).

Modbus RTU over RS485 S (server) If you are using the Modbus RTU protocol, Modbus Unit ID and RS485 serial
settings (speed and data format) have to be selected.
Available baud rates: 38400, 19200 and 9600 bits per second.
Available serial settings (data/parity/stop): 8N1, 8N2, 8E1.

Note
Some SCADA clients require a half-duplex (2-wire) RS485 interface. In order to convert the 4-wire
RS485 signal delivered by Meteo-40 plus Revision C data loggers into a 2-wire (half duplex) signal,
an accessory module has to be implemented. Refer to the separate data sheet provided by Ammonit.
For further details contact Ammonit.
The production of Meteo-40 plus Revision C stopped in October 2012.
The accessory module is not necessary for Meteo-40 plus Revision D data loggers (with Ethernet
port).

If you are using more than one Meteo-40 plus data logger in your SCADA system, each data logger requires
a unique Modbus Unit ID and all data loggers have to use the same RS485 serial settings (speed and data
format).

Save your settings. Otherwise, the configuration is reset to the previous values after moving to another page.

8.1.1 CECS power mode

To use Meteo-40 plus SCADA server, the CECS must remain permanently on (see also Section 4.2). This mode is
automatically set when the SCADA server is activated in the Communication→ SCADA. You can only switch it off
again after deactivating the SCADA server.

Important
CECS is a fully embedded Linux™ computer (see also Section 1.4). Be aware that the power consumption
of Meteo-40 plus is higher, when CECS is switched on.
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8.1.2 Statistics selection

It is possible to request both live data and statistics over SCADA (see available statistics). The time interval over which
the SCADA statistics are calcuated defaults to 10 minutes and can be modified in menu Data→ Statistics menu (see
also Section 6.3.1).

Important
The same statistics interval is used for SCADA, the Switch manager and the data snapshots.

Summary statistics are normally used to calculate the summary over a complete day. It is available for precipitation,
precipitation intensity, status, sun status, bat passes and bat pulses evaluations. The SCADA summary interval can
also be changed in Data→ Statistics menu.

The Modbus register map in the Meteo-40 plus web interface only shows the selected statistics from the Data→
Statistics menu. Go to the Data→ Statistics menu and select the required data. See also Section 6.3.1.

8.2 Meteo-40 plus and Modbus

The configurable Modbus Register Map allows Meteo-40 plus to operate in most existing SCADA systems. The user
must determine which measurement values should be available for the SCADA client and configure a unique address
for each measurement (first reference is 0, available range is 0 to 65535). For more information about the supported
function codes see the public function code definition from the Modbus application protocol specification The Modbus
Organization (http://www.modbus.org/).

Important
Meteo-40 uses Protocol Data Unit (PDU) addressing, i.e. the start address is 0. Typically, reference num-
bers are one-indexed, meaning that the start value of a given range is one. Thus if your Modbus client
expects the value at register 400001, you must introduce addess 0 in Meteo-40 Modbus Holding Register
Map. No prefixing for the data blocks is used (e.g. 3 for input and 4 for holding registers).

All registers in range 0 to 65535 not selected to hold a measurement will contain the hexadecimal value FFFFh. If the
register is selected but no valid measurement is present, the invalid value corresponding to the configured data type
is written (see Table 8.1).

Data Type Invalid Value
short (16-bit integer) 7FFFh
ushort (16-bit unsigned integer) FFFFh
long (32-bit integer) 7FFFFFFFh
ulong (32-bit unsigned integer) FFFFFFFFh
IEEE 754 (32-bit single precision binary floating
point) 7FC00000h

Unix Time 00000000h

Table 8.1: Modbus Invalid values
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Input	Registers

Measurements Live Avg Max Min SDv Sum Med Val Summary Type Factor

Anemometer,

Wind	Speed

(m/s)
2 102 104 106 108 float	(IEEE754	32-bit) 1

Wind	Vane,

Wind	Direction

(°)
4 112 118 float	(IEEE754	32-bit) 1

Hygro/Thermo,

Humidity	(%)
6 122 124 126 128 float	(IEEE754	32-bit) 1

Hygro/Thermo,

Temperature

(°C)
8 132 134 136 138 float	(IEEE754	32-bit) 1

A1	(V) float	(IEEE754	32-bit) 1

A2	(V) float	(IEEE754	32-bit) 1

A3	(V) float	(IEEE754	32-bit) 1

A4	(V) float	(IEEE754	32-bit) 1

C1	(I) float	(IEEE754	32-bit) 1

Int.	Voltage

(V)
float	(IEEE754	32-bit) 1

Int.	Current

(mA)
float	(IEEE754	32-bit) 1

Int.

Temperature

(°C)
float	(IEEE754	32-bit) 1

Switches 	 	 	 	 	 	 	 	 ushort	(16-bit) 	

	 Year Month Day Hour Minute Second 	 	 	 	 	

Date/Time	Live 	 	 	 ushort	(16-bit) 	

Date/Time

Statistics
	 	 	 ushort	(16-bit) 	

Date/Time

Summary
	 	 	 ushort	(16-bit) 	

	 Live Start End 	 	 	 	 	 	 	 	

Unix	Time 0 100 	 	 	 	 	 	 ulong	(32-bit) 	

Unix	Time

Summary
	 	 	 	 	 	 	 ulong	(32-bit) 	

Holding	Registers

Set	date/time

Set	switches	state

	Measurements	to	holding	registers

Modbus	Endianness

Byte	endianness

Big	(most	significant	first)

Word	endianness

Big	(most	significant	first)

Save

Clear	Table

Download	Table	as	CSV

Back	to	SCADA

Figure 8.2: SCADA Modbus Register Table

Column Measurements Name of the evaluation, channel, or measurand. For every measurand either two or four
registers are used, depending on the data type selected (see Table 8.2).
Name of date, time, and switches fields. Every single value needs one register, with the exception of the UNIX
time (seconds since 1970-01-01 00:00:00 GMT), which needs two registers.

Columns statistics (Live, Avg, ... Med) In these fields, themodbus register number where eachmeasurement value
will be contained must be introduced.

Type For each evaluation or channel, a data type can be selected, e.g. float, (see Table 8.2).

Factor For each evaluation or channel, a scale factor can be selected, e.g. float, (see Table 8.2).

Live data Describes instantly measured data of the active channels (A n, AC n, C n, D n, R n C m, P n) and switches
(S n) as well as instantly evaluated data (Top Anemometer Wind Speed (m/s), Precipitation (mm), etc.).

134 © 2011 — 2023 Ammonit Measurement GmbH



Data Logger Meteo-40 Plus User’s Manual 135 / 258

Live data are updated in the Modbus store once per second. If a higher measurement rate is configured for a
sensor, only the last value of every second will be available over SCADA.

All live data values, including Live Date/Time and Live Unix Time, are written in the Modbus store with an atomic
operation. This guarantees that the time-stamps, in case configured, match the measurement values.

Aggregated / statistical data Statistics can be applied to channels and to evaluated data. All statistics data values,
including Statistics Date/Time and Start-End Unix Time, are written in theModbus store with an atomic operation.
This guarantees that the time-stamps, in case configured, match the measurement values

The SCADA interval for statistics calculation (Statistics interval for SCADA, Switch manager and snapshots)
defaults to 10 minutes and can be configured in the Data→ Statistics menu. This interval is applied for standard
statistics: average (Avg), maximum (Max), minimum (Min), standard deviation (SDv), sum (Sum, only for status
signals), median (Med) and value (Val). For the Summary statistics, SCADA summary interval is applied, which
defaults to daily. The summary statistics are calculated as a simple moving statistic at the end of every SCADA
interval for statistics calculation (i.e. 10 minutes with the default configuration).

Warning
If the CECS reboots, aggregated data are only available after the corresponding statistics interval or
summary interval is elapsed.

Important
Only statistics selected in menu Data→ Statistics(see Figure 6.4) are available here for retrieval.

In order to configure the Modbus server address of the data logger for serial subnetworks, go to the Communication
→ SCADA menu. For further details about Modbus see: www.modbus.org (http://www.modbus.org).
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Option Description

Measurements
Data Type and
Scale Factor

Date/time values, i.e. year, month, day, hour, minute, and second, as well as
state of the switches are represented as unsigned short values, stored in one
16-bit Modbus register each. Data type and scale factor do not apply to these
values.
For the measurement value representation, data type and scale factor have
to be selected. Data types short, ushort, long and ulong represent a
measurement value as an integer and store it in one or respectively two
subsequent 16-bit registers. To achieve higher resolution on the
representation or a wider range of values represented with a lower resolution,
the original measured value can be divided by a scale factor before storing it
into the registers as an integer. The default data type is IEEE 754 standard in
binary32 format (32-bit single precision binary floating point), being values
stored in two subsequent 16-bit Modbus registers. In this last case, scale
factor 1 is recommended. See also Equation 8.1.

Modbus
Endianness for
SCADA Server

According to the Modbus Application Protocol Specification V1.1.b, Modbus
is a ’big-Endian’ protocol: ”Modbus uses a ’big-Endian’ representation for
addresses and data items. If a numerical quantity larger than a single byte is
transmitted, the most significant byte will be sent first.” Meteo-40 plus
endianness can be configured by the user via web interface and is set by
default to ’big-endian’ byte order and ’big-endian’ registers order
representation (high byte first, high word first). For example for value
-4.395978e-11, the representation is shown in table Table 8.3.

Modbus register
address
interpretation

For historical reasons, some devices use a starting offset to refer to Modbus
register addresses, depending on the function code used to read the data.
That means, a Modbus client may represent for example Modbus input
register 100 with address 30101 and Modbus holding register 100 with
address 40101.
Meteo-40 plus does not use this representation. Only the register address,
unique for each measurement that will be retrieved and in range 0 to 65535,
must be introduced at the Modbus register table. For the previous example,
only 100 should be introduced at the corresponding text box of the register
table.

Modbus Device
Identification

Some additional information relative to the physical and functional descripton
of the device is available with function code 43 (see Table 8.4).

Table 8.2: Optional Available Information and configuration

ValueSCADA =
ValueOriginal
Scalefactor

Equation 8.1: Scale Factor

Representation Byte Endianness Word Endianness
AE41 5650 Big (high byte first) Big (high word first)
5650 AE41 Big (high byte first) Little (low word first)
41AE 5056 Little (low byte first) Big (high word first)
5056 41AE Little (low byte first) Little (low word first)

Table 8.3: Modbus Endianness for SCADA Server
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Object Id Description Type

0x00 VendorName: ’Ammonit
Measurement GmbH’ ASCII String

0x01 ProductCode: Data logger
serial number (e.g. ’D151234’) ASCII String

0x03 VendorURL:
’http://ammonit.com/’ ASCII String

0x04 ProductName: Data logger
name (see Section 4.2) ASCII String

0x05 ModelName: Data logger type
(e.g. ’Meteo-40L’) ASCII String

Table 8.4: Modbus Device Identification

8.2.1 Input Registers

Input registers contain the measurement values configured by the user. Meteo-40 plus SCADA server instantly writes
measured values in the Live registers and the calculated statistics after each interval in the aggregated data registers.
These data can be read with modbus function code 04. Register addresses must be between 0 and 65535. The
following values can be accessed in modbus registers, if so configured in the table:

Live and statistical data of all active channels
Data logger internal values (Int. Voltage (V), Int. Current (mA) and Int. Temperature (°C))
Switches state
Unix Time (for live data and start/end of current statistics and summary intervals)
Live data time stamp (Date/Time Live)
Last second of the evaluated interval for statistical data (Date/Time Statistics)
Last second of the evaluated interval for summary data (Date/Time Summary)

Important
Only measurements selected in menu Data→ Statistics (see Figure 6.4) are available here for retrieval.

8.2.2 Holding Registers

Holding registers can be both read or written. If Write measurements to holding registers is selected, the
measurement values from the Input registers table will be also written in the same register numbers from the Holding
registers table. They can be read with function code 03.

Holding registers can be written by the SCADA client in order to achieve any of the following implemented functional-
ities.

Date/Time synchronization To synchronise data logger date and time over Modbus, configure the start holding reg-
ister number for the date/time value in the Modbus Register Map (Set Date/Time). By means of a single modbus
frame and function code 16 (write multiple registers), year, month, day, hour, minute and second must be written
in six subsequent registers, starting at the previously configured register number (16-bit unsigned short values).
A successful synchronization will be logged in the logbook.

Important
It is necessary to allow date and time synchronization over SCADA in Section 4.2.
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Set switches state If a register number is configured in Set switches state, it is possible to set the current state of
the switches. You can use modbus function code 6 (write single register) to control the state of all 8 switches
with one telegram or function code 5 (write single coil) to set the state of only one switch.
In the first case, you must write into the configured register the integer representing the state of all switches.
Each bit determines the state of one switch: ”0” for open, ”1” for closed switch.
In the second case the configured register is the first address and corresponds to S1. To change the state of
switch ’n’ (Sn) you must write the coil address.

Switch
number S8 S7 S6 S5 S4 S3 S2 S1

Bit
Position 7 6 5 4 3 2 1 0

Table 8.5: Set switches state

8.3 Cascading two Meteo-40 plus Data Loggers using RS485

An easy way to cascade two or more Meteo-40 plus data loggers to get more measurement channels, is to use one
Meteo-40 plus as RS485 SCADA client, and up to four Meteo-40 plus as RS485 servers. All data loggers have to be
connected as an RS485 bus.

Please be aware of the following characteristics of RS485 cascading:

• Due to the additional communication involved, there is a delay on the cascaded channels, between 1 and 2 seconds.
For most applications, where only 10 minute average data are relevant, this should not be a problem.

• The CECS of the servers must be always active, leading to a higher energy consumption.
• The servers do not necessarily have a connection to the Internet. If there is no additional modem or a router, the
data loggers cannot be accessed from remote nor can receive software updates easily.

• The client can only read up to 20 Modbus registers per server in one read instruction. Instead of using four Meteo-40
plus servers, one can also configure the same Meteo-40 plus up to four times to read different register sets. This
allows reading up to 80 Modbus registers from one server.

• Care has to be taken, that client and server configurations fit exactly.

8.3.1 Configuration of the servers

The Meteo-40 plus server or servers need to be configured as a SCADA device with Modbus RTU protocol and a
unique Modbus unit identifier. Note, that if you need to share more than 20 registers with the client, Meteo-40 plus
will need more than one read requests. Meteo-40 plus can perform until 8 read requests per second, of 20 registers
each. The CECS must be always active.

8.3.2 Configuration of the client

At the client side, every server has to be added as an RS485 sensor (Other Sensor/ Modbus RTU), introducing server’s
unit identifier as RS485 address. If you need to request more than 20 registers from one server, you must do this
configuring two different sensors with the same server unit identifier. After selecting the corresponding data type, the
resulting evaluations must show the same measurement value as at the server. For each of the measurement values
you should configure a custom evaluation using a linear equation in order to confer it the known unit and data type
(see Evaluation Helper).
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Chapter 9

Using the Display

The LC display of Meteo-40 plus with background light is able to show 4 lines, each with 20 characters. In order to
navigate through the menu or to perform an action, use the buttons next to the display.

Figure 9.1: Use of the Meteo-40 plus buttons

1. Press this button for a few seconds to switch Meteo-40 plus (CECS) on or off.

2. Navigate into a submenu or perform an action.

3. Scroll down in the menu list.

4. Leave the submenu, return to the previous menu.

5. Scroll up in the menu list.

Note
After connecting Meteo-40 plus to the power supply, the two lower LED lights (red and yellow) turn on for
a few seconds. When the LED lights turn off, Meteo-40 plus is ready and can be switched on.

9.1 Assigning Permissions to Display Users

In order to avoid that settings are accidentally modified by a display user, e.g. when measurement data is downloaded
on a USB flash drive, you can assign permissions to display users. The configuration can be changed in the System
→ Display menu (see also Section 4.4.1).

9.2 LED Lights

Meteo-40 plus has four LED lights next to its display. The two upper LED lights have not yet been assigned a function.
The two lower LED lights (red and yellow) turn on, when Meteo-40 plus is connected to a power supply and turn off as
soon as Meteo-40 plus is ready to be switched on. However, the lower LED lights show:

Red (third from the top) Indicates errors in measuring operation. For details see the error list in the display System
→ Errors→ Error List.

Yellow (lower LED light) Indicates that RS485 sensors are connected. According to the Modbus protocol the LED
light blinks, when a measurement is made.
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9.3 Navigating through the Display Menu

The display menu of Meteo-40 plus includes four main menu items and several submenu items. The main menu items
are System, Status, Channel and Communication.

In order to jump into a submenu or to perform an action, press the right button. To return to the previous menu, use
the left button. By pressing the upper or the lower button, you can navigate up and down the menu list. For further
details see Figure 9.1.

Some menu items allow you to reconfigure the system, e.g. Communication→ Devices→ LAN→ eth0→ Method,
which lets you change the connection method of the Ethernet port. Pressing right changes the ”>” symbol to ”>>”. You
can press up and down to change the value, and left to confirm the change. The changes will only be saved if the
display has the relevant permissions (see Section 9.1).

9.4 Menu: System

Submenu Submenu Item Description

Information
Data Logger

• Type
• Serial Number (Dnnnnnn)
• Channels

Version
• Software version
• Bootloader version

Memory

• RAM including % of memory
used

• Source Memory including %
of memory used. Note, that
the value can go beyond
100%, because the memory
is organized as ring buffer.

Time and Date
Clock Displays date and time, incl.

time zone

Set Clock

Sets date and time on
Meteo-40 plus according to
NTP server time and Time
Zone defined in the web
interface in menu System
→ Administration

Errors
Error List Displays the error list
Clear List Clears the error list

Table 9.1: Menu: System

9.5 Menu: Status

The Statusmenu includes the information shown in the status box of theMeteo-40 plus web interface (see Section 3.2
also). In order to switch recording on / off or to save the configuration, press the right navigation button next to the
display.
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Submenu Item Description

Rem. Time

• Infty = Infinity (if CECS always active is
selected)

• Remaining time in mm:ss

Recording

• On
• Off (no recording, e.g. after changing the
configuration)

Configuration
• Saved
• Unsaved (changes have been made)

CECS

• When needed
• Always (if CECS always active is
selected)

Ethernet
• Online
• Offline

Modem
• Online
• Offline

Tunnel
• Active
• Inactive

Jobs Number of currently running actions

Table 9.2: Menu: Status

9.6 Menu: Channels

The menu channels contains seven submenus: Evaluations, Analog Voltage, Analog Current, Counter,
Digital Lines, Switches and Internal. In order to set or display the values, press the right button until the
required value appears in the display.

Submenu Property

Evaluations

Displays current values of the evaluation, e.g.
wind speed, wind direction, temperature etc.
The order of evaluations is explained in
Section 5.1.3.

Table 9.3: Menu: Channels/Evaluations
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Submenu Submenu Item Property Range of Values

Analog A1 (Depending
on the data logger
type, Meteo-40 plus
offers 4, 8 or 12
analog voltage
channels)

Measurement
State On or Off

Value Displays the current
value

Settings
Range 0.1 V, 0.1–0.3 V, 1 V,

10 V

Rate

• 1/8 s–30 s
• 1 min–30 min
• 1 h

Switch
State On or Off

ID

Select the appropriate
switch. Depending on
the data logger type,
Meteo-40 plus offers
2, 4 or 8 switches.

Time

• 1/8 s–30 s
• 1 min–30 min
• 1 h

Table 9.4: Menu: Channels/Analog Voltage

Submenu Submenu Item Property Range of Values
Analog AC1
(Depending on the
data logger type,
Meteo-40 plus offers
none, 1 or 2 analog
current input
channels)

Measurement
State On or Off

Value Displays the current
value

Settings
Range 1 mA, 10 mA, 100 mA

Rate

• 1/8 s–30 s
• 1 min–30 min
• 1 h

Switch
State On or Off

ID

Select the appropriate
switch. Depending on
the data logger type,
Meteo-40 plus offers
2, 4 or 8 switches.

Time

• 1/8 s–30 s
• 1 min–30 min
• 1 h

Table 9.5: Menu: Channels/Analog Current
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Submenu Submenu Item Property Range of Values

Counter C1
(Depending on the
data logger type,
Meteo-40 plus offers
4, 8 or 12 counters)

Measurement
State On or Off

Value Displays the current
value

Settings Rate

• 1 s–30 s
• 1 min–30 min
• 1 h

Switch
State On or Off

ID

Select the appropriate
switch. Depending on
the data logger type,
Meteo-40 plus offers
2, 4 or 8 switches.

Time

• 1/8 s–30 s
• 1 min–30 min
• 1 h

Table 9.6: Menu: Channels/Counter

Submenu Submenu Item Property Range of Values

Digital D1 (Depending
on the data logger
type, Meteo-40 plus
offers 2, 4 or 8 digital
channels)

Measurement
State On or Off

Value Displays the current
value

Settings
Rate

• 1/8 s–30 s
• 1 min–30 min
• 1 h

Type

• None
• Thies10bit
• Thies8bit
• Status

Switch
State On or Off

ID

Select the appropriate
switch. Depending on
the data logger type,
Meteo-40 plus offers
2, 4 or 8 switches.

Time

• 1/8 s–30 s
• 1 min–30 min
• 1 h

ClockPin
CLK 5 V

Press the right button
to force the clock pin
to 5 V for 10 seconds.

CLK 0 V
Press the right button
to force the clock pin
to 0 V for 10 seconds.

Table 9.7: Menu: Channels/Digital Lines
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Submenu Range of Values
Displays a list of switches. Depending on the
data logger type, Meteo-40 plus offers 2, 4 or 8
switches.

On or Off

Table 9.8: Menu: Channels/Switches

Submenu Property
Voltage Displays the current value
Current Displays the current value
Temperature Displays the current value

Table 9.9: Menu: Channels/Internal

9.7 Menu: Communication

Submenu Submenu Item Property Description

Devices

Modem
Product Name (only
when a modem is
connected)

Quality: displays signal
strength
Status:
• Offline
• Active

Type: indicates
connection mode, i.e.
GSM
RX Bytes: displays sum
of bytes received
TX Bytes: displays sum
of bytes transferred

LAN

USB

State / Interface
• State: Active
• or Unavailable
• Interface: usb

IP / Netmask: displays IP
address and subnet
mask
Routes: displays router
or gateway address
MAC / Speed: displays
MAC address of the data
logger and the
transmission rate

Ethernet (network
connection)

State / Interface
• State: Active
• Interface: eth

IP / Netmask: displays IP
address and subnet
mask
DNS Servers: displays
DNS server addresses
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Submenu Submenu Item Property Description
Routes: displays router
or gateway address
MAC / Speed: displays
MAC address of the data
logger and transmission
rate
Method: DHCP/ Static
IP/ Link-local (can
be selected using the
keyboard)

WLAN
• Restart
• Active/ Inactive
• IP Address

The WLAN connection
can be restarted using
the display.

Activation

Modem: When needed
or Permanent (can be
selected using the
keyboard)
LAN: When needed or
Permanent (can be
selected using the
keyboard)
WLAN: Active or Not
active

Check Connection

Checks the connection
to Tunnel and
AmmonitOR servers, see
Section 7.10.1.

Schedule

Online • Online Perform the respective
actions immediately, by
pressing the right button.
The configuration for the
actions has to be done
beforehand. The dash
(-) is visible, if the action
is not active at the
moment, otherwise it
show runs or done.

AmmonitOR • AmmonitOR
• AmmonitOR Test

Email • Email
• Email Test

Copy • Copy
• Copy Test

Generate CSV • Gen. CSV

SMS • SMS Test
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Chapter 10

Sensors

Meteo-40 plus data loggers are designed for installation in wind and solar measurement campaigns. Thus the data
logger is compatible with all relevant sensor types. Depending on the data logger type a different number of sensors
can be connected to analog voltage, pulse or counter, digital, serial or status as well as analog current, current source
and RS485 channels. See also Chapter 11 and Section 1.3.

Depending on the measurement campaign different sensors are required. Find below a list of measurement instru-
ments for wind measurement and solar measurement purposes as well as a list of other meteorological sensors and
different measurement devices.

Note
If the sensor you want to connect is not listed in this manual, refer for technical details and connection
plans to the data sheets on the Ammonit website (http://www.ammonit.com) or contact our sales team
(+49-30-6003188-0 or info@ammonit.com).

10.1 Sensors for Wind Resource Assessment and Wind Farm Mon-
itoring

In order to evaluate the wind conditions at a specific location, various measurements for wind resource assessment
are required. According to IEC 61400-12-1 horizontal wind speed, wind direction as well as air density have to be
measured. Wind energy is calculated as follows:

P = 1/2ρ · A · v³

Equation 10.1: Calculation of Wind Energy [P]

where A is the area; ρ is the air density, ρ = p / (R • T), where p is the air pressure, T the air temperature and R the
gas constant; v is the wind speed.

Therefore, wind speed (v) is the most important parameter, as wind energy (P) is proportional to the cube of wind
speed. Δ1% wind speed ≈ Δ3% wind energy.

The following sensors are crucial for wind site assessment:
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Sensor Description Link

Anemometer (wind
speed)

• Most important parameter for wind
measurement

• Wind energy is proportional to the cube of
wind speed

• Install calibrated cup anemometers or
calibrated ultrasonic anemometers

• Heated sensors are recommended for
measurements in cold climates

Note
Vertical wind speed measurement
for turbulence and wind turbine load
analysis with 3D ultrasonic or pro-
peller anemometer.

Section 10.6
Section 10.8
Section 10.6.2

Wind vane (wind
direction)

• Important parameter for wind farm
micrositing

• Ultrasonic anemometers also determine the
wind direction

Section 10.7
Section 10.8

Temperature / Humidity
sensor

• Important parameters for air density
calculation

• Wind energy is linearly proportional to the
inverse of air temperature in K

• Measurement of relative humidity
recommended at high temperatures
according to IEC

• Combined air temperature and relative
humidity sensors available

Section 10.10

Barometric pressure
sensor

• Important parameter for air density
calculation

• Wind energy is linearly proportional to air
pressure

Section 10.11

Ultrasonic anemometer

• Evaluate horizontal wind speed and
direction; 3D ultrasonics measure vertical
wind speed for turbulence analysis

• Recommended for measurements in cold
climates, as ultrasonic anemometers do not
have moving parts and can be fully heated

Section 10.8

Table 10.1: Sensors for Wind Measurement

10.2 Sensors for Solar Resource Assessment

Certain solar measurements are necessary to design profitable solar power plants. Refer to the Ammonit website
(http://www.ammonit.com) to learn more about solar measurement systems. Depending on application (e.g. PV,
CSP, CPV) and size of the solar power plant different measurements are crucial.
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Insolation combines Direct Normal Irradiation (DNI) and Diffuse Horizontal Irradiance (DHI). Both are linked according
to the formula for Global Horizontal Irradiation (GHI):

GHI[W/m²] = DHI[W/m²] + DNI[W/m²] · cos(θ)

Equation 10.2: Calculation of Global Horizontal Irradiation

where θ is the solar zenith angle.

On a sunny day the insolation is 100 % GHI, 20 % DNI and 80 % DNI·cos(θ).

Sensor Description Link

Pyranometer

• Measures GHI (Global Horizontal
Irradiation), if installed horizontally

• Measures GTI (Global Tilted Irradiation), if
installed tilted as PV panel

• Measures DHI (Diffuse Horizontal
Irradiation), if shaded by a shadow ball or
shadow ring (installation on sun tracker)

Section 10.12.1

Pyrheliometer

• Measures DNI (Direct Normal Irradiation)
and has to be installed on a sun tracker to
follow the position of the sun on the sky

Section 10.12.3

Sunshine Duration
sensor

• Indicates the sunshine status as defined by
WMO (sunshine = direct irradiation exceeds
the level of 120 W/m²)

Section 10.12.4

Solar Tracker

• Capable to orient a payload towards the sun
Can be combined with different solar
sensors to measure solar radiation global,
direct and diffuse components

Section 10.12.5

Soiling Measurement

• Soiling and Irradiance Measurement
Systems collect critical data for evaluating
PV array performance

Section 10.19

Table 10.2: Sensors for Solar Measurement

Besides measuring the solar conditions at the site of the planned solar power plant, some additional measurements
might be necessary to design the solar power plant, e.g. wind speed, wind direction, air temperature, relative humidity
as well as air pressure (see Table 10.1). In some cases soiling detectors and precipitation sensors are required.

10.3 Other Sensors for Meteorological Purposes

There are several sensors, which are not mandatory for wind and solar resource assessment, but provide important
parameters for ground construction and other influential conditions, e.g. precipitation sensors.
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Sensor Description Link

Precipitation Rain
Gauge

• Measures the amount of precipitation (rain
gauge) Section 10.13

Laser Precipitation
Monitor

• Calculates SYNOP code (Surface Synoptic
Observations)

• Measures intensity of total precipitation
• Measures intensity of liquid precipitation
• Measures intensity of solid precipitation
• Calculates the amount of precipitation

Section 10.13.2

Table 10.3: Sensors for Meteorological Purposes

10.4 Devices for Electrical Measurements

Meteo-40 plus can be used to connect power meters, multifunction transducers or other electrical measurement de-
vices, e.g. for power curve measurement.

Device Description Link

Multifunction
Transducer

• Also power meters or measuring transducers
• Measure average phase voltage, current,
real and reactive power

Section 10.14

Table 10.4: Electrical Measurement Devices

10.5 Research Applications

Meteo-40 plus is also used for research applications. A large and always growing list of formulas, developed and tested
in collaboration with specialists, is included in the Evaluation Helper. For a complete list of the available formulas see
Section 5.3.1. Thanks to the Evaluation Helper, it is possible to apply a linear formula to live measured data for later
calculation of the standard statistics on this value. Most formulas combine different measurements and constants, like
the air density, the covariance or a plain additon. Some special statistics related to turbulences analysis like Obukhov
length or turbulence intensity can also be configured. The resulting value will be included in the statistics files.

In some research projects, a higher measurement rate can be needed. Over an RS485 client (RS485) port, Meteo-40
plus offers the possibility to record data from one RS485 sensor with a maximum polling rate of 8 Hz. If more than one
RS485 sensor is connected to the RS485 client, a maximum polling rate of 1 Hz is available. For the analog voltage
channels Ax, analog current ACx and digital channels Dx, the highest measurement rate is 8 Hz. However, for counter
channels Cx and period measurement Px the maximum is 1 Hz.

10.6 Anemometers

Anemometers measure the horizontal wind speed (velocity). This parameter is crucial for any wind site assessment.
Cup anemometers are the general standard type of anemometers. They are robust and resistant to turbulence and
skew winds caused by masts and traverses. Each anemometer should be individually calibrated and equipped with a
certified calibration report according to international standards (e.g. MEASNET). At least two anemometers have to
be installed on a met mast. Most anemometers can be equipped with electronically regulated heating.
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Refer to the Ammonit website (http://www.ammonit.com/) to learn more about anemometer behavior and
accuracy.

The wind speed (v) is determined by the linear function of the frequency (impulse) output (I):

v[m/s] =

{
slope[m] · I[1/s] + offset[m/s] : I > 0

0 : I = 0

Equation 10.3: Calculation of Wind Speed (v)

A counter value of 0 produces the minimal value, which matches the offset by default (see Equation 5.1).

For wind assessment campaigns it is required to perform an individual MEASNET calibration of each anemometer
in a wind tunnel to achieve optimal accuracy. After calibration, use the values for slope and offset according to the
calibration protocol.

Anemometers are connected to counter channels (Cx). Refer to Figure 13.11 for the connection diagram. Further
details about counter channels can be found in Section 11.2 and Section 12.2.

Anemometers can easily be configured in the Meteo-40 plus web interface via the Sensor Helper (see Section 5.1.2).

Sensor Order-No Description
Thies Anemometer FCA X
vibration extended - Modbus S11200 / S11200H See Section 10.6.1

Thies Anemometer FCA X
inclination extended - Modbus S11200 / S11200H See Section 10.6.1

Thies Anemometer FCA X -
Modbus S11200 / S11200H See Section 10.6.1

Thies Anemometer FCA X -
ASCII S11200 / S11200H See Section 10.6.1

Thies Anemometer First Class
Advanced S11100/S11100H

Thies Anemometer First Class P6100H/P6100
Thies Anemometer Compact S12100H
Thies Anemometer Classic P6121H
Anemometer Vento First Class
Vector L100 First Class S14100/S14100H
Risø P2546A S16100
Vaisala Anemometer WAA 252 S15100H
Young Propeller Anemometer
Model 27106T S17100 See Section 10.6.2

NRG #40 Anemometer S18200C
NRG #40 Anemometer linear S18200C Pure linear formula
Second Wind C3
Lambrecht Wind Professional
14522
Young Wind Monitor S17200
Met One 014 mini
Generic Anemometer

Generic Anemometer linear Pure linear formula for NRG
anemometers

Generic Anemometer PM

Table 10.5: Overview Anemometers
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Important
If you plan to install anemometer NRG #40H (Hall Effect), anemometer Risø P2546A (Reed switch) or
anemometer Thies (if open drain is used), an external circuitry is needed. This can be solved by an external
resistor or using an external module supplied by Ammonit. The external modules allow adaption for many
different types of sensors and provide stabilized and ripple-free voltage supply for the sensors. Refer to the
data sheet and contact Ammonit for further details.

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

Meteo-40 plus saves all electrically measured values to the source data (see Section 6.7). The calculated wind speed
in m/s is saved to the CSV file (see Section 6.6.1).

Note
The CSV file contains for all active channels the electrical values according to the chosen statistical inter-
val.

10.6.1 Thies First Class Advanced X

The anemometer Thies First Class Advanced X is a cup anemometer that can be connected to an RS485 client
port and offers a list of aggregated information like vibration frequency, inclination, corrected an uncorrected wind
speed. Thanks to the digital communication over an RS485 bus, this suplementary information can synchronously be
requested by Meteo-40 plus.

The corrected wind speed (EC 61400-12-1 Edition 2.0 compliant) is the result of correcting the influence of the atmo-
spheric pressure on the measured wind speed. Meteo-40 plus will acquire the measurement values of the lower table
every second, including measured frequency, corrected and uncorrected wind speed and 3-axis vibration frequencies.

If a Modbus RTU implementation is used (’Thies FCA X - Modbus’, ’Thies Anemometer FCA X vibration extended -
Modbus’ or ’Thies Anemometer FCA X inclination extended - Modbus’) and the option RS485 sensors check is active,
the sensor will be uniquely identified during configuration by requesting its hardware ID, which will be written in the
configuration file. The calibration table, which is applied to the measured frequency resulting from the uncorrected
wind speed at the second position of the table, is also requested and saved in the configuration file. If any changes
are detected in either the hardware ID or the calibration table, it is reflected in the logbook, including the time stamp
when the calibration was performed and the number of the calibration certificate.

Important
Due to the inherent time required in client/server protocols like Modbus or Thies ASCII protocol, if you
want to connect more than four RS485 sensors to the RS485 bus and request the measurement value
every second, it is not possible to request a long list of measurement data. Modbus protocol optimizes the
amount of data transmitted and you must use the plain version (’Thies FCA X - Modbus’) in this case.
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Model Channel
(Protocol) Description Measurement Data

Thies FCA X
vibration
extended -
Modbus

RS485
(Modbus RTU)

Registers 35013-35014,
35021-35022, 35025-35026,
35037-35050

Wind speed corrected (m/s)1
Wind speed uncorrected
(m/s)2
Frequency (Hz)3
Absolute atmospheric
pressure (hPa)
Status word⁴
Vibration frequency X (Hz)
Vibration amplitude X (mg)
Vibration frequency Y (Hz)
Vibration amplitude Y (mg)
Vibration frequency Z (Hz)
Vibration amplitude Z (mg)

Thies FCA X
inclination
extended -
Modbus

RS485
(Modbus RTU)

Registers 35013-35014,
35019-35022, 35025-35026,
35031-35035, 35049-35050

Wind speed corrected (m/s)1
Wind speed uncorrected
(m/s)2
Frequency (Hz)3
Housing interior temperature
(°C)
Absolute atmospheric
pressure (hPa)
Status word⁴
Inclination angle θ (°)
Inclination angle ρ (°)
Inclination angle φ (°)

Thies FCA X
one-step
calibration -
Modbus⁵

RS485
(Modbus RTU)

Registers 35019-35022,
35025-35026, 35037-35050

Wind speed with configurable
slope and offset (m/s)⁶
Temperature (°C)
Absolute atmospheric
pressure (hPa)
Status word⁴
Vibration frequency X (Hz)
Vibration amplitude X (mg)⁷
Vibration frequency Y (Hz)
Vibration amplitude Y (mg)⁷
Vibration frequency Z (Hz)
Vibration amplitude Z (mg)⁷

Thies FCA X -
Modbus

RS485
(Modbus RTU)

Registers 35013-35014,
35019-35022, 35025-35026

Wind speed corrected (m/s)1
Housing interior temperature
(°C)
Absolute atmospheric
pressure (hPa)
Status word⁴

Thies FCA X -
ASCII RS485 (Thies) Telegram 2

Wind speed calculated with
current calibration table (m/s)
Wind speed calculated with
standard curve (m/s)
Wind speed corrected (m/s)1

Thies FCA X -
Counter Counter Wind speed

corrected/calculated (m/s)

Table 10.6: Connecting Thies FCA X to Meteo-40 plus
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10.6.2 Propeller Anemometer Young

The Propeller Anemometer measures horizontal and vertical wind speed. However, it is not classified according to
MEASNET and IEC. The anemometer is widely used to measure vertical wind speed to analyse turbulences and the
wind load of a turbine.

The anemometer uses a transducer which converts linearly the rotational speed into DC voltage levels. Connect the
sensor to the analog voltage channels (Ax) of your Meteo-40 plus data logger.

The anemometer can easily be configured in the Meteo-40 plus web interface via the Sensor Helper (see Sec-
tion 5.1.2).

Sensor Order-No
Propeller Anemometer Young 27106T S17100

Table 10.7: Overview Propeller Anemometer

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

Meteo-40 plus stores all electrically measured values to the source data (see Section 6.7). The calculated wind speed
in m/s is saved to the CSV file (see Section 6.6.1).

Note
The CSV file contains for all active channels the electrical values according to the chosen statistical inter-
val.

10.7 Wind Vanes

Wind vanes indicate the horizontal wind direction. The evaluation of the wind direction enables the best possible
positioning of wind turbines. It is essential that a wind vane covers an entire 360° degree radius - without north gap.

Meteo-40 plus data loggers are capable of using different types of wind vanes: Digital Wind Vanes and Analog (po-
tentiometric) Wind Vanes. The Meteo-40 plus data logger comprises digital interfaces to connect several Digital Wind
Vanes.

In addition to Digital Wind Vanes Meteo-40 plus data loggers can make use of classical Analog Wind Vanes using a
potentiometer. Ammonit suggests using a five wire setup with two analog voltage channels to eliminate measurement
errors caused by cable length and voltage drops in the supply voltage of the wind vane.

Furthermore, wind direction can also be recorded using wind vanes with data transmission via RS485 bus.

1The air pressure compensated wind speed, based on the measured values recorded by means of the calibration curve (register
35013).

2Wind speed calculated at data logger from Frequency and current calibration table.
3Info: It is the directly measured, uncorrected frequency. Independent of the command FO (register 35049).
⁴Provides information about the condition of the transmitter.
⁵For the case that the calibration values are not saved in the sensor (not recommended).
⁶Calibration slope and offset can be applied to the directly measured, uncorrected frequency. Independent of the command FO

(register 35049).
⁷Amplitude vibration unit is mg, where 1g = 9.81m/s².
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Note
It is possible to introduce an installation offset and a calibration offset for a wind vane in the Sensor Helper
(see Section 5.1.2) of the Meteo-40 plus web interface. These values are internally added, but for docu-
mentation reasons there are two separate fields for them. The Installation Offset[°] must be filled
when the wind vane has not been precisely aligned to the north, e.g. when the wind vane has been aligned
to the mast. It specifies the angle between the North and the point the wind vane has been aligned to. The
second Offset field is meant to be used for the calibration offset.

D[°] = D[°] + offset[°] + installationoffset[°]

Equation 10.4: Wind Direction Offset

10.7.1 Digital Wind Vanes Tunnel Magnetoresistance (TMR)

Ammonit recommends installing digital wind vanes TMR to determine the wind direction. Wind vanes TMR deliver
higher precision and are less susceptible to mechanical wear because of their solid state design. Ammonit offers wind
vane Thies First Class TMR 10-bit serial-synchron and wind vane Thies Compact TMR 10-bit serial-synchron.

Wind Vane Accuracy
Thies Compact TMR ± 1°
Thies Compact POT ± 2°
Thies First Class TMR ± 0.5°
Thies First Class POT ± 1°

Table 10.8: Comparison of Wind Vane Accuracy

Each wind vane TMR requires one digital channel, whereas potentiometer wind vanes require two analog voltage
channels each. By installing wind vanes TMR instead of wind vanes POT, analog voltage channels are available for
other analog sensors, e.g. barometric pressure sensor, temperature or humidity sensors.

Tip
Considering a measurement system with wind vanes TMR a smaller Meteo-40 plus model with less chan-
nels can be sufficient.

Wind vanes TMR are connected to digital channels (Dx). Refer to Figure 13.13 for the connection diagram. Further
details about digital channels can be found in Section 11.3 and Section 12.2.

Wind vanes can easily be configured in theMeteo-40 plus web interface via the Sensor Helper (see Section 5.1.2). The
offset and installation offset are entered in degrees. The slope is also shown, but changing it is strongly discouraged.
The 10-bit gray code measured by the digital channel is multiplied by the slope to produce an angle. The 10-bit gray
code is between 0 and 2¹�, so any slope besides 360 / 1024 = 0.3515625 will produce incorrect results. If the wind
vane calibration indicates a slope close to 1, the product of the two slopes could be configured instead, but doing so
is not recommended.

Sensor Order-No
Thies First Class S21100H
Thies Compact S22100 / S22100H

Table 10.9: Overview Wind vanes TMR
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Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

D[°] = 10-bit gray code × slope + offset + installation offset

Equation 10.5: 10-bit digital wind vane formula

10.7.2 Wind Vanes with Potentiometer

To determine the wind direction with a potentiometer wind vane, e.g. Thies First Class and Thies Compact, Ammonit
recommends using a five wire connetion between data logger and wind vane. This five wire connection eliminates
voltage drops across the connection cables and also eliminates the negative impact of voltage drops in the sensor’s
supply. Select the Generic Analog Wind Vane sensor type to connect any wind vane using this equation with the
voltage range -10 V–+10 V.

The five wire connection method makes use of two consecutive analog voltage channels of the Meteo-40 plus data
logger: An, An+1. An records the total voltage of the potentiometer (voltage between vane supply and Ground), An+1

measures the voltage between wiper and Ground. The following equation shows the calculation of the wind direction
(D).

D[°] =
UAn+1[V]

UAn[V]
· 360°+ offset[°]

Equation 10.6: Calculation of the Wind Direction (D)

Refer to Figure 13.7 for the connection diagram. Further details about analog voltage channels can be found in
Section 11.1 and Section 12.2

Sensor Order-No Offset
Thies First Class S21200H 0° (if aligned to the North)
Thies Compact S22200 / S22200H 0° (if aligned to the North)

Table 10.10: Parameters for the configuration of potentiometric wind vanes

Important
If potentiometric wind vanes, e.g. Thies First Class, Thies Compact, Vector W200P, Vector W200P/L, NRG
#200P additional resistors for current limitation have to be used in the wiring setup. Contact Ammonit
regarding further details about the accessory module!

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

Meteo-40 plus stores all electrically measured values to the source data (Section 6.7). The calculated wind direction
in ° (degree) is saved to the CSV file (see Section 6.6.1).

Note
The CSV file contains the electrical values according to the chosen statistical interval for all active mea-
surement channels.
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10.7.3 Wind Vanes connected to RS485 client

Certain wind vanes have an RS485 interface. Meteo-40 plus data loggers can address up to eight smart sensors on
the RS485 bus.

Important
If you intend to connect more than one sensor to an RS485 client port, all connected sensors must use the
same protocol and serial settings. Additionally, each sensor needs a unique ID (RS485 address), which
has to be configured for the sensor. The transmission mode for all RS485-connected sensors has to be
configured as half duplex. See Section 11.6.

Wind vanes can easily be configured in the Meteo-40 plus web interface via the Sensor Helper (see Section 5.1.2).
See Table 10.11 for the configuration of RS485 wind vanes.

Model Protocol Description Channels / Evaluated
Data Required Configuration

Thies Wind
Vane TMR
RS485

Thies Telegram 3 RxCy_1: Wind direction Serial settings, address,
half duplex mode

Thies Wind
Vane First
Class
RS485

Thies Telegram 3 RxCy_1: Wind speed
RxCy_2: Wind direction

Serial settings, address,
half duplex mode

Thies Wind
Vane 8-bit
parallel via
ICP DAS
I7051

DCON

RS485
module to
connect two
Thies 8-bit
parallel wind
vanes

RxCy_1: Wind direction
vane DI: 0–7
RxCy_2: Wind direction
vane DI: 8–15

Serial settings: 38400
8N1, address: 6,
checksum: disabled

Table 10.11: Configuration of RS485 Wind Vanes

Meteo-40 plus stores all measured values to the source data (Section 6.7). The wind direction in ° (degree) is saved
to the CSV file (see Section 6.6.1).

10.7.4 Kintech Geovane™

Connecting the Kintech Geovane™ to Meteo-40 plus Plus is possible on two different ways: via RS485 or three analog
channels (two analog voltage channels A and one counter C). The true-north direction obtained must be combined
with the wind direction measured by the wind vane in post-processing. It is not recommended to apply the true-north
direction to the wind direction at one second data level.
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Model Protocol Description Channels / Evaluated
Data Required Configuration

Kintech
Geovane™
Analog

Cx: Direction True-North
Ax: Angle of inclination X
Ay: Angle of inclination Y

Analog output must be
activated

Kintech
Geovane™
ORN

NMEA ⁸ ORN
message

RxCy_1: Direction
True-North
RxCy_2: Angle of
inclination X
RxCy_3: Angle of
inclination Y
RxCy_4: Status byte

baud rate must be higher
than 9600 bps to
connect more than 4
RS485 devices

Table 10.12: Kintech Geovane™

10.8 Ultrasonic Anemometers

Ultrasonic anemometers must be connected to an RS485 client port (see Section 11.6). 2D ultrasonic anemometers
measure horizontal wind speed, wind direction and acoustic virtual temperature. 3D ultrasonic anemometers also
measure the vertical wind velocity, which is important for turbulence and wind load calculations.

Important
If you intend to connect more than one sensor to an RS485 client port, all connected sensors must use the
same protocol and serial settings. Additionally, each sensor needs a unique ID (RS485 address), which
has to be configured for the sensor. The transmission mode for all RS485-connected sensors has to be
configured as half duplex. See Section 11.6.

The following ultrasonic anemometers are included in the Meteo-40 plus sensor helper for easy configuration. More
Modbus sensors can be configured as Other sensor.

Model Protocol Description Channels / Evaluated
Data Required Configuration

Thies 2D
Anemometer Thies Telegram 3

RxCy_1: Wind speed
RxCy_2: Wind direction
RxCy_3: Acoustic virtual
temperature
RxCy_4: Thies Status
Byte⁹

serial settings, address, half
duplex mode, scalar
averaging over 1 s

Thies 3D
Anemometer Thies Telegram 3

RxCy_1: Wind speed
azimuth
RxCy_2: Wind direction
azimuth
RxCy_3: Wind speed
elevation
RxCy_4: Acoustic virtual
temperature
RxCy_5: Thies Status
Byte⁹

serial settings, address, half
duplex mode, scalar
averaging over 1 s

NMEA - Thies
Compact
Anemometer

NMEA Telegram 3 RxCy_1: Wind direction
RxCy_2: Wind speed

serial settings, address,
NMEA protocol, half duplex
mode, scalar averaging
over 1 s

⁸Compatible with Thies ASCII protocoll.
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Model Protocol Description Channels / Evaluated
Data Required Configuration

Lufft 2D
VENTUS-
V200A-UMB

Modbus RTU
input
registers 14
and 25

RxCy_1: Wind direction
RxCy_2: Wind speed

serial settings, address,
Modbus RTU protocol,
parity none

Gill Wind
Master Pro
3D

Gill Mode 4

RxCy_1: Wind direction
azimuth
RxCy_2: Wind speed
azimuth
RxCy_3: Wind speed
elevation
RxCy_4: Sonic temperature
(if activated)

serial settings (B5: 38400
bps, 8N1), address (default
Q), averaging inactive (G0),
sampling rate 20 Hz (P8),
polar polled (M4), output
format CSV (O1), Sonic
temperature activated (A3)

Gill Wind
Master Pro
3D - M3

Gill Mode 3

RxCy_1: Wind speed X
RxCy_2: Wind speed Y
RxCy_3: Wind speed Z
RxCy_4: Sonic temperature
(if activated)

serial settings (B5: 38400
bps, 8N1), address (default
Q), averaging inactive (G0),
sampling rate 20 Hz (P8),
UVW polled (M3), output
format CSV (O1), Sonic
temperature activated (A3)

Gill Wind
Master Pro
3D - XYZT

Gill Mode 4

RxCy_1: Wind speed X
RxCy_2: Wind speed Y
RxCy_3: Wind speed Z
RxCy_4: Sonic temperature
(if activated)

serial settings (B5: 38400
bps, 8N1), address (default
Q), averaging inactive (G0),
sampling rate 20 Hz (P8),
polar polled (M4), output
format CSV (O1), Sonic
temperature activated (A3)

Gill Wind
Observer /
WindSonic
2D
Anemometer

Gill Mode 4

RxCy_1: Wind direction
azimuth
RxCy_2: Wind speed
azimuth
RxCy_3: Sonic temperature
(if activated)

serial settings (B5: 38400
bps, F1: default 8N1),
address (default A),
averaging inactive (G0),
sampling rate 20 Hz (P8),
polar polled (M4), output
format CSV (O1), Sonic
temperature optionally
activated (A2)

Vaisala
WMT700
NMEA MWV

NMEA

WMT700
NMEA MWV
Data
Message

RxCy_1: Wind direction
RxCy_2: Wind speed

autoSend = 0 (automatic
messages disabled),
com2_protocol = 11
(WMT700 NMEA profile for
serial port COM2 MWV
protocol), com2_interf = 0
(RS485 interface for serial
port COM2), com2_delay =
10, wndUnit = 0 (m/s wind
speed unit), address = WI
(Weather Instruments),
device identifier = II

10.8.1 NMEA MWV V 2.0

Supported NMEA telegram: $WIMWV,<dir>,<ref>,<spd>,<uni>,<sta>*<chk><CR> <LF>

• <dir>: Wind direction xxx.x
• <ref>: Reference R = relative
• <spd>: wind speed xxx.x
• <uni>: Wind speed unit M = m/s

⁹Last value of the Thies status byte for the interval. Typical values for the Thies status byte are: 14 (0x0E) and 206 (0xCE) for a
correct behaviour; 225 (0xE1) and 97 (0x61) for malfunction. For more information see sensor’s manual.
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• <sta>: Status A = valid
• <chk>: Checksum (8-bit XOR, excluding $ and *)
• <CR>: Carriage return code, ASCII 0DH
• <LF>: Line feed code, ASCII 0AH

10.8.2 Thies Ultrasonic Configuration Options

Before connecting any Thies sensor to an RS485 client port, it has to be configured. Three Thies ultrasonic types are
available: 2D compact, 2D and 3D. You can use the Thies Device Utility software to configure your sensors (Thies
Device Utility software (https://www.thiesclima.com/en/Products/Accessories-Software/?art=2
16)).

Ammonit recommends configuring Thies ultrasonic sensors as follows:

Required settings

• Half duplex for transmission mode
• Unique ID for each sensor connected to the bus
• Heating ON/OFF

Further Thies-specific settings

• Voltage threshold for heating suppression: 17 V (HC=17)
• Serial settings: 38400 bps, 8N1 (data format)
• Average mode: scalar-averaged velocity and vectorial-averaged angle (AM=2)

Tip
For more information about Thies acoustic virtual temperature, see sensor’s manual.

10.8.3 Lufft UMB Configuration Tool

Before connecting any Lufft sensor to Meteo-40 plus, it has to be configured. Download and install the software UMB-
Config-Tool (https://www.lufft.com/de-de/produkte/download-de/software-umb-config-tool)
and follow the next steps:

1. Power on the sensor.

2. Connect sensor’s A-, B+ to your computer using RS485 to USB or RS232 adapter.

3. Start Config-Software-UMB and setup the connection in the Edit→ Connection settings menu.

4. In order to configure the sensor, switch all sensors temporarily to UMB protocol in the Options menu (follow
instructions).

5. Add the new sensor in the Edit→ Sensor menu. Select the appropriate type from the list and ID (default 1). Do
not exit this menu, press Configure to access the sensor configuration.

6. Load the profile from the sensor (press the button again, if it does not respond). Select the tab with sensor type
name and configure as described in the table above (see Section 10.8).

7. Store profile on sensor to apply the configuration changes to the sensor. Save the profile also to your disk to
keep a copy of the sensor configuration.

8. Close the configuration program, disconnect and power off the sensor. Connect the sensor to the data logger
and power on the sensor.

9. Add the sensor to the sensor list of the data logger in the Measurement→ Sensors menu, applying the same
configuration.
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10.8.4 Gill Wind Configuration Tool

Before connecting any Gill sensor to Meteo-40 plus, it must be configured accordingly.

1. Download and install Gill Wind Com (http://www.gill.co.uk/main/software.html).

2. Use the Wizard tool to change from the default configuration all parameters specified in the upper table (see
Section 10.8).

3. Use a different address for each unit connected to an RS485 client port. It is recommended that letters A to F,
K, M, N, and P are not used since they can appear in a data string and might result in erroneous poll responses.

4. Do not forget to save the configuration report in the Tools menu.

5. Close the configuration program, disconnect and power off the sensor. Connect the sensor to the data logger
and power on the sensor.

6. Add the sensor to Meteo-40 plus sensors list in the Measurement→ Sensors menu, applying the same config-
uration.

Note
Any wind magnitude lower than defined by sensor’s parameter K (default 0.050 m/s) will omit the wind
direction.

Important
Gill Wind Master sensors with firmware v7.01 can be networked with other Wind Master units on a 2-wire
RS485 bus. Units with older versions cannot be networked.

10.9 Weather and Environmental Integrated Monitoring Stations

Weather and environmental stations are capable of measuring a large amount of athmospheric conditions in only one
device. To acquire this data the preferred connection is RS485. These sensors can be connected to an RS485 client
port (see Section 11.6).

Important
If you intend to connect more than one sensor to an RS485 client port, all connected sensors must use the
same protocol and serial settings. Additionally, each sensor needs a unique ID (RS485 address), which
has to be configured for the sensor. The transmission mode for all RS485-connected sensors has to be
configured as half duplex. See Section 11.6.

The following weather and environmental stations are included in the Meteo-40 plus sensor helper for easy configu-
ration. More Modbus sensors can be configured as Other sensor.
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Model Protocol Description Channels / Evaluated
Data Required Configuration

Weather
Station Thies
Clima US
MODBUS

Modbus RTU

input
registers
35001-35006,
35013,
35014,
35017,
35018,
35029,
35030,
35033-35040

RxCy_1: Wind speed
RxCy_2: Wind direction
RxCy_3: Temperature
RxCy_4: Humidity
RxCy_5: Air pressure
RxCy_6: Direction of
brightness
RxCy_7: Precipitation
status
RxCy_8: Precipitation
intensity
RxCy_9: Precipitation sum
RxCy_10: SYNOP

BR=384, DM=0

Weather
Station Thies
Clima US

Thies Telegram 6

RxCy_1: Wind speed
RxCy_2: Wind direction
RxCy_3: Temperature
RxCy_4: Humidity
RxCy_5: Air pressure
RxCy_6: Brightness max.
value
RxCy_7: Direction of
brightness
RxCy_8: Precipitation
status
RxCy_9: Precipitation
intensity
RxCy_10: Precipitation sum
RxCy_11: SYNOP

BR=384, DM=0, DT=0,
TT=0, RD=5

Weather
Station Thies
Clima US
VDTHP

Thies Telegram 2

RxCy_1: Wind speed
RxCy_2: Wind direction
RxCy_3: Temperature
RxCy_4: Humidity
RxCy_5: Air pressure

BR=384, DM=0, DT=0,
TT=0, RD=5

Lufft Weather
station WS Modbus RTU

input
registers 10,
14, 22, 31
and 47

RxCy_1: Relative humidity
(act.)
RxCy_2: Rel. air pressure
(act.)
RxCy_3: Wind direction fast
RxCy_4: Air temperature
(act.)
RxCy_5: Wind speed fast

serial settings (38400 bps),
address, Modbus RTU
protocol, parity none

Lufft Weather
station WS
300

Modbus RTU
input
registers 10,
14 and 31

RxCy_1: Relative humidity
(act.)
RxCy_2: Rel. air pressure
(act.)
RxCy_3: Air temperature
(act.)

serial settings (38400 bps),
address, Modbus RTU
protocol, parity none

Lufft Weather
station WS
502

Modbus RTU

input
registers 10,
14, 22, 27, 31
and 47

RxCy_1: Relative humidity
(act.)
RxCy_2: Rel. air pressure
(act.)
RxCy_3: Wind direction fast
RxCy_4: Global radiation
(act.)
RxCy_5: Air temperature
(act.)
RxCy_6: Wind speed fast

serial settings (38400 bps),
address, Modbus RTU
protocol, parity none
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Model Protocol Description Channels / Evaluated
Data Required Configuration

Lufft Weather
station WS
600

Modbus RTU

input
registers 10,
14, 22, 24,
25, 31, 47,
48, 49 and 50

RxCy_1: Relative humidity
(act.)
RxCy_2: Rel. air pressure
(act.)
RxCy_3: Wind direction fast
RxCy_4: Compass
direction
RxCy_5: Precipitation type
RxCy_6: Air temperature
(act.)
RxCy_7: Wind speed fast
RxCy_8: Precipitation
Quantity Absolute
RxCy_9: Precipitation
Quantity Difference
RxCy_10: Precipitation
Intensity

serial settings (38400 bps),
address, Modbus RTU
protocol, parity none

Lufft Weather
station WS
601

Modbus RTU

input
registers 10,
14, 22, 24,
25, 31, 47,
48, 49 and 50

RxCy_1: Relative humidity
(act.)
RxCy_2: Rel. air pressure
(act.)
RxCy_3: Wind direction fast
RxCy_4: Compass
direction
RxCy_5: Precipitation type
RxCy_6: Air temperature
(act.)
RxCy_7: Wind speed fast
RxCy_8: Precipitation
Quantity Absolute
RxCy_9: Precipitation
Quantity Difference
RxCy_10: Precipitation
Intensity

serial settings (38400 bps),
address, Modbus RTU
protocol, parity none

Gill MaxiMet
GMX600 Modbus RTU registers 2 to

20

RxCy_1: Wind direction
RxCy_2: Wind speed
RxCy_3: Wind direction
corrected
RxCy_4: Air pressure
RxCy_5: Humidity
RxCy_6: Temperature
RxCy_7: Dew point
RxCy_8: Precipitation sum
RxCy_9: Precipitation
intensity

serial settings, address

WDS308
integrated
dust
monitoring
sensor

Modbus RTU registers 1 to
14

RxCy_1: Wind direction
RxCy_2: Wind speed
RxCy_3: Temperature
RxCy_4: Humidity
RxCy_5: Air pressure
RxCy_6: Precipitation sum
RxCy_7: Global irradiance
RxCy_8: UV Index
RxCy_9: Noise
RxCy_10: Particulate
Matter PM2.5
RxCy_11: Particulate
Matter PM10

averaging interval 1s, serial
settings, address
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Model Protocol Description Channels / Evaluated
Data Required Configuration

LSI Lastem
DNB201 Modbus RTU registers 0 to

18

RxCy_1: Wind speed
RxCy_2: Wind direction
RxCy_3: Temperature
RxCy_4: Humidity
RxCy_5: Air pressure
RxCy_6: Minute
precipitation
RxCy_7: Hour precipitation
RxCy_8: Day precipitation
RxCy_9: Total precipitation

serial settings, address

10.10 Temperature Humidity Sensors

Temperature sensors measure the air temperature, while humidity sensors measure the air humidity. Both sensors
are often applied in combination to reduce cost.

Temperature humidity sensors, e.g. Galltec Active KP, Galltec Active TP, have to be connected to analog voltage
channels (Ax). Refer to Figure 13.4 for the connection diagram.

The output signal (U) from the temperature sensor is proportional to the temperature (T) in °C.

T[°C] = slope[°C/V] · U[V] + offset[°C]

Equation 10.7: Calculation of Temperature (T)

The output signal (U) from the humidity sensor is proportional to the humidity (RH) in %.

RH[%] = slope[%/V] · U[V]

Equation 10.8: Calculation of Humidity (RH)

Slope and Offset are internal parameters of the sensor, which are important to calculate temperature (T) in °C and
humidity (RH) in %. Both values are pre-configured in the Sensor Helper (see Section 5.1.2).

Note
For more flexibility, when connecting the combined Galltec temperature and humidity sensor to Meteo-40
plus, two different Galltec Active KP sensors are listed in the Sensor Helper (see Section 5.1.2). Two analog
channels are needed and thus the order of the signals to be connected is selectable. ”Galltec Thermo-Hygro
Active KP” assigns the first analog channel to temperature and the second to humidity. As opposite, ”Galltec
Hygro-Thermo Active KP” assigns the first channel to humidity and the second to temperature.

Sensor Order-No Slope Offset
Galltec Active KP
(Temperature + Humidity) S52100 100 %/V (Humidity)

100 °C/V (Temperature)
0 % (Humidity)
-30 °C(Temperature)

Galltec Active TP
(Temperature) S42100 100 °C/V -30 °C

Table 10.13: Parameters for the configuration of temperature humidity sensors
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Important
If you install calibrated sensors, enter the values given in the calibration protocol.

Meteo-40 plus saves all electrically measured values in V to the source data (Section 6.7). The calculated values for
temperature (°C) and humidity (%) are saved to the CSV file (see Section 6.6.1).

Note
The CSV file also contains for all active channels the electrical values according to the chosen statistical
interval.

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

10.10.1 Resistance Temperature Detectors (RTD) / Pt100 / Pt1000

RTDs measure the temperature by correlating the resistance of the RTD element with temperature. Those sensors
provide high accuracy and repeatability; the sensors are suitable for precision applications. RTDs use electrical resis-
tance and require a power source to operate.

Platinum Resistance Thermometers (Pt100 / Pt1000) are classified according to DIN EN 60751 - see tolerance classes
below.

Tolerance Class Tolerance in K
Class B1/3 DIN ±(0.10 K + 0.0017 × [t])
Class A ±(0.15 K + 0.002 × [t])
Class B ±(0.30 K + 0.005 × [t])
Class 0.5 ±(0.50 K + 0.006 × [t])

Table 10.14: Tolerance Classes - Platinum Resistance Thermometers (Pt100)

Pt100 / Pt1000 sensors have to be connected to the analog voltage channel and the current source of Meteo-40 plus
data loggers. The sensors can easily be configured via the Sensor Helper (see Section 5.1.2) in the Meteo-40 plus
web interface.

Meteo-40 plus saves all electrically measured values in V to the source data (Section 6.7). The calculated value for
temperature ( °C) is saved to the CSV file (see Section 6.6.1).

Note
The CSV file also contains for all active channels the electrical values according to the chosen statistical
interval.

10.10.2 Temperature Humidity Sensors connected to RS485 client

Some available temperature humidity sensors have to be connected to a Meteo-40 plus RS485 client bus. The sensors
can easily be configured in the Meteo-40 plus web interface via the Sensor Helper (see Section 5.1.2).
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Important
If you intend to connect more than one sensor to an RS485 client port, all connected sensors must use the
same protocol and serial settings. Additionally, each sensor needs a unique ID (RS485 address), which
has to be configured for the sensor. The transmission mode for all RS485-connected sensors has to be
configured as half duplex. See Section 11.6.

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion
Galltec
Thermo/Hygro
KPC.MS

Modbus RTU registers 0, 1,
3, 4

RxCy_1: Temperature
RxCy_2: Humidity

Fixed serial
settings
(19200 8N1)

Campbell
Hygro/Thermo
CS215

SDI-12 D0 RxCy_1: Temperature
RxCy_2: Humidity

External
module
needed
(address,
19200 8N1,
120Ω
termination).
See SDI-12

Thies Hygro-
Thermo-Baro -
RS485

Modbus RTU registers
35001 - 35013

RxCy_1: Absolute air
pressure
RxCy_2: Reduced air
pressure
RxCy_3: Relative humidity
RxCy_4: Air temperature
RxCy_5: Dew point
temperature
RxCy_6: Sensor Status

serial settings,
address

Table 10.15: Data request for RS485 Temperature Humidity Sensors

Meteo-40 plus saves all measured values to the source data (Section 6.7). The values for temperature (°C) and
humidity (%) are saved to the CSV file ( see Section 6.6.1).

10.11 Barometric Pressure Sensors

Barometric pressure sensors measure the air pressure. Air pressure and air temperature should be evaluated for an
accurate wind site assessment. It is recommended including an air pressure sensor as part of a measuring system.

Barometric pressure sensors, e.g. AB60, AB100 and Vaisala PTB110, have to be connected to analog voltage chan-
nels (Ax). Refer to Figure 13.3 for the connection diagram.

The output signal (U) from the barometric pressure sensor is proportional to the air pressure (P).

P[mbar] = slope[mbar/V] · U[V] + offset[mbar]

Equation 10.9: Calculation of Air Pressure (P)

Slope and Offset are internal parameters of the sensor, which are important to calculate the air pressure in hPa.
Both values are pre-configured for sensors listed in the library of the Sensor Helper (see Section 5.1.2).
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Sensor Order-No Slope Offset
Ammonit AB60 S31100 60 mbar/V 800 mbar
Ammonit AB100 S31200 100 mbar/V 600 mbar

Vaisala PTB110 S32100 for PTB 110.3
S32200 for PTB 110.2
S32300 for PTB 110.1

60 mbar/V 800 mbar

Table 10.16: Parameters for the configuration of barometric pressure sensors

Important
If you install calibrated sensors, enter the values given in the calibration protocol.

Meteo-40 plus saves all electrically measured values in V to the source data (Section 6.7). The calculated air pressure
value in mbar is saved to the CSV file (see Section 6.6.1).

Note
The CSV file contains for all active channels the electrical values according to the chosen statistical inter-
val.

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

10.11.1 Barometric Pressure Sensors connected to RS485 client

Certain barometric pressure sensors have to be connected to a Meteo-40 plus RS485 client bus The sensors can
easily be configured in the Meteo-40 plus web interface via the Sensor Helper (see Section 5.1.2).

Important
If you intend to connect more than one sensor to an RS485 client port, all connected sensors must use the
same protocol and serial settings. Additionally, each sensor needs a unique ID (RS485 address), which
has to be configured for the sensor. The transmission mode for all RS485-connected sensors has to be
configured as half duplex. See Section 11.6.

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion
Thies Baro
Transmitter Thies Telegramm 1 RxCy_1: Air pressure

RxCy_2: Temperature
serial settings,
address

Table 10.17: Data request for RS485 Barometric Pressure Sensors

Meteo-40 plus saves all measured values to the source data (Section 6.7). The air pressure value in hPa is saved to
the CSV file (see Section 6.6.1).
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10.12 Solar Sensors

10.12.1 Pyranometers

Pyranometers measure the global horizontal radiation. They are also used as reference instruments thanks to their
measurement precision. The use of this sensor is crucial for measurements with solar-powered applications.

Meteo-40 plus indicates for pyranometers the global horizontal irradiation (GHI).

Pyranometers, e.g. MS series of EKO Instruments or CMP series of Kipp & Zonen, have to be connected to analog
voltage channels (Ax). Refer to Figure 13.2 for the connection diagram.

The output signal (U) from the pyranometer is proportional to the solar irradiance (E) in W/m².

E[W/m²] =
U[μV]

Sensitivity[μV/[W/m²]]

Equation 10.10: Calculation of Solar Irradiance (E)

Sensitivity is an internal parameter of the sensor, which is important to calculate the radiation in W/m². The value
is given in the calibration certificate of the sensor.

Sensor Order-No
CMP 3 S61100
CMP 6 S61110
CMP 10 S61130
CMP 11 S61120
EKO ML-01 S64350
EKO MS-40 S64111
EKO MS-410 S64130
EKO MS-60 S64131
EKO MS-602 S64110
EKO MS-60M (RS485) S64160
EKO MS-60S (RS485) S64137
EKO MS-80A S64150
EKO MS-80M (RS485) S64160
EKO MS-80S (RS485) S64185
EKO MS-802 S64120
EKO MS-90+ (RS485)
Kipp & Zonen CMP11 S61120
Kipp & Zonen CMP6 S61110
Kipp & Zonen CMP3 S61100
Kipp & Zonen SMP10 (RS485) S61430 / S61420
Hukseflux Pyranometer LP 02 S63100
Hukseflux Pyranometer SR 11 S63120
Hukseflux Pyranometer SR30 (RS485)
Hukseflux Pyranometer SR20-T1
SP Lite2 S61180
Silicon Irradiance Sensor MT 0-1V S68310 / S68320 / S68330
Silicon Irradiance Sensor MT 0-10V S68100
Silicon Irradiance Sensor MT 4-20mA S68110 / S68210
Silicon Irradiance Sensor SiS-13TC-T S68250
Li-Cor LI-200SZ
ISET Solar Radiation Sensor
Datasol MET Reference Cell (RS485)

Table 10.18: Pyranometers
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Meteo-40 plus saves all electrically measured values in V to the source data (Section 6.7). The calculated values for
solar radiation are saved in W/m² to the CSV file (see Section 6.6.1).

Note
The CSV file also contains for all active channels the electrical values according to the chosen statistical
interval.

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

Some pyranometers can or must be connected to an RS485 client port. For EKO pyranometers, it is also possible to
use the M-Box RS485 Modbus RTU adapter and connect analog pyranometers to an RS485 client bus. If more than
one sensor is connected to an RS485 client bus, they must be configured with a unique Modbus ID and they must all
share the same protocol and serial settings (see Section 11.6).
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Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

Hukseflux
Pyranometer
SR30

Modbus RTU registers 2 to
7

R1C1_1: Global Irradiance
Compensated (W/m²)
R1C1_2: Global Irradiance
Uncompensated (W/m²)
R1C1_3: Internal
Temperature (°C)

serial settings
(default 9600,
8N2)

EKO MS-60M Modbus RTU registers 19 to
24

R1C1_1: Measuring Voltage
(mv)
R1C1_2: Global Irradiance
(W/m²)
R1C1_3: Internal
Temperature (°C)

serial settings
(default 9600,
8N2)

EKO MS-80M Modbus RTU registers 19 to
24

R1C1_1: Measuring Voltage
(mv)
R1C1_2: Global Irradiance
(W/m²)
R1C1_3: Internal
Temperature (°C)

serial settings
(default 9600,
8N2)

EKO MS-80S Modbus RTU
registers 2, 3,
8, 9, 14-17
and 20-25

R1C1_1: GHI (W/m²)
R1C1_2: Temperature Pt100
(°C)
R1C1_3: Angle of Inclination
X
R1C1_4: Angle of Inclination
Y
R1C1_5: Analog Voltage
(mV)
R1C1_6: Temperature (°C)
R1C1_7: Humidity (%)

serial settings

EKO MS-90+ Modbus RTU
registers 4-7,
12-13, 22-23
and 28-29

R1C1_1: GHI MS-80S
(W/m²)
R1C1_2: DNI MS-90 (W/m²)
R1C1_3: DHI calculated
(W/m²)
R1C1_4: Humidity MS-80S
(%)
R1C1_5: Temperature
MS-80S (°C)
R1C1_6: Elevation (°)
R1C1_7: Azimuth (°)

serial settings,
MS-90
sensitivity
configured in
C-Box

EKO M-Box Modbus RTU registers 19 to
24

R1C1_1: Measuring Voltage
(mv)
R1C1_2: Global Irradiance
(W/m²)
R1C1_3: Internal
Temperature (°C)

serial settings
(default 9600,
8N2)

EKO SMP10 Modbus RTU registers 5 to
10

R1C1_1: Solar Irradiance
(W/m²)
R1C1_2: Solar Irradiance
Long (W/m²)
R1C1_3: Temperature (°C)

serial settings
(default
19200,
8E1)10

Table 10.19: Data request for RS485 pyranometer
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Important
MS-90+ systems are preconfigured and must be handled as a unit. The sensitivity value of MS-90 and the
RS485 address of the MS-80S are already configured in the C-Box. It is very important to keep the system
as a unit and don’t exchange the sensors without adapting the C-Box configuration to prevent comunication
problems and data loss.

10.12.2 Delta-T Sunshine SPN 1

The pyranometer Delta-T Sunshine SPN 1 measures global horizontal and diffuse irradiation in W/m². It provides 2
analog voltage outputs (Ax) for global and diffuse irradiation, and 1 digital output (Dx) for sunshine duration.

Additionally, Meteo-40 plus estimates the direct normal irradiation based on the values of global horizontal and diffuse
irradiation according to the general formula: Global Horizontal Irradiation = Diffuse Horizontal Irradiation + Direct
Normal Irradiation * cos(θ), where θ is the solar zenith angle

The order number for Delta-T Sunshine SPN 1 is S65100.

Important
In order to estimate direct normal irradiation (DNI) and sun status, latitude and longitude of themeasurement
station have to be entered in the System→ Administration menu (see also Section 4.2).
If any estimated values should be included in the CSV statistics file, the values have to be selected in the
Data→ Statistics menu under Select statistics (see also Section 6.3.1).

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

10.12.3 Pyrheliometers

Pyrheliometers are used to measure the direct irradiance emitted by the sun in a 5 degree angle. The sensors have
to be connected to the analog voltage channels (Ax) of Meteo-40 plus.

The output signal (U) from the pyrheliometer is proportional to the solar irradiance (E) in W/m².

E[W/m²] =
U[μV]

Sensitivity[μV/[W/m²]]

Equation 10.11: Calculation of Direct Solar Irradiation (E)

Sensitivity is an internal parameter of the sensor, which is important to calculate the irradiation in W/m². The value
is given in the calibration certificate of the sensor.

Meteo-40 plus indicates for pyrheliometers direct normal irradiation. Additionally, the data logger estimates DNI *
cos(θ) and sun status based on the recorded values for direct normal irradiation. In order to estimate sun status and
DNI * cos(θ), latitude and longitude of the measurement station have to be entered in the System→ Administration
menu (see also Section 4.2)

The sensor often comes with built-in Pt100 sensor and thermistor. The Pt100 sensor can be connected to the current
source (see Section 11.5) of Meteo-40 plus.

If the built-in Pt100 sensor should be connected to Meteo-40 plus, pyrheliometer and Pt100 sensor have to be con-
figured separately in the Sensor Helper: Pyrheliometer via sensor type Solar Sensors and Pt100 via sensor type
Hygro/Thermo.

10SmartExplorer software - Kipp & Zonen (https://www.kippzonen.com/Download-Center/Downloads-per-categ
ory).
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Important
Do not connect the thermistor to Meteo-40 plus!

Sensor Order-No
EKO MS-56 S64210
Kipp & Zonen CPH1 S62210

Table 10.20: Pyrheliometers

Important
In order to estimate sun status and direct normal irradiation [DNI * cos(θ)], latitude and longitude of the
measurement station have to be entered or acquired with a GPS device in the System→ Administration
menu (see also Section 4.2).
If any estimated values should be included in the CSV statistics file, the values have to be selected in the
Data→ Statistics menu under Select statistics (see also Section 6.3.1).

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

10.12.4 Sunshine Duration Sensors

Sunshine duration sensors indicate the sunshine status as defined by the WMO (sunshine = irradiation exceeds the
level of 120 W/m²). The sensor measures the irradiation and switches the output voltage high or low to indicate sunny
or not sunny conditions.

Sunshine duration sensors, e.g. Kipp & Zonen CSD 3, have to be connected to analog voltage channels (Ax). If direct
irradiation should be measured, connect this output also to another analog voltage channel (Ax). Refer to Figure 13.2
for the connection diagram.

The output signal (V) indicates sunshine or no sunshine. Additionally, the calculated direct irradiation can bemeasured.
The output signal (mV) for direct irradiation is proportional to the direct irradiation (W/m²).

E[W/m²] =
U[μV]

Sensitivity[μV/[W/m²]]

Equation 10.12: Calculation of Solar Irradiation (E)

Sensitivity is an internal parameter of the sensor, which is important to calculate the radiation in W/m². The value
is given in the calibration certificate of the sensor.

Meteo-40 plus saves all electrically measured values in V to the source data (Section 6.7). The calculated values for
direct irradiation are saved in W/m² to the CSV file (see Section 6.6.1).

Sensor Order-No
Kipp & Zonen CSD 3 S61910

Table 10.21: Sunshine Duration Sensors
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Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

Meteo-40 plus saves all electrically measured values to the source data (Section 6.7). The calculated direct irradiation
in W/m² and the current sun status are saved to the CSV file (see Section 6.6.1).

Note
The CSV file contains for all active channels the electrical values according to the chosen statistical inter-
val.

10.12.5 Solar Trackers

EKO Instruments high precision STR Sun Tracker provide high tracking reliability, enhanced functionality with fully
automated set up procedure through a built in GPS receiver. The compact sun trackers are suited to support all kinds
of measurement sensors to measure Global, Diffuse and Direct Radiation.

EKO Sun Trackers must be connected to an RS485 client port by means of an RS232 to RS485 adapter.

Date, time and location are acquired from the sensor by means of commands TM and LO. If the data logger values
are significantly different, Meteo-40 plus will get automatically synchronized and the changes will be logged in the
logbook. This synchronization happens in two cases: when configuring the sensor and, if RS485 sensors check is
active, on every CECS reboot. If you want to trigger the synchronisation routine, you can access the configured EKO
Sun Tracker for editing and save it again without changing the configuration.

According to the configured polling rate, which is 1 s per default, the calculated angle according to the GPS information
and the current angle are requested and recorded.

Important
Make sure that no other method to synchronize date and time is active (Section 4.2).

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

EKO Sun
Tracker EKO Commands

MR and CR

R1C1_1: Azimuth calculated
(CR)
R1C1_2: Altitude calculated
(CR)
R1C2_1: Azimuth (MR)
R1C2_2: Altitude (MR)

serial settings

Table 10.22: Data request for RS485 Sun Tracker

10.12.6 Rotating Shadowband Irradiometer

Measure Global, Diffuse and Direct Radiation from two LiCor sensors as well as the temperature. The average values
from both sensors are also calculated.
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Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

CSPS RSI Modbus RTU Registers 0 to
20

R1C1_1: Global Horizontal
Irradiance (GHI)
R1C1_2: Difuse Horizontal
Irradiance (DHI)
R1C1_3: Direct Normal
Irradiance (DNI)
R1C1_4: Temperature
R1C1_5: GHI LiCor 1
R1C1_6: DHI LiCor 1
R1C1_7: DNI LiCor 1
R1C1_8: GHI LiCor 2
R1C1_9: DHI LiCor 2
R1C1_10: DNI LiCor 2

serial settings

Table 10.23: Configuration of RS485 CSPS RSI

10.12.7 Reference Cell

Model Protocol Description Channels / Evaluated
Data

Required
Configura-

tion

Datasol
MET
Reference
Cell

Modbus
RTU

registers 96
to 108

RxCy_1: Solar
irradiance Avg. (W/m²)
RxCy_2: Solar
irradiance 1 (W/m²)
RxCy_3: Solar
irradiance 2 (W/m²)
RxCy_4: Wind Speed
(m/s)
RxCy_5: Temperature
Air (°C)
RxCy_6: Temperature
Panel (°C)

serial
settings,
address

Table 10.24: Configuration details for RS485 Reference Cell

10.13 Precipitation Sensors

10.13.1 Rain Gauge

Precipitation sensors are designed to measure the quantity and intensity of precipitation striking the earth’s surface.
Precipitation is best measured with a tipping bucket device. Precipitation, collected over a surface of 200 cm², is
moved through an inflow sieve into a tipping bucket. When the bucket has collected 2 cm³ = 0.1 mm of precipitation, it
tips over. This measurement principle is based on the “Guide to Meteorological Instruments No 8, WMO”. Precipitation
sensors are typically applied for meteorological assessments.

Precipitation sensors, e.g. Young precipitation sensor, have to connected to counter channels (Cx). Refer to Fig-
ure 13.12 for the connection diagram.

The output signal (I) from the sensor is proportional to the precipitation quantity (N).
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Nμm = slope[μm/pulse] · I[pulse]

Equation 10.13: Calculation of Precipitation Quantity (N)

Slope is an internal parameter of the sensor, which is important to calculate the precipitation quantity according to the
measurement rate set in the sensor configuration. The value is pre-configured in theSensor Helper (see Section 5.1.2).

Sensor Order-No Slope Offset
Thies Precipitation Sensor S71100H 0.1 mm/I 0 mm
Young Precipitation Sensor S73100 / S73100H 0.1 mm/I 0 mm

Table 10.25: Parameters for the configuration of precipitation sensors

Important
If you install calibrated sensors, enter the values given in the calibration protocol.

Meteo-40 plus saves all electrically measured values in Pulse [I] to the source data (Section 6.7). The calculated
values are saved to the CSV file (see Section 6.6.1).

Note
The CSV file also contains for all active channels the electrical values according to the chosen statistical
interval.

Important
If you plan to install precipitation sensor Thies or Young, you have to implement an accessory module!
Refer to the data sheet and contact Ammonit for further details.

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

10.13.2 Laser Precipitation Monitors

Laser precipitation monitors measure various precipitation details, i.e. intensity of total, liquid and solid precipitation
as well as the precipitation amount and the SYNOP parameter.

Thies Laser Precipitation Monitor (LPM) sensor performs a new calculation every minute, after the first 5 minutes of
operation. Meteo-40 plus requests data with a 1 s rate in order to guarantee a valid measurement per minute with a
working sensor.

Thies LPM has to be connected to RS485 client port.
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Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

Precipitation
Monitor Thies
Laser

Thies Telegram 8

RxCy_1: SYNOP
RxCy_2: Intensity total
precipitation
RxCy_3: Intensity liquid
precipitation
RxCy_4: Intensity solid
precipitation
RxCy_5: Precipitation
amount

Serial
settings,
address, half
duplex mode,
no automatic
telegram
sending

Table 10.26: Configuration of RS485 Laser Precipitation Monitor Sensors

Note
SYNOP (surface synoptic observations) is a numerical code used for reporting weather observations, also
called FM-12 by the World Meteorological Organization. Refer to Thies LPM sensor’s manual for more
information.

10.14 Multifunction Transducer, Power Meters and other Electrical
Measurement Devices

Meteo-40 plus can be used to connect power meters, multifunction transducers or other electrical measurement de-
vices, e.g. for power curve measurement. The devices are connected to a Meteo-40 plus RS485 client port (see
Section 11.6).

Model Protocol Description Channels and Evaluated
data

Sensor’s
previous
configura-
tion needed

Sineax CAM
(see Sec-
tion 10.14.1)

Modbus RTU

Actual values
(registers
40100,
40118 to
40122,
40134 to
40142)

RxCy_1: Average phase
Voltage U
RxCy_2: Current I1
RxCy_3: Current I2
RxCy_4: Current I3
RxCy_5: Real Power P1
RxCy_6: Real Power P2
RxCy_7: Real Power P3
RxCy_8: Total Real Power
P
RxCy_9: Total Reactive
Power Q

Serial
settings,
address
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Model Protocol Description Channels and Evaluated
data

Sensor’s
previous
configura-
tion needed

Iskra MT540
(see Iskra
manuals
download
(http:
//www.is
krasiste
mi.si/do
wnload/m
anuals/))

Modbus RTU

Normalized
actual values
(registers
804, 809 to
811, 816 to
819, 823)

RxCy_1: Average phase
Voltage U
RxCy_2: Current I1
RxCy_3: Current I2
RxCy_4: Current I3
RxCy_5: Real Power P1
RxCy_6: Real Power P2
RxCy_7: Real Power P3
RxCy_8: Total Real Power
P
RxCy_9: Total Reactive
Power Q

Serial
settings,
address

GD2000
Multi-function
Power
Analyzer

Modbus RTU registers 56
to 63

RxCy_1: Active power
RxCy_2: Power factor
RxCy_3: Reactive power
RxCy_4: Apparent power

Serial
settings
(19200 bps),
address

10.14.1 Sineax CAM Measuring Unit

Sineax CAM is a universal measuring unit for heavy current variables. Actual measurements for average phase volt-
age, current, real and reactive power are requested from this sensor. For more information refer to Gossen Metrawatt
Sineax CAM documentation (http://www.gossenmetrawatt.com/english/produkte/sineaxcam.htm#).

10.15 Remote Sensing

10.15.1 ZephIR 300 Lidar

Meteo-40 plus can acquire ZephIR 300 live and averaged wind data measurements and include them in the measure-
ment CSV files or share them over SCADA. You can select ’ZephIR 300’ for averaged data or ’ZephIR 300 Live’ for
live data from the sensors list under ’Other Sensor’.

Before adding a ZephIR 300 to the list, it must be powered and connected to an RS485 client port. The configured
heights will be automatically requested and for each height, an RS485 channel (RxCy) will be configured. If both live
and averaged data are requested, a maximum of 4 heights can be configured at ZephIR 300.

Note
For more information about how to electrically connect ZephIR 300 and Meteo-40 plus please contact us.

Important
Measurement polling interval for averaged data is 1 minute per default. To ensure a valid measurement
per interval it must always be lower than the statistics time interval (see Section 6.3).
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Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

ZephIR 300 Modbus RTU

Averaged
wind data per
height
(registers
4096-4103,
4116-4121
and
4150-4153)

RxCy_1: Reference
RxCy_2: Wind Speed
RxCy_3: Vertical Wind
Speed
RxCy_4: Wind Direction
RxCy_5: Temperature
RxCy_6: Air Pressure
RxCy_7: Humidity
RxCy_8: Wind Speed Max
RxCy_9: TI

Serial
settings,
address

ZephIR 300
Live Modbus RTU

Live wind data
per height
(registers 1-7
and 21-26)

RxCy_1: Reference
RxCy_2: Wind Speed
RxCy_3: Vertical Wind
Speed
RxCy_4: Wind Direction
RxCy_5: Temperature
RxCy_6: Air Pressure
RxCy_7: Humidity

Serial
settings,
address

Table 10.27: Requested values

10.16 Bats Detection

10.16.1 Song Meter SM3BAT/SM4BAT

It is possible to connect the Wildlife Acustics Song Meter SM3BAT or SM4BAT FS to an RS485 client interface. This
allows a real time monitoring of bat passes and pulses, as well as of the status of the SM3BAT/SM4BAT flash memory
card and power supply.

Note
An external RS232 to RS485 adapter is required.

Model Protocol Description Channels / Evaluated Data

SM3BAT ASCII⁸
Protocol
compatible with
Thies

RxCy_1: Internal Voltage (V)
RxCy_2: Internal Temperature (°C)
RxCy_3: Flash memory level (%)
RxCy_4: Bat passes Mic0
RxCy_5: Bat pulses Mic0
RxCy_6: Bat passes Mic1
RxCy_7: Bat pulses Mic1

SM4BAT FS ASCII⁸
Protocol
compatible with
Thies

RxCy_1: Internal Voltage (V)
RxCy_2: Internal Temperature (°C)
RxCy_3: Flash memory level (%)
RxCy_4: Bat passes
RxCy_5: Bat pulses

Table 10.28: Requested values
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Scheduling: The SM3BAT can be programmed to monitor during specific periods of the day, and “sleep” during other
parts of the day to conserve power. When the SM3BAT is sleeping, it will not respond to Meteo-40 plus messages.
Thus, the SM3BAT needs to be programmed when to be monitoring for bats e.g. 24 hours or just at night, etc..

Recording: The SM3BAT normally records the ultrasonic echolocation audio data on up to 4 SDHC or SDXC flash
cards. Full spectrum recordings can typically consume 1-2GB of card space per night depending on bat activity. The
flash cards will eventually fill up. Normally, the SM3BAT would shut down if it is no longer able to make recordings.
However, for this application, it is desirable to continue monitoring, updating bat counters, and responding to requests.
If the interface to Meteo-40 plus is detected, then the SM3BAT will continue monitoring for bats even if the flash cards
are full, but no new bat activity data will be recorded. This condition is indicated by the flash card 100% full indication
in the response messages.

Bat Activity: Echolocating bats typically produce individual ultrasonic “pulses” continuously while they fly for navigation,
avoiding obstacles, and hunting for food. The frequencies, bandwidth and duration of pulses vary from species to
species and with the functional needs of the bat at the time (e.g. many bats will increase bandwidth and decrease
duration as they close in on prey). The SM3BAT can be configured to recognize pulses that may be tuned to specific
bats in a given area. This includes specifying the minimum and maximum frequencies and minimum and maximum
durations of a pulse. These parameters can be tuned to recognize echolocating bats while avoiding false positives
from other ultrasonic noise sources such as wind, rain, and insects. The optimum parameters will depend on the
specific bats and insects likely occurring in a given area. A “bat pass” refers to a series of pulses recorded as a bat
flies by the microphone. Additional parameters in SM3BAT help define what a bat pass is including the maximum
trigger duration and the maximum time between pulses (the trigger window). A bat pass begins with the first detected
pulse, and ends when either no pulses have been detected after the maximum time between pulses has occurred, or
when the maximum trigger duration has been reached. SM3BAT will not count a bat pass unless it contains at least
two pulses. In this way, the SM3BAT can count passes and pulses detected on an ongoing basis and report these
counts to the customer equipment.

10.17 Lightning Detector

10.17.1 SG1000 Lightning Detector

The SkyScan SG1000 lightning detector can detect the presence of lightning or thunderstorm activity occurring within
64 km of your location. It detects the characteristic electromagnetic emissions from individual lightning strokes and
uses patented technology to determine the distance to the detected stroke. The distances are indicated in four ranges:
0-5 km; 5-13 km; 13-32 km; and 32-64 km. This allows you to track the approach of dangerous storm activity.

Note
More than one range can be detected simultaneously.

SG1000 may also identify certain types of especially strong storms. These storms can produce dangerous winds,
heavy rains or tornadoes. When SG1000 detects lightning patterns indicating the presence of these storms, it activates
the Severe thunderstorm alarm.

Four digital signals with complementary information are supplied by this lightning detector: Alarm, Error, Battery power
and Baseline (see Table 10.29).
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Signal Description
0-5km Distance range 0-5 km
5-13km Distance range 5-13 km
13-32km Distance range 13-32 km
32-64km Distance range 32-64 km
Severe Severe thunderstrom alarm
Alarm Lightning activity has moved within range

Error There is a system error that needs to be addressed (error code
is indicated by the status LED on the unit)

Battery power Mains power has been interrupted and system is operating on
battery backup

Baseline Ensures that there is activity on the digital output (i.e. can be
used as a heartbeat to confirm system is up-and-running)

Table 10.29: SG1000 status signals

Important
If the period of the digital output signal of the sensor is changed, it is necessary to configure the measure-
ment rate at Meteo-40 plus accordingly. The period of the digital output signal can be set to a value between
2.0 and 4.8 seconds, being the default value 2.0. The measurement rate configured at the data logger for
this sensor must be at least twice as long as the period duration of the digital output, in order to guarantee
that a complete period is catched. The default measurement rate is 5 seconds.

10.18 Soil Water Content

Measuring the water content, electrical conductivity (EC), and temperature of soil is a main topic for any agricultural
project. Meteo-40 plus supports several volumetric water content (VWC) sensors, connected to an analog channel or
to an RS485 client interface.

Sensor
Decagon EC-20, EC-10, EC-5 Soil Moisture Sensors

Table 10.30: Soil Moisture Sensors

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

Campbell
Reflectometer
CS650

SDI-12 D0

RxCy_1: Volumetric water
content
RxCy_2: Electrical
conductivity

External
module
needed
(address,
19200 8N1,
120Ω
termination).
See SDI-12.

Table 10.31: RS485 Soil Water Content Sensors
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10.19 Soiling Measurement

Soiling is the accumulation of dust, dirt and other contaminants on the surfaces of photovoltaic (PV) modules. The
amount of dust is extremely dependent on the location of the PV power plant, e.g. in a desert valley with sand storms. In
the absence of significant rain events or regular cleaning, production losses due to soiling effects increase. Measuring
soiling effects provides important details about the PV power plant production, e.g. how much dust can be on the
modules before any problem occurs and how the dust affects transparency and efficiency of the modules.

10.19.1 Atonometrics RDE300

Soiling and Irradiance Measurement Systems with the Atonometrics RDE300 Series measurement and control unit
collect critical data for evaluating PV array performance. The systems can be used at operating PV power plants and
pre-construction site survey locations.

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

Atonometrics
RDE300 Modbus RTU

R1C1_1: Global Irradiance
PV1
R1C1_2: Analog Current
PV1
R1C1_3: Temperature PV1
R1C1_4: Active Power PV1
R1C2_1: Global Irradiance
PV2
R1C2_2: Analog Current
PV2
R1C2_3: Temperature PV2
R1C2_4: Active Power PV2
R1C2_5: Soiling Ratio
R1C2_6: Soiling Ratio Isc
R1C2_7: Soiling Ratio Pmax
R1C3_1: Event Code
R1C4_1: Status Fluid
R1C5_1: Status Pump

Serial
settings,
address

Table 10.32: Data request for RS485 Soiling Measurement

10.19.2 Ammonit Soiling Measurement Kit SD2100

The temperature-corrected short-circuit current of a clean PV module is proportional to the irradiance. After measuring
short-circuit current and temperature of the PV module, the effective solar irradiance (Eeff) can be determined (see also
Section 5.3.1.7).

The Ammonit soiling measurement kit compares the estimated effective irradiance of a naturally-soiled PV module
with a clean reference PV module. The measurement station determines the short-circuit current output as well as the
module surface temperature from the backside of both soiled and clean PV modules. Based on these measurements
the effective irradiance can be determined for each module.
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Formula

Effective	irradiance

Effective	irradiance

Analog	Current	Isc

SD2100	Analog	Current	Isc-soiled

Temperature

SD2100	Temperature	soiled

Short	Circuit	Current	Reference	(A)

3.07

Reference	Condition	Irradiance	(W/m²)

1000

Surface	Temperature	Reference	(°C)

25

Temperature	Coeficient	at	Isc	(%)

0.081

Label

Effective	Irradiance	soiled

Installation	height	(m)

0.0

Save

Delete

Figure 10.1: Ammonit Soiling Measurement Kit Effective Irradiance Soiled PV

Two standard metrics for the effects of soiling on energy production are available at the Evaluation Helper. The Soiling
Ratio Isc index (see also Section 5.3.1.8), which equals 1 when both modules are clean, and the Soiling Loss Index
(see also Section 5.3.1.9), expressed as a percentage.

The Ammonit soiling measurement kit includes the following components: Ammonit I-U Conversion Box, Surface
Temperature Sensor and a 30 W Photovoltaic (PV) Module. The reference constants for the PV-module must be
introduced for the effective irradiance and soiling ratio Isc formulas:

• Isc0: Short Circuit Current (A)
• G0: Reference Condition Irradiance (W/m²)
• T0: Surface Temperature (°C)
• TK Isc: Temperature Coeficient at Isc (%)

Configure an Ampere meter from the sensors list for each of the I-U Conversion Boxes. In order to achieve best match
to the output voltage, the appropriate voltage range must be selected. If you are using CM8281, with a shunt resistor
of 50 mΩ, you must select the ±1.0 V range.

For the surface temperature measurement, a PT100 is used.

10.19.3 Kipp & Zonen DustIQ

The Kipp & Zonen DustIQ is an instrument meant to measure and report the transmission loss (TL) and soiling ratio
(SR) caused by light being blocked and reflected and subsequently not getting through the glass of the panel due to
soiling of the panel.

182 © 2011 — 2023 Ammonit Measurement GmbH



Data Logger Meteo-40 Plus User’s Manual 183 / 258

Important
A local dust calibration of the device is required. The DustIQ leaves the factory calibrated for Arizona
Test Dust (ATD) but it is very unlikely that the local dust composition matches this ATD and it is therefore
advised to train each DustIQ for the local dust composition (see https://www.kippzonen.com/ for
more information).

Before and after the calibration process, Ammonit recommends to read some relevant Modbus registers to record this
values in the data logger logbook. The RS485 Serial Interface must be used: register 2 (software version), register 34
(device status flags), register 35 (calibration flags), register 36 (current sensitivity value).

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

DustIQ Modbus RTU registers 20,
21, 24, 25

R1C1_1: Soiling Ratio 1 (%)
R1C1_2: Transmission Loss
1 (%)
R1C1_3: Soiling Ratio 2 (%)
R1C1_4: Transmission Loss
2 (%)

Serial
settings,
address

DustIQ &
temperature Modbus RTU registers 20,

21, 24, 25, 31

R1C1_1: Soiling Ratio 1 (%)
R1C1_2: Transmission Loss
1 (%)
R1C1_3: Soiling Ratio 2 (%)
R1C1_4: Transmission Loss
2 (%)
R1C1_5: Temperature (°C)

Serial
settings,
address

Table 10.33: Data request for DustIQ RS485 Soiling Measurement

10.20 Other RS485 Sensors

In addition to meteorological sensors, further RS485-compatible sensors or devices can be connected to an RS485
client bus (see Section 11.6). The following list includes some sensors and their configuration.
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10.20.1 RS485 Multiplexer

Sensor
type Model Protocol Description Channels / Evaluated

Data

Required
Configura-

tion

Multi
Channel
Voltage
Module

Gantner
e.bloxx A1

Modbus
RTU

registers 17
to 32

RxCy_1: Analog
Voltage AI1
RxCy_2: Analog
Voltage AI2
RxCy_3: Analog
Voltage AI3
RxCy_4: Analog
Voltage AI4
RxCy_5: Analog
Voltage AI5
RxCy_6: Analog
Voltage AI6
RxCy_7: Analog
Voltage AI7
RxCy_8: Analog
Voltage AI8

Serial
settings,
address,
protocol,
channels
definition

Multi
Channel
Voltage
Module

Gantner
e.bloxx
A3-1

Modbus
RTU

registers 17
to 26

RxCy_1: Analog
Voltage 1
RxCy_2: Analog
Voltage 2
RxCy_3: Analog
Voltage 3
RxCy_4: Analog
Voltage 4
RxCy_5: Digital status

Serial
settings,
address,
protocol,
channels
definition

Multi
Channel
Digital
Module

Gantner
e.bloxx
D1-1

Modbus
RTU

registers 0
to 7

RxCy_1: Digital status 1
RxCy_2: Digital status 2
RxCy_3: Digital status 3
RxCy_4: Digital status 4
RxCy_5: Digital status 5
RxCy_6: Digital status 6
RxCy_7: Digital status 7
RxCy_8: Digital status 8

Serial
settings,
address,
protocol,
channels
definition

Power
system
monitor

SYCBA
Monitor

Modbus
RTU

registers 0
to 6

RxCy_1: Analog
Voltage Load
RxCy_2: Analog
Current Load1
RxCy_3: Analog
Current Load2
RxCy_4: Analog
Current Load3
RxCy_5: Analog
Current Load4
RxCy_6: Analog
Voltage Charge

Serial
settings
(default
9600 8N1),
address
(default 1)

Table 10.34: Configuration details for other RS485 Sensors / Devices
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10.20.2 Configuring generic Modbus RTU sensors

It is possible to connect up to 8 Modbus RTU sensors to RS485 client port (see Section 11.6). They can be combined
with other Modbus RTU sensors implemented in Meteo-40 plus like Lufft sensors, but not with other protocols like
Thies or Gill.
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Sensor	type

Other	Sensor

Sensor

Modbus	RTU

Installation	height	(m)

0.0

Label

Serial	number

Evaluation	type

Other	Evaluation

Unit

Serial	port

R1

RS485	Channel

R1C1

Sensor	ID	(1..247)

1

Data	Type:

ushort	(16-bit)

Word	Endianness:

Big	(most	significant	first)

Modbus	start	register	(0..65535)

0

Modbus	register	quantity	(1..20)

1

Modbus	function	code	(3..4)

4

Serial	settings

RS485	speed

38400

RS485	data	format

8N1

Measurement	period

1	s

Add	more

Finish

Figure 10.2: Generic Modbus RTU sensor configuration
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The maximum quantity of consecutive registers that can be read from each sensor is 20. It is necessary to specify
the first register (PDU addressing, first reference is 0) and the amount of registers. The function code is selectable
between ’03’ (read holding registers) and ’04’ (read input registers).

Read registers will be evaluated according to the selected data type (see Table 10.35). If a 32-bit data type is selected,
each pair of registers will be merged. For each register pair (if 32-bit data type selected) or each individual register (if
16-bit data type selected), an evaluation is generated. E.g. reading 10 registers on RS485 channel R1C1 will generate
10 evaluations if a 16-bit data type is selected (R1C1_1 to R1C1_10) and 5 evaluations if a 32-bit data type is selected
(R1C1_1 to R1C1_5).

The resulting evaluations have no unit or evaluation type. You can create a new evaluation on top of each original
evaluation by means of the linear equation from the Evaluation Helper (see Section 5.3.1). Finally, it is necessary to
properly select the evaluations to be included in the CSV statistics files in the Data→ Statistics(see Figure 6.4).

Data Type Description
short (16-bit) 16-bit integer
ushort (16-bit) 16-bit unsigned integer
long (32-bit) 32-bit integer
ulong (32-bit) 32-bit unsigned integer
float (IEEE754 32-bit) 32-bit single precision binary floating point
32-bit unsigned (8-bit exp) 8-bit signed decade exponent, 24-bit uint
32-bit signed (8-bit exp) 8-bit signed decade exponent, 24-bit signed int

Table 10.35: Data types available
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Chapter 11

Channels

The previous chapter described various sensors which can be connected to Meteo-40 plus. The sensors have to be
connected to the corresponding channel. Depending on the data logger type, Meteo-40 plus offers up to 35 channels.
Meteo-40 plus provides connectors for the following measurands and signals:

• Analog Voltage (DC)
• Analog Current (DC)
• Pulse Counter / Period
• Digital / Serial / Status
• RS485 (client)

Furthermore, the data logger Meteo-40 plus provides up to two high precision Current Sources to supply passive
sensors.

See also Section 1.3.

11.1 Connecting Sensors to Analog Voltage Channels

Meteo-40 plus is equipped with up to 12 differential voltage inputs, depending on the logger’s type. Generally, there
are two benefits from differential inputs:

1. Reduced impact of perturbances and interferences on the signal lines,

2. Helps to avoid ground loops.

You can find the analog voltage channels (Ax, Bx) on the lower left side of the measuring unit (see Section 1.2).
For example, analog wind vanes, barometric pressure sensors or pyranometers with analog voltage output can be
connected to analog voltage channels of Meteo-40 plus.

The analog voltage ranges comprise the following voltage ranges:

• ±0.1 V,
• ±1 V,
• ±10 V,
• 0.1 V to 0.3 V.

Note: The voltage range 0.1 V to 0.3 V is a high resolution range, especially designed for use with passive Pt1000
temperature sensors in conjunction with the current sources of Meteo-40 plus.

For further electrical details refer to Section 12.2.

Channel Meteo-40S Meteo-40M Meteo-40L Meteo-40A
Analog Voltage Channels 4 8 12 12

Table 11.1: Analog Channels of Meteo-40 plus
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11.2 Connecting Sensors to Counter / Period Channels

The counter channels (C) are located next to the analog voltage channels (see Section 1.2). For example, anemome-
ters and precipitation sensors can be connected to counter channels. For electrical details refer to Section 12.2.

With data loggers produced since 2017-06, one can use the counter channels C5, C6, C11, and C12 as period mea-
surement channels (P). This is useful for low frequency signals. The channel names are P1 to P4, respectively.

Channel Meteo-40S Meteo-40M Meteo-40L Meteo-40A
Counter
Channels 4 8 12 2

Period
measurements 0 2 4 0

Table 11.2: Counter / Period Channels of Meteo-40 plus

11.2.1 Period measurement

Meteo-40 plus can detect rising and falling edges of a signal connected to P channels. Three different measurement
options are implemented: period, pulse width and duty cycle. These can be configured as Other Sensor in the
Sensor Helper (see Section 5.1.2). If you want to use the period measurement to connect an anemometer, you
must select the Generic Anemometer PM form the list of sensors.

For the period-related measurements, the first two or three edges in the measurement interval are registered. No
averaging is applied for a measurement interval.

Important
The measurement rate must be at least twice as long as the period of the measured signal. If the measure-
ment rate is too short, there might not be enough edges per measurement interval.

Period: The Period is the duration of time of one cycle in a repeating event, so the Period is the reciprocal of the
frequency. For the Period measurement, a total of three edges is needed.

Pulse Width: The Pulse Width or pulse duration is the time between a rising and a falling edge. At least one rising
and one falling edge are needed for this measurement.

Duty Cycle: The Duty Cycle is the percentage of the ratio of the pulse width to the total period of the waveform. In
this case, at least three edges are needed for the measurement.

Period, Pulse Width and Duty Cycle are illustraded in Figure 11.1.
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Figure 11.1: Illustration of Period, Pulse Width and Duty Cycle.

11.3 Connecting Sensors to Digital Channels

To use digital serial wind vanes Meteo-40 plus includes up to eight Digital Channels (D). These Digital Channels are
located in the middle of the connection panel of the data logger. For further electrical details refer to Section 12.2.

Channel Meteo-40S Meteo-40M Meteo-40L Meteo-40A
Digital Channels 2 4 8 4

Table 11.3: Digital Channels of Meteo-40 plus

11.3.1 Functionality Check of Clock Output

To set up a proper digital connection between the sensor and Meteo-40 plus it is sometimes necessary to verify the
functionality of the Digital Clock Output. The Digital Clock Output sends a short data sequence to the sensor, the
sensor should respond with a data sequence on the IN line of the serial interface.

To request data from the sensor the Digital Clock Output must provide voltage levels that can be detected (understood)
by the sensor. To simply test the functionality of the Digital Clock Output with a Multimeter, Meteo-40 plus provides a
software driven test procedure. To perform the CLK-Line Output Test do the following:

• Disconnect the sensor from the data logger.
• Connect the data logger to the PC to configure it via web interface.
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• Login into the data logger and follow the links Measurement→ Channels
• Press the ”Digital test” button below the sensor list.
• A tabular showing the Digital Channels available on this logger appears. The right columns of the table contain two
buttons: ”5 V” and ”0 V” corresponding to each channel.

Channel CLK	5	V CLK	0	V

D1 5	V 0	V

D2 5	V 0	V

D3 5	V 0	V

D4 5	V 0	V

D5 5	V 0	V

D6 5	V 0	V

D7 5	V 0	V

D8 5	V 0	V

Figure 11.2: Configuration Menu for CLK-Line Test in Meteo-40 plus.

• Connect the multi meter between CLK output and GND of the Digital Channel you intend to check.
• First step: Press the button ”5 V” to switch on the DC voltage of the Clock Output. There must be a voltage between
4 V and 5.6 V present at the Clock Output.

• Second Step: Add a resistor of 1 kΩ–1.2 kΩ in parallel to the multi meter (see figure Figure 11.3). Press the button
”5 V” to switch on the DC voltage of the Clock Output. The voltage at the Clock Output must not drop below 3 volts.

Notes:

• The DC voltage output can be toggled between High- and Low-level via the two buttons ”5 V” and ”0 V”
• The test has limited timespan: After pressing the ” Digital test” button and choosing the DC voltage level, the
voltage level will remain only 10 seconds. To repeat the test, the button ” 5 V” has to be pressed again.

Test Result: If the voltage level drops below 3 volts, the CLK output of the data logger could be defective.
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Figure 11.3: Setup for CLK-Line test of Serial Interface.

11.4 Connecting Sensors to Analog Current Channels

Meteo-40 plus data loggers offer analog current measurement channels: Meteo-40L and Meteo-40A provide two
channels; Meteo-40M and Meteo-40S one each.

Barometric pressure sensors with current output can be connected to these channels. The current measurement
channels offer current ranges of 1 mA, 10 mA and 100 mA which can be configured via web interface.
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Channel Meteo-40S Meteo-40M Meteo-40L Meteo-40A
Analog Current Channels 1 1 2 2

Table 11.4: Analog Current Channels of Meteo-40 plus

11.5 Connecting Sensors to Current Source

The current source (CS) is located on the left of the communication unit next to the analog current channels (see
Section 1.2). Meteo-40 plus data loggers are equipped with one or two current sources, depending on the logger’s
type. The goal of these current sources is to supply passive temperature sensors (PT100 or PT1000).

Single Pt100 and Pt1000 sensors as well as Pt100 sensors, which are for example implemented inside pyrheliometers
can be connected to the current source of Meteo-40 plus. For electrical details refer to Section 12.2.

Channel Meteo-40S Meteo-40M Meteo-40L Meteo-40A
Current Source Channels 1 1 2 2

Table 11.5: Current Source Channels of Meteo-40 plus

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

11.6 Connecting Sensors to RS485 Client

All data logger types of Meteo-40 plus offer one RS485 client (RS485-M) terminals for RS485-Bus connection of up to
eight sensors with RS485 interface. The RS485 client of Meteo-40 is half-duplex: two connectors for Data+, Data- and
Ground (GND). The RS485 client interface of Meteo-40 plus does not provide galvanic separation. For this reason
we recommend to use an additional repeater that provides sufficient isolation when cable length of the RS485-Bus is
above than 30 meters. The figure below depicts an example setup with isolation repeater and biasing module M83570
(both available from Ammonit Measurement GmbH).

For further electrical details refer to Section 12.2.
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Figure 11.4: Electrical Connection Plan: RS485 client terminals of Meteo-40 plus

11.6.1 Configuring Sensors for RS485 client in the User Interface

When adding an RS485 sensor in the Measurement→ Sensors menu, a (selectable) channel name between RxC1
and RxC8 is assigned to the sensor. Subindexes, e.g. R1C1_1, R1C1_2, are created for measured data and evalua-
tions. In the Measurement→ Evaluation menu the evaluations are displayed. Both measured values and evaluated
data are included in the CSV files and can be seen in the Data→ Live menu.
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Most RS485 sensors have to be configured before use. The same configuration must be applied, when adding the
sensors to Meteo-40 plus in the Measurement→ Sensors menu.

Important
Only sensors using the same protocol and serial settings can share the same RS485 bus. It is necessary
to configure each sensor with a unique RS485 address in the bus.

The time allocated to a sensor depends on the number of sensors configured and the measurement period. The
sensor request, the response delay and the response transmission itself should happen within this interval. Otherwise
the response telegram will not be fully read and an RS485_TELEGRAM_ERROR will appear in the Measurement and
Recording Errors (see Section 4.7).

The response telegram will be recorded at the end of this interval, this implies a delay between sensor response and
recording. The maximum delay is 1 s.

If more than one sensor is configured and the measurement period is 1 s, the time must be shared between the
sensors. The minimum dedicated time per sensor is 125 ms.

Measurement intervals between 1 s and 1 h can be selected. If only one RS485 sensor is configured, shorter mea-
surement intervals are available: 1/2 s, 1/4 s, 1/4 s and 1/8 s.

Available baud rates: 38400, 19200 and 9600 bits per second.

Available serial settings (data/parity/stop): 8N1, 8N2, 8E1.

11.6.2 SDI-12 sensors

SDI-12 is a standard communications protocol which provides a means to transfer measurements taken by an intel-
ligent sensor to a data recorder. A subset of the SDI-12 protocol is implemented on Meteo-40 plus. By means of
an external hardware, an RS485 client interface can be used to connect SDI-12 sensors. If more than one SDI-12 is
connected, the external adapters must be configured with different RS485 addresses. The supported SDI-12 sensors
can be found in section Sensors.

11.7 Using the Switches

Each Meteo-40 plus data logger includes switches to switch different kinds of loads on and off. The number of switches
depends on the type of the logger (S, M, L, or A). The switch is internally realized with a P-channel MOSFET. The
loads can be sensors as well as relays (electro-mechanical or solid state). Each switches section consists of three
terminals: 5 V output, Input (In) and Output (Out).

Input terminal: This is the input of the voltage to be switched. Note: Input voltage must be positive with respect to
ground (GND).

Output terminal: Output of the switch.

5 V Output terminal: The 5 V output can be used as a control voltage for external devices. Load current must be
below 50 mA. The 5 V output is always available, it is not toggled with the switch. Furthermore, it can be used as input
voltage for the switches.

The following two figures show example circuits to make clear the use of the 5 V and the switches terminals.
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Figure 11.5: Use switches to supply sensors.
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Figure 11.6: Use switches and 5 V to control external loads.
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Chapter 12

Technical Data

12.1 Specification

Property Specification
Housing Dimensions 260 × 194 × 50 [mm]
Weight 950 g
Protection IP65

Temperature -40–+65 °C (operation)
-20–+65 °C (display readable)

Memory Meteo-40S: 1 GB
Meteo-40M: 2 GB
Meteo-40L: 2 GB
Meteo-40A: 1 GB

Date Format YYYY-MM-DD
Time Format hh:mm:ss

Clock
Buffered real time clock
Accuracy: -40–+85 °C (±3.5 ppm);
0–+40 °C (±2 ppm)
3 V Lithium Button Cell CR2032;
approx. 180 mAh; operating time >3 years

Power Supply No internal supply! (see Section 12.2.12)

Important
Meteo-40 plus has no internal supply battery! External power supply is essential for proper operation.
Section 12.2.12 contains the characteristics of the voltage supply and the current consumption of the data
logger.

© 2011 — 2023 Ammonit Measurement GmbH 199



71
51

225±0.4

12
5±0

.4

4x threaded inserts for mounting
metric screw thread: M5
screw-in-depth: 10 mm

Figure 12.1: Mounting threads dimensions.

12.2 Electrical Characteristics

The values given in the following tables Table 12.1 to Table 12.11 contain the specifications of the digital and analog
inputs and outputs. The given values are specified for a temperature range of -40 – +65 °C.

Note
All inputs and outputs are protected against overvoltage and electrostatic discharge using suppressor
diodes. All voltage outputs of the data logger are fused by an self-resetting electronic fuse. Addition-
ally, the power supply includes a reverse-polarity protection diode.
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12.2.1 Electrical Specifications of Analog Voltage Channels / Differential Inputs

Property Specification

Number of Channels per Data Logger Type
4 @ Meteo-40S (A1–A4)
8 @ Meteo-40M (A1–A8)
12 @ Meteo-40L (A1–A12)
12 @ Meteo-40A (A1–A12)

Available Voltage Ranges (DC)
±0.1 V
±1 V
±10 V
0.1 V–0.3 V

Internal Resolution (Bit)
15 bit (Range: ±0.1 V)
16 bit (Range: ±1 V)
16 bit (Range: ±10 V)
16 bit (Range: 0.1 V–0.3 V)

Internal Resolution (Voltage)
6.1 µV (Range: ±0.1 V)
30 µV (Range: ±1 V)
300 µV (Range: ±10 V)
3.1 µV (Range: 0.1 V–0.3 V)

Measurement Accuracy (Voltage)
≤ 50 µV (Range: ±0.1 V)
≤ 150 µV (Range: ±1 V)
≤ 1 mV (Range: ±10 V)
≤ 50 µV (Range: 0.1 V–0.3 V)

Input Impedance 1 MΩ
Input Voltage min. -12 V

max. +12 V
Maximum Measurement Frequency 4 Hz

Table 12.1: Electrical Specifications of Analog Voltage Channels / Differential Inputs

12.2.2 Electrical Specifications of Analog Current Channels / Differential Inputs

Property Specification

Number of Channels per Data Logger Type
1 @ Meteo-40S (AC1)
1 @ Meteo-40M (AC1)
2 @ Meteo-40L (AC1–AC2)
2 @ Meteo-40A (AC1–AC2)

Available Current Ranges (DC) ±1 mA
±10 mA
±100 mA

Measurement Accuracy (DC) ≤ 5µA (Range: ±1 mA)
≤ 30µA (Range: ±10 mA)
≤ 300µA (Range: ±100 mA)

Resolution (Bit) 13 bit (Range: ±1 mA)
15 bit (Range: ±10 mA
15 bit (Range: ±10 mA

Input Impedance (Shunt) 4.7 Ω
Maximum Input Current 150 mA
Maximum Input Voltage 0.75 V
Maximum Measurement Frequency 4 Hz

Table 12.2: Electrical Specifications of Analog Current Channels / Differential Inputs
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12.2.3 Electrical Specifications of Counter Channels / Non-Differential Inputs

The counter counts impulses within a defined measurement timespan. This measurement timespan is derived from a
precise timer signal with a precision of ± 5 ppm in the temperature range -40–+65 °C.

In case of a measurement timespan of one second the count of impulses is equal to frequency (Unit: Hz).

Property Specification

Number of Channels per Data Logger Type
4 @ Meteo-40S (C1–C4)
8 @ Meteo-40M (C1–C8)
12 @ Meteo-40L (C1–C12)
2 @ Meteo-40A (C1–C2)

Maximum measurable frequency 65535/period  in Hz
Frequency Resolution 1 1/period in Hz
Voltage Threshold (f > 1 Hz) 0.22 V
Input Voltage min. -12 V

max. +12 V
Period Measurement (Non-Differential Inputs) Channels P1 (C5), P2 (C6), P3 (C11), P4 (C12)

Table 12.3: Electrical Specifications of Counter Channels / Non-Differential Inputs

12.2.4 Electrical Specifications of Digital Channels (Serial Input / Output)

Property Specification

Number of Channels per Data Logger Type
2 @ Meteo-40S (D1–D2)
4 @ Meteo-40M (D1–D4)
8 @ Meteo-40L (D1–D8)
4 @ Meteo-40A (D1–D4)

Input Voltage Range (High State) 2 V–25 V
Input Voltage Range (Low State) -0.5 V–0.6 V
Input Resistance ≥ 10 kΩ

Table 12.4: Electrical Specifications of Digital Channels (Serial Input / Output)

12.2.5 Electrical Specifications for Digital Clock Output

Property Specification

Number of Channels per Data Logger Type
2 @ Meteo-40S (D1–D2)
4 @ Meteo-40M (D1–D4)
8 @ Meteo-40L (D1–D8)
4 @ Meteo-40A (D1–D4)

High State 5 V
Low State 0 V
Output Resistance 100 Ω
Minimal Load Resistance 500 Ω

Table 12.5: Electrical Specifications for Digital Clock Output

1The frequency resolution depends on the measurement period setting. Longer period time setting results in higher resolution.
Measurement period defines how often the signal frequency is measured per second.
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12.2.6 Electrical Specifications for Analog Current Source

Property Specification

Number of Channels per Data Logger Type
1 @ Meteo-40S (CS1)
1 @ Meteo-40M (CS1)
2 @ Meteo-40L (CS1–CS2)
2 @ Meteo-40A (CS1–CS2)

Nominal Current 200 µA
Tolerances < 0.5 %
Max. Resistance 10 kΩ

Table 12.6: Electrical Specifications for Anlog Current Source

12.2.7 Electrical Specifications for Switches

Property Specification

Number of Channels per Data Logger Type
2 @ Meteo-40S (S1–S2)
4 @ Meteo-40M (S1–S4)
8 @ Meteo-40L (S1–S8)
4 @ Meteo-40A (S1–S4)

Switch Voltage Range 5 V–28 V
Max. Current Continuous Switch 120 mA
Peak Switch Current (2 s) 400 mA
Switch On Resistance < 350 mΩ
Switch Off Resistance > 10 MΩ
Max. Output Voltage of 5 V Output Terminal 5.5 V
Min. Output voltage of 5 V Output Terminal 4.7 V
Max. Output Current per 5 V Output Terminal 15 mA

Table 12.7: Electrical Specifications for Switches

Important
The Meteo-40 plus switches deliver 5 V output to supply peripheral devices inside the steel cabinet of the
measurement setup. The 5 V supply is not intended to supply sensors connected with long cables due to
the risk of damage caused by lightning strike.
The 5 V outputs provide an electronic current limiter and an overvoltage protection.

12.2.8 Electrical Specifications of the RS485 Interface

Property Specification
Supply Voltage RS485 A, B 5 V
Termination Resistor (Bus Termination) 120 Ω
Maximal Transmission Rate 1 MB/s

Table 12.8: Electrical Specification of the RS485 Interface
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Note
Biasing of RS485 interface via external module M83570.

12.2.9 Electrical Specification of the Ethernet Interface

Important
The Ethernet interface is only available on Meteo-40 plus Revision D.

Property Specification
Ethernet port (Meteo-40 plus Revision D) 100 Mbit/s (100BASE-TX)

Table 12.9: Electrical Specification of the Ethernet Interface

12.2.10 Electrical Specification of the RS232 Interface

Important
The RS232 interface is only available on Meteo-40 plus Revision C. The production of Meteo-40 plus
Revision C stopped in October 2012.

Property Specification

Serial interface port (Meteo-40 plus Revision C) Male 9-pin RS232 connector for connection to
serial modem

Maximal Baudrate 115200 Baud

Table 12.10: Electrical Specification of the RS232 Interface

12.2.11 Electrical Specifications of Internal Measurements

Meteo-40 plus measures the Internal Supply Voltage and Internal Current of the data logger. These measurement
values can be used for remote verification of the functionality of the data logger and are written to the source data and
the CSV data files respectively.

Important Notes:

• Internal Supply Voltage and Internal Current are recorded with 12 bit resolution only,
• Internal Supply Voltage is measured directly behind a reverse polarity protection diode. This means the measured
value is approximately 0.35 volt lower than the supply voltage at the logger’s supply terminals.

12.2.12 Electrical Specification of the Power Supply

Important
Meteo-40 plus has no internal supply battery! External power supply is essential for proper operation.
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Power Supply Property Specification
Supply Voltage Input (with
Reverse Voltage Protection)

Supply Voltage Range 9 V (DC)–36 V (DC)
Peak Supply Voltage (10 s) 55 V (DC)

Current Consumption

Average Current Consumption
@ 12 V (DC) during
measurement

≤ 30 mA (P < 360 mW)

Average Current Consumption
@ 12 V (DC) during
communication

≤ 80 mA (P ≤ 960 mW)
for Meteo-40 plus Revision D
≤ 60 mA (P < 720 mW)
for Meteo-40 plus Revision C

Average Current Consumption
@ 12 V (DC) with display
illumination

175 mA (P ≤ 2.1 W)
for Meteo-40 plus Revision D

Table 12.11: Electrical Specification of the Power Supply

Note
When the CECS is switched off, no power can be drawn from the USB or Ethernet ports.
When 5 V output ports (Switches) are used the load at these ports must also be taken in account when
calculating the power consumption of the data logger.
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Chapter 13

Electrical Connection Plans

The following connection plans explain how Meteo-40 plus is connected with power supply, sensors and other periph-
erals.

Note
Since Meteo-40 plus is designed to be very flexible, various sensors can be connected to the data logger.
If the sensor you intend to connect is not listed in this manual, refer for technical details and connection
plans shown on the data sheets on our website (www.ammonit.com (http://www.ammonit.com)) or
contact our sales team (+49-30-6003188-0 or sales@ammonit.com).

Figure 13.1: Meteo-40 plus Supply incl. Modem
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Figure 13.2: Electrical Connection Plan: Analog Voltage (Pyranometer)

Floating voltage source (pyranometer) is connected via terminal or OVP to the differential analog voltage channels.
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Figure 13.3: Electrical Connection Plan: Analog Voltage (Temperature / Barometric Pressure Sensor)

The temperature and/or barometric pressure sensor is connected via terminal or OVP to the differential analog voltage
channels. To avoid ground loops, it is not recommended connecting the B terminal of the analog voltage input directly
to common ground.
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Figure 13.4: Electrical Connection Plan: Analog Voltage (Temperature + Humidity Sensor)

Voltage sources (temperature and humidity sensor) are connected via terminal or OVP to the differential analog voltage
channels. To avoid ground loops, it is not recommended connecting the B terminal of the analog voltage input directly
to common ground.
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Figure 13.5: Electrical Connection Plan: Analog Voltage / Current Source (4-wire-connection; Pt1000)

Analog Current Source (CS) of Meteo-40 plus is applied to feed a Pt100/Pt1000 temperature sensor. The sensor is
connected via terminal or OVP to the differential analog voltage channel. 4-wire measurement is recommended to
avoid voltage errors due to the resistance of feed line.
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Figure 13.6: Electrical Connection Plan: Analog Voltage / Current Source (4-wire-connection; Pt1000 +
Humidity)

Analog Current Source (CS) of Meteo-40 plus supplies the Pt100/Pt1000 temperature sensor. The active humidity
sensor may be fed by the same supply as the data logger. Both sensor outputs are connected via terminal or OVP to
individual differential analog voltage channels.
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Figure 13.7: Electrical Connection Plan: Analog Voltage (Potentiometric Wind Vane)

The figure above shows the 5-wire connection of a potentiometric wind vane. The intention of this configuration is to
avoid voltage drops on the measurement lines caused by wire resistance. The first analog voltage channel measures
the voltage across the whole potentiometer while the second channel measures the voltage between wiper and ground.
The configuration is supplied via current limiting resistor by a 5 V supply. All lines to the wind vane are connected via
terminal or OVP.
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Figure 13.8: Electrical Connection Plan: Analog Voltage with Voltage Divider (R1, R2)

The Meteo-40 plus data logger is designed to measure analog DC voltages from -10 V–10 V. This is sufficient for most
meteorological sensors. If voltages higher than +10 V occur, the voltage at the analog voltage inputs must be shared
by a voltage divider. Note that R2 is in parallel to the input impedance of the analog voltage channel (1 MΩ).
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Figure 13.9: Electrical Connection Plan: Analog Current (2-wire-connection), active

Meteo-40 plus includes analog current measurement inputs (AC) to measure DC currents up to 100 mA. Many me-
teorological sensors provide analog current outputs with 0–20 mA or 4–20 mA. The positive signal line has to be
connected to the A input. The negative line (or signal ground) has to be connected to the B input of the analog current
input. The figure above depicts the recommended setup using connections via terminal or OVP to the data logger.
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Figure 13.10: Electrical Connection Plan: Analog Voltage with Shunt

TheMeteo-40 plus data logger canmeasure DC currents up to 100 mA on its analog current inputs. This is sufficient for
most meteorological sensors. If currents higher than 100 mA are to be measured, a shunt can be used in conjunction
with the analog voltage inputs.
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Figure 13.11: Electrical Connection Plan: Pulse Counter (Anemometer)

Meteo-40 plus includes several impulse counter inputs (CNT). In most cases they are used for anemometer setup.
The signal output of the sensor has to be connected to the CNT input of the data logger. To avoid floating signals
common ground is used for the negative line of counter connection. The figure above depicts the recommended setup
using connections via terminal or OVP to the data logger.
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Figure 13.12: Electrical Connection Plan: Pulse Counter with Pull-up Module for Precipitation Measure-
ment

The counter inputs of the Meteo-40 plus data logger can be used for precipitation sensors. Most precipitation sensors
have open collector outputs or use a switching reed contact. In both cases an additional pull-up resistor has to be
applied. This pull-up resistor is tied to a 5 V supply to feed the sensor’s output. The module M83570 by Ammonit
has several configurable pull-up resistors and an internal 5 V supply. M83570 can easily be integrated in the setup of
a steel cabinet. The figure above shows the recommended setup using connections via terminal or OVP to the data
logger.
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Figure 13.13: Electrical Connection Plan: Digital Serial for Serial Wind Vane (Thies TMR)

The Digital Serial inputs of Meteo-40 plus data loggers are designed to connect sensors using serial communication.
The data logger sends a clock burst to the sensor via the CLK line. The response of the sensor is sent back to the data
input line (IN) of the Digital Serial panel. It is essential that sensor and data logger use the same common ground.
The figure above shows the recommended setup using connections via terminal or OVP to the data logger.
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Figure 13.14: Electrical Connection Plan: Status with Pull-down Module

In some cases an additional pull-down resistor may be required to equalise the electrical potential on the status signal
lines. This may be necessary to reduce perturbance caused by floating lines. The potential equalization can be
realized by an external resistor to GND or an external module M83570 provided by Ammonit. This external module
has pull down resistors for several signal lines.
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Figure 13.15: Electrical Connection Plan: Status for Obstacle Light

Many obstacle lights provide a diagnosis port to indicate malfunction. This diagnosis port can be connected to the IN
port of the Serial Digital panel. For a detailed description of the electrical characteristics of the interfaces see table in
Section 12.2.4. The figure above shows the recommended setup using connections via terminal or OVP to the data
logger.
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Figure 13.16: Electrical Connection Plan: RS485 with RS485 Module

In case of RS485 bus communication an additional biasing may be required. This can be done with the configura-
tion shown above. Ammonit provides the external Module M83570 which includes a configurable circuit for biasing
purposes. The M83570 module contains an internal voltage supply providing 5 V for biasing the RS485 bus lines.
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Figure 13.17: Electrical Connection Plan: Switch external Sensor Heating via Meteo-40 plus Switch Man-
ager

The configuration above displays the connection of an external sensor heating switched by the Meteo-40 plus heating
control.
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Chapter 14

Cryptographic Software

Ammonit uses certain standard cryptographic software to protect sensitive measurement data. None of the algorithms
are developed by Ammonit. All cryptographic software used on Meteo-40 plus is free software. Its source code is
available for everybody to study and check for security problems.

Currently the following is encrypted:

• Access to Meteo-40 plus via web interface over HTTPS with high-grade encryption using the RSA 2048 bit or Elliptic
Curve Cryptography (ECC) 256 bit key.

• All data sent and received via the Meteo-40 plus web interface, e.g. data download
• Data upload via SCP to AmmonitOR or your own server, using an RSA 2048 bit or Elliptic Curve Digital Signature
Algorithm (ECDSA) 256 bit key.

• Emails and attached CSV files sent by Meteo-40 plus (optional)
• Live data publishing to our or your own server, using the XMPP protocol with ECC 384 bit certificate

Note
There is no encryption, when data is uploaded via FTP to a server. Moreover, the data stored on Meteo-40
plus is not encrypted. But only computer specialists with inside knowledge could be able to access the
data.
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Software or Protocol Description Used Algorithms

HTTPS

All access to the user interface
of the data logger is done via
HTTPS, a combination of
HTTP with SSL/ TLS, as
implemented in OpenSSL.

RSA (2048 bits), ECC NIST
Curve P-256 (256 bits)

SSH

The connection to the
AmmonitConnect server (the
Ammonit one or any
AmmonitConnect server of
your choice) is performed with
an SSH reverse tunnel.

RSA (2048 bits), ECDSA NIST
Curve P-256 (256 bits)

OpenPGP (GnuPG)

The international standard
OpenPGP, specifically the
GnuPG implementation, is
used to digitally sign and
encrypt measurement data.

RSA (2048 bits), ECC NIST
Curve P-256 (256 bits)

XMPP

Meteo-40 plus live data can be
published to our server using
the XMPP, which is an open
communication protocol
designed for instant
messaging. The
communication is encrypted
using the TLS certificate.

ECC NIST Curve P-384 (384
bits)

Table 14.1: Cryptographic Software
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Chapter 15

Maintenance and Care

In order to ensure that Meteo-40 plus data loggers work properly, it is important that you maintain and handle the
device with care.

Important
If an error occurs and the Ammonit support team needs to be contacted, download the configuration file
(config-Dnnnnnn.txt in menu System→ Information) and send it with the error description to the Am-
monit Support support@ammonit.com.

15.1 Operation and Storage

The data logger can be affected by extreme temperature and humidity conditions. Meteo-40 plus is designed to operate
properly at temperatures between -40 and +65 °C in non-condensing environments. The display is readable between
-20 and +70 °C.

On site the data logger has to be installed in a robust and weatherproof cabinet (see also at www.ammonit.com
(http://www.ammonit.com/)). The cabinet protects the data logger against weather and condensation damage,
theft and vandalism. If humidity tolerance is exceeded and moisture penetrates, the electronics of Meteo-40 plus can
be damaged. Users are responsible for effective humidity control.

Handle Meteo-40 plus with care, do not drop it, and avoid mechanical shocks and vibrations to prevent the electronics
from being damaged. Do not open or break the Meteo-40 plus housing or any of the slots. Avoid permanent pressure
on the data logger.

To ensure that Meteo-40 plus operates properly, install only equipment, e.g. sensors, adapters and cables, which is
undamaged and approved by Ammonit. Contact Ammonit, if any questions occur.

15.2 Overvoltage / Lightning Protection

Ammonit offers lightning and overvoltage protection devices for DC and AC low-voltage supplies of components and
measuring systems, ensuring protection of data and signal lines and power cables. The surge protection cable clamp
is installed in the steel cabinet instead of a regular unprotected cable clamp. We offer several types of surge protection
devices, differing in number of pins and voltage levels. Although the installation of overvoltage protection devices is not
mandatory, we highly recommend installing them, as unprotected lightning can lead to a total breakdown of the entire
measuring system. Overvoltage protection is strongly advised at freestanding measuring stations or when aircraft
obstacle lights are applied.
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Chapter 16

Frequently Asked Questions

Find in this chapter a summary of frequently asked questions.

If you do not find the answer to your specific question in this chapter, contact the Ammonit support team.

16.1 Local Communication

Question Answer

The Meteo-40 plus display does not
show anything.

The display is switched off. Press the middle button of your data logger
and hold it until the display turns on. The display of Meteo-40 plus is
only illuminated, when CECS is running. During MARS operation, the
display is switched off. Refer to Chapter 9.
If the ambient temperature is below -20 °C, the crystals of the LCD may
be stuck.

I cannot configure Meteo-40 plus
using the buttons.

You do not have permission to configure the data logger with the
buttons on the Meteo-40 plus housing. See Section 9.1.

The red LED light is turned on.
What does it indicate?

It indicates that an error in the measuring operation occured. For
details see System→ Logbook in the web interface or System
→ Errors→ Error List in the display menu.

The yellow LED light blinks. What
does it indicate?

It indicates that at least one RS485 sensor is connected. According to
the Modbus protocol, the yellow LED light blinks, when a measurement
is taken.

I do not have an USB Ethernet
adapter available. How can I
connect Meteo-40 plus Revision C
to the LAN?

As Meteo-40 plus Revision C has no Ethernet port, an USB Ethernet
adapter is required. Use the USB Ethernet adapter included in the
delivery.
Meteo-40 plus Revision D data loggers are equipped with Ethernet port
and can be connected directly to the LAN - without any accessories.

Meteo-40 plus is connected to the
LAN. After entering the IP address
of Meteo-40 plus in my browser, I
receive an error message.

Check the following possibilities:
• The browser does not trust the TLS certificate supplied by the
Meteo-40 plus. See Section 2.3.

• The CECS is switched off. The web interface can only be accessed
when the CECS is on. See Section 1.4.

• Make sure the Meteo-40 plus and your PC are within the same LAN.
• A static IP address is configured, which does not exist in your current
LAN. If you have the permission, you can activate DHCP in the
display of Meteo-40 plus. Go to the Communication→ Devices
→ LAN→ eth menu and set Use DHCP to Yes (see Section 9.1. Or
connect the data logger via USB and change the LAN settings. See
Section 7.7.
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Question Answer
Meteo-40 plus is connected via
USB to a Windows PC but is not
recognized.

Download and install the required driver file. See Section 2.5.

Which cable I have to use to
connect Meteo-40 plus to my PC?

Use a standard USB-A+B cable, the same cable used to connect
printers or other devices.
Note that you might require a driver file for Meteo-40 plus (see above).
Ethernet also works if both ends are configured for link-local
connections.

16.2 Remote Communication

16.2.1 Modem

Question Answer

Modem USB connected but internet
(e.g. AmmonitConnect, email,
remote copy) is not working.

It is a common mistake to try to test the modem communication while
accessing the user interface locally via ethernet. With the default
configuration, the preferred connection in this case is the ethernet and,
if there is no internet access via ethernet, the data logger will not have
internet access. You can see in the status box: Connection:
ETHERNET, Modem (See Figure 3.2).
The recommended way to test the USB GSM modem is to disconnect
the ethernet cable and check the connection at the display menu
Communication (see Section 7.10) or via AmmonitConnect (see
Section 7.3).
You can always access the data logger user interface using the USB-B
cable, which doesn’t interfere with the modem communication.
If both the ethernet communication (for local access) and the modem
communication (for remote access) are needed, you must activate the
option Connect to Internet via modem only in Communication→ LAN
menu (see Section 7.7). This is usually the case with SCADA (Modbus
TCP).

After configuring and connecting
the Sierra Wireless FXT009
modem, the connection cannot be
established.

• Make sure the SIM card is not broken. The SIM card should be
inserted properly and the SIM card slot of the modem has to be
locked (see Section 7.9.6.1).

• Check the power supply of the modem. A small red light indicates
that the modem is running.

• Make sure that you configured the SIM card’s provider details in the
provider settings. Use the Provider helper (see Section 7.9.1), if you
are unsure. If your provider is not given in the list, ask your provider
for the details, i.e. APN, username and password.
We recommend double checking the provider details.

• Make sure that the used SIM card has not been locked by entering a
wrong PIN code. You can create a new PIN code via the Meteo-40
plus web interface; the PUK code is required.

• Make sure that you use a SIM card and contract which support
mobile Internet.

An Internet connection is always
established, when I switch on the
CECS of Meteo-40 plus. The
modem should only be online,
when data has to be sent.

Deselect the checkbox Modem online, when CECS is on in the
Communication→ Modem menu. Thus the modem only establishes an
online connection when an action (e.g. upload data, email data or
online availability) is scheduled.

230 © 2011 — 2023 Ammonit Measurement GmbH



Data Logger Meteo-40 Plus User’s Manual 231 / 258

Question Answer

I cannot connect to the data logger
via modem?

• Make sure the modem is switched on and running to perform the
scheduled actions. Did you configure a switch to toggle the modem?
If the modem is connected via relay to the data logger, a switch has
to be configured in the Communication→ Modem menu of the data
logger. S1 is set by default in the modem configuration.
It is not sufficient to toggle the switch manually, as it is not saved to
the data logger configuration. After rebooting the data logger or after
power supply interruptions, the modem will not start again. It remains
switched off. See also Section 7.9.

• If the modem is configured properly and you do not receive any
measurement data, it could be a problem with the modem. Are the
frequency bands configured correctly? Refer to Section 7.9.6.1.
We also recommend upgrading the data logger firmware regularly as
we continuously improve the software.

• If you receive measurement data, the signal might be too weak to set
up the Internet connection to access the data logger. In this case
refer to Section 16.2.2.

Tip
We recommend testing the modem functions before installa-
tion in the field, e.g. sending emails, uploading files and ac-
cessing the web interface via modem connection.

How do I connect a BGAN satellite
modem?

BGAN satellite modems are connected via Ethernet cable to Meteo-40
plus. If you are working with Meteo-40 plus Revision C with RS232 slot,
you need an USB Ethernet adapter to connect the modem.
In order to supply the satellite modem, a LAN switch has to be assigned
in the Communication→ LAN menu. Make sure that the checkbox LAN
online, whenever CECS is on is not selected. Hence, the modem goes
online only when needed. The modem itself has to be configured using
the software provided by its manufacturer. For further details refer to
Section 7.9.7 and especially to Section 7.9.7.3.

16.2.2 AmmonitConnect

Question Answer

I see the error ”Your data logger is
currently not connected to
AmmonitConnect.”.

• Your data logger is (currently) not connected to the Internet. Maybe
the data logger has not been configured to be online for this time.
Meteo-40 plus establishes an Internet connection for the periods
configured in the schedule (see Section 7.2).

Tip
If you use AmmonitOR to monitor your data logger, you can
check, when the data logger is scheduled to be online.

• The data logger is busy, e.g. performing an upgrade, uploading files.
Try again after a few minutes.

• Another user is logged in and is downloading data files. Try again
after a few minutes.
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Question Answer

The entered URL seems to be
wrong.

Make sure that the URL has the form
https://Dnnnnnn.connect.ammonit.com/, where Dnnnnnn
must be replaced with the serial number of the data logger without
spaces or hyphens.

I do not know the access code. Contact the Ammonit support team. The default access code is
”Ammonit”.

The data logger is sending /
uploading data, but I cannot
connect via AmmonitConnect.

The connection seems to be unstable. The issue can be solved as
follows:
• The GPRS connection might be very weak. Switch to GSM. Ask your
provider for the dial-in number (P-to-P). The dial-in Number has to be
configured in the Meteo-40 plus web interface in the Communication
→ Modem menu. An APN does not have to be entered. See also
Section 7.9.

• The signal might be very weak. Replace the installed antenna with a
Yagi directional antenna. The Yagi antenna can be aligned to a near
transmitting station to receive a better signal. For further details see
Wikipedia
(http://en.wikipedia.org/wiki/Yagi-Uda_antenna).

• Instead of using a standard SIM card with dynamic IP address, insert
a SIM card with public IP address into the modem. The data logger
can be accessed via its public IP address as well as
AmmonitConnect, if configured. See also Section 7.3.
If your data logger is registered in AmmonitOR, you can find its public
IP address in the Data Loggers→ Connections menu. Go with the
mouse pointer on a displayed connection in the graphic view or look
up the IP address in the text view.

16.3 Firmware Upgrade

Question Answer

Do I have to be on site to perform
an upgrade?

No, you can start the upgrade via remote access (tunnel connection),
e.g. when the data logger is scheduled to be online.
Nevertheless we recommend upgrading the data logger in the office to
avoid any unexpected difficulties.

The upgrade does not work, despite
of having an internet connection.

Check date and time of the data logger. If the data logger date and time
is too far in the past or in the future, the upgrade will not work.

My data logger is not connected to
the Internet; how can I perform an
upgrade?

In order to perform an upgrade, the data logger has to be connected to
the Internet.
By connecting your smartphone to the data logger, you can set up an
Internet connection via the tethering function of the smartphone.
Connect your smartphone to your Meteo-40 plus data logger via USB
(USB-A slot of the data logger and micro USB slot of the smartphone).
Open the settings for Tethering and portable hotspot of the smartphone
operating system (see Figure 4.15). Activate USB tethering.
Browse for the IP address of your Meteo-40 plus data logger using the
keys (Communication→ Devices→ LAN→ USB (Activated)→ IP
settings). Enter the data logger’s IP address in your smartphone
browser, login and perform the upgrade.
See also Section 4.3.3.

Do I have to install all upgrades?

We recommend installing all available upgrades to benefit from new
features and to fix recent problems.
Ammonit regularly informs Meteo-40 plus users about available
upgrades by email.
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Question Answer
During the download process the
connection was interrupted? Do I
have to restart the download
process?

The downloaded software packages are stored on the data logger.
Start the upgrade process again to continue the download and
installation process. Once downloaded packages do not have to be
downloaded again.

How does the installation process
affect the recording of the MARS?

If the MARS is not affected by the upgrade, the recording continues
without any interruption.
If the MARS will be upgraded, the recording stops for approx. 30s and
continues afterwards.

16.4 Data: Format, Transfer and Download

Question Answer

Which methods are available to
transfer data files?

• Upload data files via SCP/FTP/SFTP/FTPS connection to a server of
your choice or the AmmonitOR installation on your server (see
Section 7.6).

• Upload data files to your AmmonitOR account on the Ammonit server
(AmmonitOR project key is required, see Section 7.6).

• Sent data files to an email account (see Section 7.5).
• Manual download of CSV files via the Meteo-40 plus web interface.
• Manual download of CSV files on pre-configured USB flash drive on
site (see Section 4.4.3).

If no Internet connection is available
on site, can I download data files?

Yes, you can download the statistics and/or the source data using a
pre-configured USB flash drive. Switch on the data logger (CECS) and
plug in the prepared USB flash drive. All generated CSV files will
automatically be saved on the USB flash drive. See also Section 4.2.
You can also connect to the data logger via USB or W-LAN on site and
download the CSV files on your PC.

What happens to data files which
could not be sent or uploaded
according to the schedule time, e.g.
because of connection problems?

Files which have not been sent according to the scheduled time will be
sent or uploaded at the next scheduled action.

I receive data files with the file type
csv.gz? How do I handle these
files?

The file is compressed using GNU gzip (See Section 6.6) and has to be
decompressed before you can use it. If you work with Microsoft
Excel™, open the file as decribed in Section 6.6.3. If you work with
LibreOffice or OpenOffice, use the settings decribed in Section 6.6.2.

How can I open CSV files
generated by Meteo-40 plus with
Microsoft Excel?

In order to open CSV files with Microsoft Excel, the settings have to be
adapted. Launch Microsoft Excel and open the Options in menu File.
Under Advanced the decimal and thousands separators are defined.
Adapt the settings for Meteo-40 plus CSV files as follows, if necessary.
Decimal separator has to be a dot (.); thousands separator has to be a
comma (,). If necessary, deselect the function Use system separators.
CSV files generated by Meteo-40 plus data loggers use the comma (,)
as field separator, double quote (”) for embedding commas in textual
strings and UTF-8 as character set. These details have to be
considered, when data files are imported. In order to import CSV files,
click on From Text on the Data tab and browse for the CSV file. Follow
the instructions of the import wizard.
For further details refer to Section 6.6.3.

I have an AmmonitOR installation
on my own server. How can I
upload the data files to it?

Select in the Communication→ AmmonitOR menu of your Meteo-40
plus data logger for AmmonitOR server the value Custom AmmonitOR
and below under server the name or IP address of your server.

What does the date/time at the
beginning of each row of the CSV
file show?

The date and time value shows the start time of the statistics interval of
this row. Date and time format are similar to ISO-8601, e.g. 2014-07-17
15:50:00. The date and time values are always the local time of the
data logger. See also Section 6.6.
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16.5 Sensor: Configuration and Connection

16.5.1 Sensor Configuration

Question Answer

The sensor which I have to install is
not given in the sensor list. How do
I configure the sensor?

If the sensor is not given in the list, you can select Other Sensor in the
Sensor Helper and configure channels, slope and offset values,
measurement rate etc. manually.
If the anemometer you want to install is not listed in the Sensor Helper,
select Anemometer for the sensor type and Generic Anemometer for
the sensor. The other values have to be configured manually.
If the analog wind vane you want to install is not listed in the Sensor
Helper, select Wind Vane for the sensor type and Generic Analog Wind
Vane for the sensor. The other values have to be configured manually.

Important
Only for the sensors listed in the Sensor Helper, Ammonit as-
sures the correct calculation of the statistics!

If you are unsure how to configure an unlisted sensor, contact the
Ammonit support team.

I have a calibrated sensor. Where
do I enter the calibration values?

For each configured sensor you can modify the slope and offset values
in the Sensor Helper.

My configured pyranometer SPN1
does not display any estimated
value?

In order to estimate DNI and sun status, you have to enter the
geographic coordinates of the measurement station, i.e. latitude and
longitude. Both coordinates are important to get the zenith angle of the
sun at the site. Enter latitude and longitude in the System
→ Administration menu of your Meteo-40 plus data logger.

Why is the slope of a 10-bits digital
wind vane 0.3515625?

The slope of a 10-bits wind vane is always 360°/2¹�. Since version
2.1.7, you can change the value, but we recommend not to change it,
even if the calibration certificate shows a slightly different value.

Some statistics files have been
generated with incorrect
configuration, e.g. because a
sensor was replaced but the slope
and offset were not updated. How
do I regenerate the statistics?

In the Data→ Statistics menu, click ”Show month” and select the files
to be recreated. Click ”Download selected” first to make a backup.
Then click ”Delete selected” to remove the incorrect files. You may now
click ”Generate now” or wait for the next scheduled transfer action
which will automatically regenerate the statistics.

16.5.2 Sensor Connection

Question Answer

Where can I find a plan to connect
a sensor?

• If you ordered the measurement system including steel cabinet and
cables from Ammonit, connection plans can be found in the steel
cabinet. Additionally, the sensor connection with Ammonit cables is
described in the data sheet, which you received for each sensor
bought from Ammonit.

• If you ordered only the sensors without cables from Ammonit, refer to
the data sheet by the sensor’s manufacturer. In Chapter 13 you can
find the electrical connection plans for Meteo-40 plus.
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Question Answer

I have to install two potentiometric
wind vanes, a barometric pressure
sensor and a temperature humidity
sensor - all connected to analog
voltage channels. Which data
logger model is suitable?

The Meteo-40M model offers 8 analog voltage channels to connect two
potentiometric wind vanes, a barometric pressure sensor and a
temperature humidity sensor.
If digital wind vanes TMR would be installed, which require only one
digital channel each, the Meteo-40S model would be suitable, as well.

Note
Digital wind vanes TMR are more precise than potentiometric
wind vanes. Additionally, digital wind vanes TMR are sub-
ject to less mechanical wear than potentiometer wind vanes
thanks to their solid state design. Wind vanes TMR do not
have moving parts, except the bearings. Thus digital wind
vanes TMR are more reliable and less susceptible to failure.

16.6 Measurement

Question Answer

Sensors are configured and
connected, but the measurement is
not recorded?

Check the following options:
• It seems that the power supply during measurement was not
sufficient or has stopped. Thus MARS is turned off. Connect
Meteo-40 plus to a reliable power supply to turn MARS on.

• In the status box Recording is swiched off. Click Switch on in the
Meteo-40 plus web interface.

• The configuration has not been saved after the last modification.
Save the configuration and click Switch on for recording.

Where can I find the meteorological
data in m/s or °C?

The current value of each evaluation is displayed in the Measurement
→ Evaluation menu in the Meteo-40 plus web interface. Additionally,
you can display live data in the Data→ Live menu of the data logger.
In the CSV files you can find the evaluated meteorological data
according the the settings you made in the Data→ Statistics menu.
Furthermore, if you work with AmmonitOR, you can monitor the
meteorological data in your AmmonitOR project, e.g. in various plots for
selectable periods.

Where can I find the original
electrical measurement data?

The current electrical value of each channel is displayed in the
Measurement→ Channels menu of the Meteo-40 plus web interface.
Additionally, you can see the electrical values of all channels in the
Data→ Source menu.
In the source file, which can be downloaded in the Data→ Statistics
menu of the data logger, you can see all electrical values of all channels
for a selected period.

16.7 Errors and Messages

Question Answer

After saving a configuration or
starting an action, an Internal error
occured and is displayed in the web
interface?

Internal errors could have various reasons. Not always a serious error
occured, e.g. due to a short connection time out, an operation could
have been interrupted. Try the following actions to solve the problem:
• Go to another page and perform the action again.
• Restart the data logger and perform the action again.
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Question Answer

The red LED light is turned on.
What does it indicate?

It indicates that an error in the measuring operation occured. For
details see System→ Logbook in the web interface or System
→ Errors→ Error List in the display menu.

Important
If you should notice any error on your data logger or in the web interface, we kindly ask you to inform us as
soon as possible. The Meteo-40 plus data logger is a very complex system, so unfortunately it can happen
that errors occur. In order to avoid any disruption of the data logger operation, we need on your assistance.
In case of an error, please note down what have been done on the data logger before the error occured,
which system components are used, e.g. GSMmodem or satellite modem, and which system configuration
is active.
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Release Notes

Version 2.2.4 (2024-02-08)

• Run actions which are scheduled only once per week (previously these actions were erroneously skipped).
• Allow source data which begins with repeated config changes to be indexed correctly.
• Generate statistics files during sending actions even if the configuration is invalid.
• Show incoming live data access requests in the web interface.
• Rename POA irradiance to Effective irradiance evaluations, correct name for the formula applied.

Version 2.2.3 (2023-12-13)

• Allow measurement data with invalid timestamps to be indexed again (not working since 2.2.2).

Version 2.2.2 (2023-12-06)

• Output statistics with an appropriate number of decimal places for the measurement precision (in most cases 1 or 2
fewer).

• Allow the time zone to be changed without duplicating timestamps or creating artifical gaps.

Note
After the upgrade, manually restart the recording once, generate statistics and wait 24 hours before
changing the time zone.

• Add Effective Irradiance calculation in Evaluation Helper.
• Fix configuring ’Wind Vane Lambrecht wind Professional 14521’.
• Show progress on the display when copying statistics files to a USB flash drive (missing since 2.2.0).
• Fix wind direction calculation for upside down ultrasonic sensors.
• Add ”Disabled” Ethernet mode for reduced power consumption.
• Include more measurements in statistics files either side of configuration changes.
• Improved compatibility with GLONASS and Galileo GPS-like devices.

Version 2.2.1 (2023-10-27)

• Preserve user-submitted inputs when the Sensor Helper form is reloaded.
• Fix ’Silicon Irradiance Sensor M&T 2 x 0-10V’ implementation.
• Migrate average and standard deviation statistics for secondary and tertiary files.
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Version 2.2.0 (2023-10-18)

• Thies weather station is now supported in MODBUS protocol too (see Weather Stations).
• New pyranometer EKO MS-80SH.
• New pyranometer Hukseflux SR20-D2.
• New Anemometer Comptus A75-104CM.
• Remove 3 hour timeout from file upload and statistics generating actions. Uploads still time out after 20 seconds of
no data transfer, and there is still a midnight reboot if CECS is not always on.

• Fix erroneous adjustments in the ”Date and time set by NTP” logbook message.
• If an automatic NTP or GPS time synchronisation fails, it will be retried after 10 minutes instead of 6 hours.
• Improve reliability of start recording button.
• Add a ”Disable recording” button to the administration page.
• Add a ”stop_recording = yes” directive to the USB copy keyfile.
• Add ”Fetch data” button to the channels and evaluations pages in low traffic mode.
• Fix Thies RS485 wind vanes implementation.
• Enable the config save button whenever the config is not saved.
• Only mark statistics files as empty if they do not contain data.
• WLAN implemented in display menu.
• Make the remaining sensor names in the Sensor Helper consistent with the Ammonit website.

Version 2.1.13 (2023-08-01)

• Disable another erroneous ”Production failed: please contact the development department” logbook message.

Version 2.1.12 (2023-07-06)

• Ensure the wake-up time is updated when the system time is automatically synchronised.
• Handle time zone changes correctly when ”Method to set Date, Time and Location” is set to manual.
• Forbid empty values in required fields in the web UI.
• Prevent erroneous ”Ungraceful shutdown detected” messages.
• Improve the reliability of configuration changes when many sensors are configured.
• Fix Kintech Pressure K611PB implementation.
• Show the order number in the Sensor Helper model dropdown and add a disambiguation dropdown.
• Add ”Low traffic mode” checkbox to the login page.
• The height of evaluations configured by means of the Evaluation Helper can be customized.
• Fix Precipitation Monitor Thies Laser implementation.
• Recover missing sensor ’Temperature Humidity sensor Galltec active KPC T/H’ (missing since version 2.1.9).

Warning
The sensor ’Temperature Humidity sensor Galltec active KPC’ configured with version 2.1.9 to 2.1.11 is
equivalent to ’Temperature Humidity sensor Galltec active KPC H/T’

• Disable IPv6. Previously some LAN connections would use it but it wasn’t fully supported.
• Improve reliability of USB source data copy.

Version 2.1.11 (2023-05-26)

• Disable an erroneous ”Production failed: please contact the development department” logbook message.
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Version 2.1.10 (2023-05-16)

• Fix inconsistency in the source data indexing calculation introduced in 2.1.9. Any statistics files which were not
generated on version 2.1.9 will be generated after upgrading to 2.1.10.

Version 2.1.9 (2023-05-10)

• Add Thies status byte to CSV file for Thies Ultrasonic 2D and 3D (see Section 10.8).
• Soiling measurement formulas POA radiation and soiling ratio Isc can be used with any PV-module.
• Fix default voltage range for soiling Ampere Meter CM8281.
• Define albedo value constraints (see Section 5.3.1.3). Already existing albedo evaluations must be newly saved
after the upgrade in order to user the new formula.

• Improve the accuracy of system time synchronisation via GPS.
• Report system time adjustments larger than 25 days in the logbook accurately.
• New Thies hygro-thermo-presure sensor over analog channels.
• New Irradiance RSR3 pyranometer MODBUS sensor.
• Optimize CSV generation in case of automatically deleting oldest files.
• Add ”Verify server SSL/TLS certificates” checkbox to FTPS Remote Copy.
• Fix system storage information swapped in System Information UI overview.
• Include network connection traffic metering information in UI, display and CSV files.
• Remove remote maintenance Start and Stop buttons. The Allow manufacturer administration checkbox controls it
exclusively.

• Add power supply documentation to System Administration page.
• Add linear humidity and wind direction offset formulas to Evaluation Helper.
• Reduce maximum delay for RS485 sensors measurement recording in case that the measurement period is higher
than 1 s.

• Increase dedicated time for RS485 sensors request (see Section 11.6).
• Forbid commas, (semi-)colons and quotes in sensor labels to prevent CSV syntax errors.
• Reset default statistics when changing between different evaluation types (e.g. by changing sensor type).
• Fix scalar evaluations using a vector statistics formula and vice versa.

Warning
Any statistics files using the wrong formula will be marked as inconsistent with the check status ”Statistics
mismatch”. They must be manually deleted and regenerated after the upgrade.
This change breaks configuration file forwards compatability. Configuration files downloaded from sys-
tems with 2.1.9 and newer should not be uploaded to systems with 2.1.8 and older.

• New Wind Vane Vaisala WAV151 6 Bits Gray code.
• Fix the implementation of Pyranometer Hukseflux SR20-T1.
• Make the sensor names in the Sensor Helper consistent with the Ammonit website.

Version 2.1.8 (2023-01-19)

• New net radiation formula in evaluation helper (see Section 5.3.1.11).
• Send the correct timestamp in the live data publisher JSON.
• Reset automatic shutdown timer during USB-copy and include sourcedata from 2.1.7 correctly.
• Allow changing all parameters of evaluations created by Evaluation Helper.
• Solar irradiance summary available over SCADA and in CSV file footer.
• Do not show errors in the logbook when AmmonitOR or email are not configured.

Version 2.1.7 (2022-12-16)

• Add support for G-STAR GPS-dongle.
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• New Lufft WS601 weather station sensor.
• New Lufft WTB100 external rain gauge.
• New LSI Lastem DNB201 weather station sensor.
• New Thies hygro-thermo-presure sensor over RS485 (see Table 10.15.
• Fix implementation of Kintech K308TH Thermo-Hygro.
• Handle evaluations with absent dependencies correctly.
• Improve reliability of USB source data copy and skip files which were already copied.
• Show SMS messages received by the modem in new page of the web UI.
• Fix SCADA register mapping (broken in 2.1.6).
• Add wind direction installation offset.
• Thies digital wind vanes slope can be changed over web UI.
• Live data publisher now purges and deletes the nodes when changing servers or turning off publishing.
• Live data publisher conditionally allows publishing to the public nodes, where the data is publicly avaliable.

Version 2.1.6 (2022-11-11)

• Fix NTP time adjustments when the clock is fast. In 2.1.5, the adjustment only works when the clock is slow.
• New Navis wind vane WSS 100 with shunt resistor.
• Fix memory leak with RS485 channels of type ”modbus other”.
• Fix live data publisher.
• Improve resilience to temporary issues with excessive recording speed.
• Summary values can be obtained via SCADA.
• Preserve passwords and PINs when uploading configuration files unless manually entered.
• Add band restrictions selector to the ”Communication > Modem” page.
• Characters : * \ ” and ’ are no longer accepted as sensor, evaluation and switches label.
• Fix evaluation types for pyranometers with more than one evaluation, e.g. Delta-T Sunshine Pyranometer SPN1.
• Delay network and AmmonitConnect configuration changes to avoid disconnecting before the browser receives the
response.

• WhenOpenPGP encryption is activated, encrypt statistics in zip files, and allow users with permission User or Viewer
download them.

• Fix schedule page in the web UI on small devices.
• Adopt current Modbus terminology: use client/server instead of master/slave.

Version 2.1.5 (2022-08-18)

• Ensure that the display is usable every time the CECS boots.
• New Kintech sensors: K360V winvane, K308TH Thermo-Hygro, and K611PB barometer.
• Prevent NTP time adjustments if the server is behaving inconsistently.
• Check that each evaluation of a given type has a unique label, and that an Admin is active, when uploading config-
uration files.

• Show a warning when logging in if there are new errors in the logbook.
• Revert the names of internal channels to V, I and T for the CSV data snapshot (they were changed in 2.1.4).

Version 2.1.4 (2022-07-22)

• Fix display of longitude on the ”System > Information” page.
• Show more information about running actions in the web interface.
• Add weekly overview of source data to the web interface.
• Remove switch (pretime) settings from Sensor Helper which were not working correctly.
• Allow a longer time for the modem to connect before abandoning file transfers.
• Show more information about the modem in the web interface and remove incorrect warnings.
• Add a button to manually ignore warnings about possibly inconsistent CSVs.
• Add ”Remote Copy” methods for SCP and SFTP with password. The original methods now use the SSH key only.
• Add TLS client certificate support to live data publisher.
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• Add menus to the display to send test files.
• Show the origin channel of evaluations on the display.
• Add a dropdown to choose between global and diffuse irradiance for pyranometers.
• Fix creating CSV files when the clock is set to 1st Jan 2000 or after the year 2050.
• Recording can only be started if at least one sensor is configured.
• Fix the live data page if the sensor label contains special characters.
• Check that user names are unique when uploading config files.
• Change separator for fractional seconds from ”:” to ”.” in evaluated source data.
• New Thies barometer sensor 0..5V.

Version 2.1.3 (2022-07-07)

• Add support for counter ICs with new specification. There is no need to upgrade existing devices to this release.

Version 2.1.1 (2022-04-08)

• Add a minimal_value variable for linear wind speed calculations, which is used when the counter measurement
channel records zero. This is equal to the offset by default. See Equation 5.1 for more information.

• Fix offline USB-Upgrade ”Error (5) Could not read environment”. This version or later must be installed via the
internet in order to use future USB-Upgrades.

• Fix GPS with certain modems, such as the PLS8. Include GPS response in the KML file.
• Fix Switch Manager timer as sufficient condition.
• Improve web-UI status box accuracy.
• Fix toggling Switch 1 via the display.
• Estimated DHI value is 0 instead of NAN between sunset and sunrise.
• New SYCBA Monitor over RS485.
• Always include data snapshot in EMail body text.
• Record a message in the logbook when CSV files could not be generated or are manually deleted.
• Show number of statistics files on the ”System > Information” page.
• Show the same hints when changing sensors as when adding them.

Version 2.1.0 (2022-02-02)

• Live data can now be published via XMPP. See Section 6.2 for more information.
• If the ”Delete all measurement data” process is interrupted, it will now be resumed.
• Fix uploads to AmmonitOR when ”Sign and encrypt data (OpenPGP)” is selected.
• Embed signature in encrypted files so that they are compatible with Ammonit Verify.
• Avoid sending incomplete logbook files more reliably when ”Yes” is selected.
• Show more information about inconsistent statistics files.
• Show progress of statistic file generation.
• More feedback when triggering actions on the display.
• Warn about invalid directories configured for Remote Copy.
• Shrink ”Order No.” column on the sensor list.
• Fix non-functional ”Download week” button in Source Data view.
• Ensure information displayed in the web UI status box is up-to-date.
• New turbulence intensity (TI) formula, rename the existing formula to longitudinal TI.
• Request MS-90+ altitude and azimuth every second.

Version 2.0.14 (2021-10-28)

• Fix MS-90+ implementation.
• Increased robustness against invalid configuration files upload.
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• Ensure that cross-signed TLS certificates are accepted when one signature has expired e.g. for SFTP with letsen-
crypt.

Version 2.0.13 (2021-10-20)

• Improve system stability when generating many statistics files with high-frequency RS485 sensors configured.
• New pyranometer EKO MS-60 S over RS485.
• Request coordinates for EKO MS-90+ on every CECS reboot.
• Fix ’Thies FCA X - Counter’ statistics calculation.
• Allow switch manager to be disabled by setting the ”Managed switch” to none.
• Improve reliability of copying files to USB flash drives and show progress on the LCD.
• Fix error page when saving USB passphrase.
• Hide prompt to view manual when entering the wrong password.
• Add Japanese language support.

Version 2.0.12 (2021-08-23)

• Fix unrelated sensors being removed when a sensor is deleted.

Version 2.0.11 (2021-08-17)

• Improved robustness against RS485 data corruption for ASCII protocols.
• Improved memory usage for CSV generation with ’Thies Clima Sensor US’.
• New NRG PB60 pressure sensor.
• New NRG T60 temperature sensor.
• New WDS 100 4..20 mA wind vane.
• Fix DHI formula in Evaluation helper.
• Fix statistics calculation for ’Thies FCA X - ASCII’ and ’Vaisala WMT700 NMEA’.

Warning
You must delete and regenerate older files to correctly perform the statistics calculation.

• Deleting a sensor no longer deletes other sensors with the same label.
• The option ”Behaviour if file limit is reached” now prevents re-creating deleted statistics when there is low storage
space.

• Improve handling of non-ASCII characters on the display.
• Ensure that only completed logbook files are sent when ”Yes” is selected.
• Show beta status of software on update.
• Prevent auto shutdown during upgrade more reliably.

Version 2.0.10 (2021-07-12)

• Improve reliability of manufacturer administration procedure.
• The option ”Behaviour if file limit is reached” now deletes files when there is low storage space.

Version 2.0.9 (2021-07-08)

• Reconnect to AmmonitConnect more quickly when settings are changed.
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• Show live data in the configured time zone in the web interface, not in UTC.
• Update settings immediately when changed on the display.
• Restore ability to set the clock pin for digital channels on the display.
• Add modem signal quality graphic to display.
• Smoother page transitions on the display.
• New EKO MS-80 S over RS485.
• New EKO MS-90+ over RS485 (C-Box).
• New Kintech Geovane over RS485.
• Fix Lufft WS 600 implementation.
• Fix DustIQ with temperature implementation.
• Fix EKO MS-80 S 4-20 mA.

Version 2.0.8 (2021-06-14)

• New DustIQ with temperature measurement.
• New Lufft WS 600.
• New EKO MS-80 S analog.
• New Generic Voltage Wind Vane with slope and offset input fields.
• New Thies FCA X - Counter.
• Fix Lufft WS 502 implementation.
• Fix generate new CSV file after configuration change.
• Show additional sensor details in the web interface.
• Record config file uploads in the logbook.
• Add connectivity timeout to file sending actions.
• Ensure username/ password completion prompts only appear where necessary in the web interface.
• Indicate table sorting in the web interface.

Version 2.0.7 (2021-05-20)

• Fix issue where incomplete attachments were sent via EMail. Only attachments from EMails sent directly from
the data logger are affected. Remote Copy, AmmonitOR upload, EMails from AmmonitOR and USB Copy are not
affected.

Version 2.0.6 (2021-05-20)

• Fix secondary CSV files statistics interval.
• Fix problem generating CSV files if RS485 sensors configured.
• Respect display user permissions.
• Data snapshots sent to AmmonitOR now display correctly.
• Represent data values on the display and in the UI with the same precision as in the data files.
• Add ”Minimal offset for automatic time adjustments” field to System Administration page, so that small time adjust-
ments can be ignored.

• New Kintech Geovane analog connection.
• Fix visualise Data Live menu if an RS485 sensor is not answering.
• Fix endianness for Galltec Thermo-Hygro KPC MS

Version 2.0.5 (2021-03-24)

• GPS dongle is supported again.
• Fix Analog Current AC1 channel missing for Meteo-40S Plus statistics files. Please re-generate affected files after
upgrade. Meteo-40M Plus and Meteo-40L Plus are not affected.

• Enable changing CECS Power Mode on the display between Always On andWhen Needed.
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• Ensure the display stays on when in use.
• Use more descriptive modem names on the display.
• Show modem signal quality and operator name in the web interface.
• Add page to check connection to AmmonitConnect and AmmonitOR on the display.
• Speed improvements in the Web Interface.
• Fix combination of ”Connect to internet via USB modem only” checkbox and Static IP.
• Apply correct netmask with Static IP.
• New Wildlife Acoustics SM4BAT FS in Sensor Helper.

Version 2.0.4 (2021-02-16)

• Add option to store live data in SCADA holding registers.
• Report current LAN and Modem status more reliably on the display.
• Show state more reliably on the Switches page.
• Fix rounding error related to negative integers in the web interface and CSV files.

Version 2.0.3 (2021-02-01)

• Add required Modbus unit id for SCADA Modbus TCP server.
• Add SCADA holding registers to set date/time and switches state.
• Fix graphical issue below footer affecting Chrome 87+.
• Improve responsiveness of modem, sensor and evaluation configuration pages.
• Add option to enable server SSL/TLS certificate verification when sending e-mails.
• Send e-mails more reliably with certain configurations.
• Sort evaluations correctly and always show their values on the display.
• Fix display digital channels.
• Improve display modem page stability and show signal quality.
• Fix display IP subnet mask representation.
• Show more decimal values for measurements on the display.
• Fix decimal values being accepted in certain fields (such as ”Installation height”).
• Improve responsiveness of the Switches page.

Version 2.0.2 (2020-12-15)

• Fix placeholder notification text and automatic status updates on the Modem configuration page.
• Fix missing rows from manual full-day source data downloads.
• Fix ordering of messages in the logbook related to CECS start-up.

Version 2.0.1 (2020-11-26)

• Fix RS485 sensors measurement data excluded from CSV files.

Note
If there exist older CSV files without measurement data for RS485 sensors, they must be removed and
regenerated with the new version.

• Fix selected statistics reverting to the default when a sensor is reconfigured in the UI.
• Only show five decimal values in the UI.
• Fix ”Good-bye” message shown on display while booting.
• Fix driver problem with RS485 S/M (SCADA).
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• Chinese translation completed.
• Only send configuration file if the config was changed.
• Some missing communication menus added to the display.
• Fix tertiary statistics generation.
• Fix download statistics CSV files as ZIP.

Version 2.0.0 (2020-10-30)

• More modems are supported, esp. with support for LTE (4G): PLS8-E, MC89LTE, FX30S, and GL7600.
• TLS 1.1, 1.2, and 1.3 are supported now, which makes Meteo-40 plus plus compatible with more web browsers and
more SMTP servers.

• User management has been added to the web interface: Admin user can create new users or delete them. Prede-
fined users can be deleted.

• The tunnel has been replacedwith AmmonitConnect. The newURL is https://<serialnumber>.connect.ammonit.com/.
• The SCADA Meteo-32 stream protocol is not supported anymore.
• Fetching of historical data over SCADA is not supported anymore.
• Holding registers are not yet supported for SCADA.
• Modbus RTU and TCP are much faster now.
• Remote Copy supports FTPS now.

Known Problems

Although Meteo-40 plus plus has been released for measurement campaigns, errors can occur. Please find below a
list of known problems. We will fix the problems as soon as possible.

• Wi-Fi stick TL-WN321G does not work
• Chinese translation is still incomplete

Older releases

For older release notes from version 1.0 (2011) to 1.7.x (2020), please refer to Data Logger Meteo-40 plus User’s
Manual.
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GNU General Public License

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the
GNU General Public License is intended to guarantee your freedom to share and change free software - to make sure
the software is free for all its users. This General Public License applies to most of the Free Software Foundation’s
software and to any other program whose authors commit to using it. (Some other Free Software Foundation software
is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed
to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish),
that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new
free programs; and that you know you can do these things.

To protect your rights, we need tomake restrictions that forbid anyone to deny you these rights or to ask you to surrender
the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if
you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all
the rights that you have. You must make sure that they, too, receive or can get the source code. And you must show
them these terms so they know their rights.

We protect your rights with two steps:

1. copyright the software, and

2. offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author’s protection and ours, we want to make certain that everyone understands that there is no
warranty for this free software. If the software is modified by someone else and passed on, we want its recipients to
know that what they have is not the original, so that any problems introduced by others will not reflect on the original
authors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors
of a free program will individually obtain patent licenses, in effect making the program proprietary. To prevent this, we
have made it clear that any patent must be licensed for everyone’s free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

TERMSANDCONDITIONSFORCOPYING, DISTRIBUTIONANDMOD-
IFICATION

Section 0

This License applies to any program or other work which contains a notice placed by the copyright holder saying it
may be distributed under the terms of this General Public License. The “Program”, below, refers to any such program
or work, and a “work based on the Program” means either the Program or any derivative work under copyright law:
that is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated
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into another language. (Hereinafter, translation is included without limitation in the term “modification”.) Each licensee
is addressed as “you”.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope.
The act of running the Program is not restricted, and the output from the Program is covered only if its contents
constitute a work based on the Program (independent of having been made by running the Program). Whether that is
true depends on what the Program does.

Section 1

You may copy and distribute verbatim copies of the Program’s source code as you receive it, in any medium, provided
that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of
warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other
recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection
in exchange for a fee.

Section 2

You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program,
and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet
all of these conditions:

a. You must cause the modified files to carry prominent notices stating that you changed the files and the date of
any change.

b. You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the
Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this
License.

c. If the modified program normally reads commands interactively when run, you must cause it, when started
running for such interactive use in the most ordinary way, to print or display an announcement including an
appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty)
and that users may redistribute the program under these conditions, and telling the user how to view a copy of
this License. (Exception: If the Program itself is interactive but does not normally print such an announcement,
your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from
the Program, and can be reasonably considered independent and separate works in themselves, then this License,
and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the
same sections as part of a whole which is a work based on the Program, the distribution of the whole must be on the
terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every
part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the
intent is to exercise the right to control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on
the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this
License.

Section 3

You may copy and distribute the Program (or a work based on it, under Section 2 in object code or executable form
under the terms of Sections 1 and 2 above provided that you also do one of the following:

a. Accompany it with the complete corresponding machine-readable source code, which must be distributed under
the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,
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b. Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than
your cost of physically performing source distribution, a complete machine-readable copy of the corresponding
source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for
software interchange; or,

c. Accompany it with the information you received as to the offer to distribute corresponding source code. (This
alternative is allowed only for noncommercial distribution and only if you received the program in object code or
executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable
work, complete source code means all the source code for all modules it contains, plus any associated interface
definition files, plus the scripts used to control compilation and installation of the executable. However, as a special
exception, the source code distributed need not include anything that is normally distributed (in either source or binary
form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs,
unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering
equivalent access to copy the source code from the same place counts as distribution of the source code, even though
third parties are not compelled to copy the source along with the object code.

Section 4

You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any
attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your
rights under this License. However, parties who have received copies, or rights, from you under this License will not
have their licenses terminated so long as such parties remain in full compliance.

Section 5

You are not required to accept this License, since you have not signed it. However, nothing else grants you permission
to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this
License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your
acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program
or works based on it.

Section 6

Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a
license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You
may not impose any further restrictions on the recipients’ exercise of the rights granted herein. You are not responsible
for enforcing compliance by third parties to this License.

Section 7

If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to
patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the
conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to
satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence
you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution
of the Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy
both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the
section is intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest
validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution
system, which is implemented by public license practices. Many people have made generous contributions to the wide
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range of software distributed through that system in reliance on consistent application of that system; it is up to the
author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot
impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

Section 8

If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted in-
terfaces, the original copyright holder who places the Program under this License may add an explicit geographical
distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus
excluded. In such case, this License incorporates the limitation as if written in the body of this License.

Section 9

The Free Software Foundation may publish revised and/or new versions of the General Public License from time to
time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems
or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which
applies to it and “any later version”, you have the option of following the terms and conditions either of that version or
of any later version published by the Free Software Foundation. If the Program does not specify a version number of
this License, you may choose any version ever published by the Free Software Foundation.

Section 10

If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different,
write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to
the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals
of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software
generally.

NO WARRANTY Section 11

BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM,
TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE
COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM “AS IS” WITHOUTWARRANTY OF
ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY
AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU
ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

Section 12

IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT
HOLDER, OR ANYOTHER PARTYWHOMAYMODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED
ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSE-
QUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT
NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU
OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN
IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS
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How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve
this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most
effectively convey the exclusion of warranty; and each file should have at least the “copyright” line and a pointer to
where the full notice is found.

<one line to give the program’s name and a brief idea of what it does.> Copyright (C) <year> <name of author>

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public
License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later
version.

This program is distributed in the hope that it will be useful, but WITHOUT ANYWARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNUGeneral Public License
for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free
Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author Gnomovision comes with ABSOLUTELYNOWARRANTY;
for details type “show w”. This is free software, and you are welcome to redistribute it under certain conditions; type
“show c” for details.

The hypothetical commands “show w” and “show c” should show the appropriate parts of the General Public License.
Of course, the commands you use may be called something other than “show w” and “show c”; they could even be
mouse-clicks or menu items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a “copyright disclaimer”
for the program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the program “Gnomovision” (which makes passes at compil-
ers) written by James Hacker.

<signature of Ty Coon>, 1 April 1989 Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is
a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is
what you want to do, use the GNU Library General Public License instead of this License.
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Chapter 17

Glossary

APN
Access Point Name

CDMA
Code Division Multiple Access

CECS
Configuration, Evaluation, and Communication System

CPV
Concentrated Photovoltaics

CSP
Concentrated Solar Power

CSV
Comma Separated Values

DHCP
Dynamic Host Configuration Protocol

DHI
Diffuse Horizontal Irradiation

DNI
Direct Normal Irradiation

DNS
Domain Name System

FTP
File Transfer Protocol

FTPS
FTP Secure (using TLS/SSL)

GHI
Global Horizontal Irradiation

GIS
Geographic Information System

GNU
GNU’s Not Unix

GnuPG
GNU Privacy Guard

GPL
General Public License
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GPRS
General Packet Radio Service

GPS
Global Positioning System

GSM
Global System for Mobile communications

GTI
Global Tilted Irradiation

HTTP
HyperText Transfer Protocol

HTTPS
HTTP Secure

IEEE
Institute of Electrical and Electronics Engineers

IP
Internet Protocol

JID
Jabber Id, an XMPP address

LAN
Local Area Network

LCD
Liquid Crystal Display

LED
Light-emitting diode

LGPL
Lesser General Public License

MARS
Measurement And Recording System

NTP
Network Time Protocol

OVP
Overvoltage Protection

PIN
Personal Identification Number

POA
Plane of Array

POT
Potentiometer - Measurement principle, e.g. Wind vane POT

PPP
Point-to-point protocol

PUK
PIN Unlock Key (or Personal Unblocking Code, PUC)

PV
Photovoltaic

RNDIS
Remote Network Driver Interface Specification

SCADA
Supervisory Control and Data Acquisition

SCP
Secure Copy Protocol/Program (using SSH)
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SFTP

Secure FTP (using SSH)

SIM

Subscriber Identity Module

SMS

Short Message Service

SMSC

Short Message Service Center

SSH

Secure Shell

SSL

Secure Sockets Layer

TCP/IP

Transmission Control Protocol/Internet Protocol

TLS

Transport Layer Security

TMR

Tunnel Magnetoresistance - Measurement principle, e.g. Wind vane TMR

UMTS

Universal Mobile Telecommunications System

USB

Universal Serial Bus

W-LAN

Wireless Local Area Network

WMO

World Meteorological Organization

XMPP

Extensible Messaging and Presence Protocol (originally named Jabber)
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Index

A
Access Point Name, 119
Access Rights, 25, 139

Admin, 25
Guest, 25
User, 25
Viewer, 25

Accessing Meteo-40 plus
Ethernet, 9, 14
LAN, 9, 12
USB, 9, 19

Addition, 60
Admin, 25
Air density evaluation, 61
Albedo, 62
AmmonitConnect, 95
AmmonitOR, 91, 95, 99
Ampere meter, 62
Analog Current, 193
Analog Voltage, 189
Anemometers, 55, 150
APN, 119

B
Barometric Pressure Sensors, 166
BGAN, 128, 129
Bonjour Print Services, 12

C
Camera, 46
Cascading, 138
CECS, 4, 5, 31, 131, 140
Change Passwords, 31
Channels, 59

Analog Current, 141, 193
Analog Voltage, 141
Counter, 141, 190
Digital, 141, 191
Period Measurement, 190
RS485, 194
Status, 141, 191

Communication
Ethernet, 9, 14, 144
LAN, 9, 12, 91, 144
Modem, 91, 119, 144
Satellite Modem, 91, 119, 128
Recommended Settings, 129

USB, 9, 19, 91, 144
W-LAN, 144
WLAN, 91, 118

Communication Configuration, 93
Communication Methods, 7
Communication Schedule, 93
Configuration

Access Point Name, 122
Email Parameters, 102
LAN, 116
Modem, 119
Online Access, 95
WLAN, 118

Configuration File, 29
Download, 29
Format, 29
Upload, 29

Configuration Status, 26
Connection Plans, 207
Connection Status, 26
Cookie, 14, 22
Counter Channels, 190
Cryptographic Software, 225
CSV File, 70, 77, 81, 82

D
Data Evaluation, 59, 69
Data Logger Name, 31
Data Retrieval

LAN, 7
Modbus RTU, 7
Modbus TCP/IP, 7
Modem, 7
USB, 7
WLAN, 7

Data Storage, 6
Data Transmission, 91
Debian, 23
Delete Measurement Data, 31, 39
DHCP, 9, 12, 14, 116
Differential temperature evaluation, 62
Diffuse solar irradiance, 67
Digital Channels, 191
Digital Wind Vanes, 155, 157
Display, 42, 139
Division, 63
Driver, 19
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Dynamic IP Address, 95, 116, 120, 122

E
ECC, 225, 226
ECDSA, 225
Effective irradiance, 63
Electrical Characteristics, 200
Email, 91, 102
Email Attachments, 102
Encryption, 225

Force Encryption, 37
Error List, 140
Ethernet, 144
Evaluation, 59

F
Factory Reset, 31, 39
FAQ, 229
File Interval, 70, 73
File Upload, 91

FTP, 113
SCP, 113
SFTP, 113

FileZilla
FTP server, 116

FTP, 91, 113
active mode, 114
passive mode, 114

FXT009, 125

G
Generic Modbus RTU sensors, 185
Generic Sensors

Modbus RTU, 185
Gill Ultrasonic Sensors, 161
Global Control Elements, 26
GnuPG, 104, 226
GPS, 31
Guest, 25
Gust Data, 76

H
HTTPS, 226
Humidity Sensors, 164

I
IEEE 754, 136
Import CSV Files, 81, 82
Inflow angle evaluation, 64
INI File, 29
Ini File, 77
Input Channels, 2
Internet Explorer, ii
IP Address, 116, 144

J
JavaScript, 14

L
LAN, 7, 12, 91, 116, 144
Laser Precipitation Monitors, 175
LED Lights, 139
LibreOffice Calc, 81

Linear equation, 64
link-local, 14
Linux, ii, 4, 23
Live Data, 69
Location, 31
Logbook, 51
Login, 25
Lufft Ultrasonic Sensors, 160

M
Maintenance, 227
MARS, 4
Measurement Values, 59
Memory, 2, 140
Menu

Display, 140
Web Interface, 27

Microsoft Excel 2010, 82, 87
Modbus, 133
Modbus Register Map, 133
Modbus RTU, 7, 131
Modbus TCP/IP, 7, 131
Modem, 7, 91, 119, 140, 144, 207

FXT009, 125
Mozilla Firefox, ii, 12, 22
Multiplication, 65

N
Net radiation total, 64
NTP Server, 31

O
Obukhov length evaluation, 66
Obukhov stability parameter evaluation, 66
Online Period, 95
OpenOffice Calc, 81
OpenPGP, 36, 104, 226
OpenSSL, 226
Output Channels, 2
Overvoltage Protection, 227

P
Period Measurement, 190
Photos, 102
Point-to-Point Ethernet Connection, 14
POP Server, 102
Potentiometric Wind Vanes, 156
Power Meters

RS485 Sensors, 177
Power Supply, 2
Precipitation Sensors, 174, 175
Provider Helper, 122
Pyranometers, 55, 168
Pyrgeometer incoming long wave irradiance, 64

R
Rain Gauge, 174
Recording, 26, 54, 140
Register Map, 131
Release Notes, 237
Research Applications, 150
Restart Data Logger, 39
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RNDIS USB Driver, 19
Rotating Shadowband Irradiometer, 173
RS485, 194

Wind Vanes, 157
RS485 S, 131
RS485 Serial Interface, 57
RSA, 225, 226

S
SCADA, 5, 7, 131

Configuration, 131
SCP, 91, 113, 225
Security

Force Encryption, 37
Sensible heat flux evaluation, 66
Sensitivity, 168
Sensor Configuration, 53
Sensor Helper, 55
Sensor Settings, 55, 57
Sensors

Anemometers, 55, 150
Barometric Pressure Sensors, 166
Humidity Sensors, 164
Modbus RTU Sensors, 185
Precipitation Sensors, 174, 175
Pyranometers, 168, 171
Research Applications, 150
Rotating Shadowband Irradiometer, 173
RS485 Sensors, 177
SG1000 Lightning Detector, 179
Soil Water Content, EC and Temperatur sensors,

180
Soiling Measurement, 181
Solar Trackers, 173
Song Meter SM3BAT/SM4BAT, 178
Temperature Sensors, 164
Ultrasonic Sensors, 159–161
Wind Vanes, 55, 155, 156
ZephIR 300, 177

SFTP, 91, 113
SG1000 Lightning Detector, 179
Sierra Wireless, 125
SIM Card, 95, 125
Sineax CAM Measuring Unit, 177
SMTP Server, 102
Soil Water Content, EC and Temperature sensors, 180
Soiling Measurement, 181
Solar Trackers, 173
Solar zenith angle, 66
Song Meter SM3BAT/SM4BAT, 178
Source Data, 87
SSH, 226
Static IP Address, 95, 116, 118, 120, 124
Statistics, 70

Configuration, 70
Statistics Interval, 70, 73
Status (Channel), 191
Status Box, 26, 140
Storage Size, 2, 140
Subdomain, 95
Switch, 48

Configuration, 48

Switch Manager, 48
Switch Manager, 48
Switches, 196
System

CECS, 4, 131
MARS, 4

System Administration, 31
System Information, 29

T
Technical Data, 199
Temperature Humidity Sensors, 164
Temperature Sensors, 164
Tethering, 7
Thies Ultrasonic Sensors, 160
Total apparent power, 67
Tunnel, 91
Tunnel Server, 95
Turbulence intensity, 65

U
Ubuntu, 23
Ultrasonics, 194

Gill Sensors, 161
Lufft Sensors, 160
Thies Sensors, 160

Upgrade Data Logger Software, 39
USB, 7, 19, 91, 144
USB Flash Drive, 43
User, 25
User Interface, 6

V
Viewer, 25

W
W-LAN, 144
Web Interface Menu, 27
Webcam, 46
WiFi, 118
Wind Vanes, 55, 155, 156

Digital, 155, 157
Potentiometer, 156
RS485, 157
TMR, 155

Windows, ii, 12, 14, 19
WLAN, 7, 91, 118

X
XMPP, 226

Z
ZephIR 300, 177
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